~ubuntu-branches/ubuntu/vivid/virtualbox-ose/vivid

« back to all changes in this revision

Viewing changes to debian/patches/12-make-module.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Felix Geyer
  • Date: 2009-10-13 23:06:00 UTC
  • mfrom: (0.3.2 upstream) (0.1.12 sid)
  • Revision ID: james.westby@ubuntu.com-20091013230600-xhu2pwizq0wo63l9
Tags: 3.0.8-dfsg-1ubuntu1
* Merge from debian unstable (LP: #444812), remaining changes:
  - Enable DKMS support on virtualbox host and guest modules (LP: #267097)
    - Drop virtualbox-ose{-guest,}-modules-* package templates
    - Recommend *-source instead of *-modules packages
    - Replace error messages related to missing/mismatched
      kernel module accordingly
  - Autoload kernel module
    - LOAD_VBOXDRV_MODULE=1 in virtualbox-ose.default
  - Disable update action
    - patches/u01-disable-update-action.dpatch
  - Virtualbox should go in Accessories, not in System tools (LP: #288590)
    - virtualbox-ose-qt.files/virtualbox-ose.desktop
  - Add apport hook
    - virtualbox-ose.files/source_virtualbox-ose.py
    - virtualbox-ose.install
  - Add launchpad integration
    - control
    - lpi-bug.xpm
    - patches/u02-lp-integration.dpatch
* Try to remove existing dkms modules before adding the new modules
  (LP: #434503)
  - debian/virtualbox-ose-source.postinst
  - debian/virtualbox-ose-guest-source.postinst
* Don't fail if dkms modules have already been removed
  - debian/virtualbox-ose-source.prerm
  - debian/virtualbox-ose-guest-source.prerm

Show diffs side-by-side

added added

removed removed

Lines of Context:
4
4
## DP: Fix ARCH setting in modules Makefiles
5
5
 
6
6
@DPATCH@
7
 
 
8
 
diff -Naurp virtualbox-ose-3.0.0-dfsg.orig/src/VBox/Additions/linux/module/Makefile.module virtualbox-ose-3.0.0-dfsg/src/VBox/Additions/linux/module/Makefile.module
9
 
--- virtualbox-ose-3.0.0-dfsg.orig/src/VBox/Additions/linux/module/Makefile.module      2009-07-01 11:30:49.000000000 +0200
10
 
+++ virtualbox-ose-3.0.0-dfsg/src/VBox/Additions/linux/module/Makefile.module   2009-07-01 11:30:40.000000000 +0200
11
 
@@ -37,9 +37,21 @@
12
 
   BUILD_TARGET_ARCH := amd64
13
 
  else
14
 
   ifeq ($(ARCH),i386)
15
 
-   BUILD_TARGET_ARCH := x86
16
 
+   ifeq ($(CONFIG_X86_32),y)
17
 
+     BUILD_TARGET_ARCH := x86
18
 
+   else
19
 
+     BUILD_TARGET_ARCH := amd64
20
 
+   endif
21
 
   else
22
 
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
23
 
+    ifeq ($(ARCH),x86)
24
 
+      ifeq ($(CONFIG_X86_32),y)
25
 
+        BUILD_TARGET_ARCH := x86
26
 
+      else
27
 
+        BUILD_TARGET_ARCH := amd64
28
 
+      endif
29
 
+    else
30
 
+      BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
31
 
+    endif
32
 
   endif
33
 
  endif
34
 
 else
35
 
diff -Naurp virtualbox-ose-3.0.0-dfsg.orig/src/VBox/Additions/linux/sharedfolders/Makefile.module virtualbox-ose-3.0.0-dfsg/src/VBox/Additions/linux/sharedfolders/Makefile.module
36
 
--- virtualbox-ose-3.0.0-dfsg.orig/src/VBox/Additions/linux/sharedfolders/Makefile.module       2009-07-01 11:35:37.000000000 +0200
37
 
+++ virtualbox-ose-3.0.0-dfsg/src/VBox/Additions/linux/sharedfolders/Makefile.module    2009-07-01 11:36:21.000000000 +0200
38
 
@@ -37,9 +37,21 @@
39
 
   BUILD_TARGET_ARCH := amd64
40
 
  else
41
 
   ifeq ($(ARCH),i386)
42
 
-   BUILD_TARGET_ARCH := x86
43
 
+   ifeq ($(CONFIG_X86_32),y)
44
 
+     BUILD_TARGET_ARCH := x86
45
 
+   else
46
 
+     BUILD_TARGET_ARCH := amd64
47
 
+   endif
48
 
   else
49
 
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
50
 
+    ifeq ($(ARCH),x86)
51
 
+      ifeq ($(CONFIG_X86_32),y)
52
 
+        BUILD_TARGET_ARCH := x86
53
 
+      else
54
 
+        BUILD_TARGET_ARCH := amd64
55
 
+      endif
56
 
+    else
57
 
+      BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
58
 
+    endif
59
 
   endif
60
 
  endif
61
 
 else
62
 
diff -Naurp virtualbox-ose-2.2.4-dfsg.orig/src/VBox/HostDrivers/Support/linux/Makefile virtualbox-ose-2.2.4-dfsg/src/VBox/HostDrivers/Support/linux/Makefile
63
 
--- virtualbox-ose-2.2.4-dfsg.orig/src/VBox/HostDrivers/Support/linux/Makefile  2009-06-04 13:30:14.000000000 +0200
64
 
+++ virtualbox-ose-2.2.4-dfsg/src/VBox/HostDrivers/Support/linux/Makefile       2009-06-04 13:34:46.000000000 +0200
65
 
@@ -48,9 +48,21 @@
66
 
   BUILD_TARGET_ARCH := amd64
67
 
  else
68
 
   ifeq ($(ARCH),i386)
69
 
-   BUILD_TARGET_ARCH := x86
70
 
+   ifeq ($(CONFIG_X86_32),y)
71
 
+     BUILD_TARGET_ARCH := x86
72
 
+   else
73
 
+     BUILD_TARGET_ARCH := amd64
74
 
+   endif
75
 
   else
76
 
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
77
 
+   ifeq ($(ARCH),x86)
78
 
+     ifeq ($(CONFIG_X86_32),y)
79
 
+       BUILD_TARGET_ARCH := x86
80
 
+     else
81
 
+       BUILD_TARGET_ARCH := amd64
82
 
+     endif
83
 
+   else
84
 
+     BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
85
 
+   endif
86
 
   endif
87
 
  endif
88
 
 else
89
 
diff -Naurp virtualbox-ose-2.2.4-dfsg.orig/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile virtualbox-ose-2.2.4-dfsg/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile
90
 
--- virtualbox-ose-2.2.4-dfsg.orig/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile       2009-06-04 13:30:14.000000000 +0200
91
 
+++ virtualbox-ose-2.2.4-dfsg/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile    2009-06-04 13:34:46.000000000 +0200
92
 
@@ -48,9 +48,21 @@
93
 
   BUILD_TARGET_ARCH := amd64
94
 
  else
95
 
   ifeq ($(ARCH),i386)
96
 
-   BUILD_TARGET_ARCH := x86
97
 
+   ifeq ($(CONFIG_X86_32),y)
98
 
+     BUILD_TARGET_ARCH := x86
99
 
+   else
100
 
+     BUILD_TARGET_ARCH := amd64
101
 
+   endif
102
 
   else
103
 
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
104
 
+   ifeq ($(ARCH),x86)
105
 
+     ifeq ($(CONFIG_X86_32),y)
106
 
+       BUILD_TARGET_ARCH := x86
107
 
+     else
108
 
+       BUILD_TARGET_ARCH := amd64
109
 
+     endif
110
 
+   else
111
 
+     BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
112
 
+   endif
113
 
   endif
114
 
  endif
115
 
 else
116
 
diff -Naurp virtualbox-ose-3.0.0-dfsg.orig/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile virtualbox-ose-3.0.0-dfsg/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile
117
 
--- virtualbox-ose-3.0.0-dfsg.orig/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile       2009-07-01 11:37:57.000000000 +0200
118
 
+++ virtualbox-ose-3.0.0-dfsg/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile    2009-07-01 11:38:20.000000000 +0200
 
7
diff -urNad virtualbox-ose-3.0.8-dfsg~/src/VBox/Additions/linux/module/Makefile.module virtualbox-ose-3.0.8-dfsg/src/VBox/Additions/linux/module/Makefile.module
 
8
--- virtualbox-ose-3.0.8-dfsg~/src/VBox/Additions/linux/module/Makefile.module  2009-10-07 11:27:13.000000000 +0200
 
9
+++ virtualbox-ose-3.0.8-dfsg/src/VBox/Additions/linux/module/Makefile.module   2009-10-07 13:43:30.705472033 +0200
 
10
@@ -37,9 +37,21 @@
 
11
   BUILD_TARGET_ARCH := amd64
 
12
  else
 
13
   ifeq ($(ARCH),i386)
 
14
-   BUILD_TARGET_ARCH := x86
 
15
+   ifeq ($(CONFIG_X86_32),y)
 
16
+     BUILD_TARGET_ARCH := x86
 
17
+   else
 
18
+     BUILD_TARGET_ARCH := amd64
 
19
+   endif
 
20
   else
 
21
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
22
+    ifeq ($(ARCH),x86)
 
23
+      ifeq ($(CONFIG_X86_32),y)
 
24
+        BUILD_TARGET_ARCH := x86
 
25
+      else
 
26
+        BUILD_TARGET_ARCH := amd64
 
27
+      endif
 
28
+    else
 
29
+      BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
30
+    endif
 
31
   endif
 
32
  endif
 
33
 else
 
34
diff -urNad virtualbox-ose-3.0.8-dfsg~/src/VBox/Additions/linux/sharedfolders/Makefile.module virtualbox-ose-3.0.8-dfsg/src/VBox/Additions/linux/sharedfolders/Makefile.module
 
35
--- virtualbox-ose-3.0.8-dfsg~/src/VBox/Additions/linux/sharedfolders/Makefile.module   2009-10-07 11:27:13.000000000 +0200
 
36
+++ virtualbox-ose-3.0.8-dfsg/src/VBox/Additions/linux/sharedfolders/Makefile.module    2009-10-07 13:43:30.705472033 +0200
 
37
@@ -37,9 +37,21 @@
 
38
   BUILD_TARGET_ARCH := amd64
 
39
  else
 
40
   ifeq ($(ARCH),i386)
 
41
-   BUILD_TARGET_ARCH := x86
 
42
+   ifeq ($(CONFIG_X86_32),y)
 
43
+     BUILD_TARGET_ARCH := x86
 
44
+   else
 
45
+     BUILD_TARGET_ARCH := amd64
 
46
+   endif
 
47
   else
 
48
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
49
+    ifeq ($(ARCH),x86)
 
50
+      ifeq ($(CONFIG_X86_32),y)
 
51
+        BUILD_TARGET_ARCH := x86
 
52
+      else
 
53
+        BUILD_TARGET_ARCH := amd64
 
54
+      endif
 
55
+    else
 
56
+      BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
57
+    endif
 
58
   endif
 
59
  endif
 
60
 else
 
61
diff -urNad virtualbox-ose-3.0.8-dfsg~/src/VBox/HostDrivers/Support/linux/Makefile virtualbox-ose-3.0.8-dfsg/src/VBox/HostDrivers/Support/linux/Makefile
 
62
--- virtualbox-ose-3.0.8-dfsg~/src/VBox/HostDrivers/Support/linux/Makefile      2009-10-07 11:27:14.000000000 +0200
 
63
+++ virtualbox-ose-3.0.8-dfsg/src/VBox/HostDrivers/Support/linux/Makefile       2009-10-07 13:43:30.705472033 +0200
 
64
@@ -48,9 +48,21 @@
 
65
   BUILD_TARGET_ARCH := amd64
 
66
  else
 
67
   ifeq ($(ARCH),i386)
 
68
-   BUILD_TARGET_ARCH := x86
 
69
+   ifeq ($(CONFIG_X86_32),y)
 
70
+     BUILD_TARGET_ARCH := x86
 
71
+   else
 
72
+     BUILD_TARGET_ARCH := amd64
 
73
+   endif
 
74
   else
 
75
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
76
+   ifeq ($(ARCH),x86)
 
77
+     ifeq ($(CONFIG_X86_32),y)
 
78
+       BUILD_TARGET_ARCH := x86
 
79
+     else
 
80
+       BUILD_TARGET_ARCH := amd64
 
81
+     endif
 
82
+   else
 
83
+     BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
84
+   endif
 
85
   endif
 
86
  endif
 
87
 else
 
88
diff -urNad virtualbox-ose-3.0.8-dfsg~/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile virtualbox-ose-3.0.8-dfsg/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile
 
89
--- virtualbox-ose-3.0.8-dfsg~/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile   2009-10-07 11:27:14.000000000 +0200
 
90
+++ virtualbox-ose-3.0.8-dfsg/src/VBox/HostDrivers/VBoxNetAdp/linux/Makefile    2009-10-07 13:43:30.705472033 +0200
 
91
@@ -39,9 +39,21 @@
 
92
   BUILD_TARGET_ARCH := amd64
 
93
  else
 
94
   ifeq ($(ARCH),i386)
 
95
-   BUILD_TARGET_ARCH := x86
 
96
+   ifeq ($(CONFIG_X86_32),y)
 
97
+     BUILD_TARGET_ARCH := x86
 
98
+   else
 
99
+     BUILD_TARGET_ARCH := amd64
 
100
+   endif
 
101
   else
 
102
-   BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
103
+   ifeq ($(ARCH),x86)
 
104
+     ifeq ($(CONFIG_X86_32),y)
 
105
+       BUILD_TARGET_ARCH := x86
 
106
+     else
 
107
+       BUILD_TARGET_ARCH := amd64
 
108
+     endif
 
109
+   else
 
110
+     BUILD_TARGET_ARCH := $(BUILD_TARGET_ARCH_DEF)
 
111
+   endif
 
112
   endif
 
113
  endif
 
114
 else
 
115
diff -urNad virtualbox-ose-3.0.8-dfsg~/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile virtualbox-ose-3.0.8-dfsg/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile
 
116
--- virtualbox-ose-3.0.8-dfsg~/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile   2009-10-07 11:27:14.000000000 +0200
 
117
+++ virtualbox-ose-3.0.8-dfsg/src/VBox/HostDrivers/VBoxNetFlt/linux/Makefile    2009-10-07 13:43:30.705472033 +0200
119
118
@@ -39,9 +39,21 @@
120
119
   BUILD_TARGET_ARCH := amd64
121
120
  else