~ubuntu-branches/ubuntu/vivid/virtualbox-ose/vivid

« back to all changes in this revision

Viewing changes to debian/patches/22-no-static-libstdcpp.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Felix Geyer
  • Date: 2009-10-13 23:06:00 UTC
  • mfrom: (0.3.2 upstream) (0.1.12 sid)
  • Revision ID: james.westby@ubuntu.com-20091013230600-xhu2pwizq0wo63l9
Tags: 3.0.8-dfsg-1ubuntu1
* Merge from debian unstable (LP: #444812), remaining changes:
  - Enable DKMS support on virtualbox host and guest modules (LP: #267097)
    - Drop virtualbox-ose{-guest,}-modules-* package templates
    - Recommend *-source instead of *-modules packages
    - Replace error messages related to missing/mismatched
      kernel module accordingly
  - Autoload kernel module
    - LOAD_VBOXDRV_MODULE=1 in virtualbox-ose.default
  - Disable update action
    - patches/u01-disable-update-action.dpatch
  - Virtualbox should go in Accessories, not in System tools (LP: #288590)
    - virtualbox-ose-qt.files/virtualbox-ose.desktop
  - Add apport hook
    - virtualbox-ose.files/source_virtualbox-ose.py
    - virtualbox-ose.install
  - Add launchpad integration
    - control
    - lpi-bug.xpm
    - patches/u02-lp-integration.dpatch
* Try to remove existing dkms modules before adding the new modules
  (LP: #434503)
  - debian/virtualbox-ose-source.postinst
  - debian/virtualbox-ose-guest-source.postinst
* Don't fail if dkms modules have already been removed
  - debian/virtualbox-ose-source.prerm
  - debian/virtualbox-ose-guest-source.prerm

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 22-no-static-libstdcpp.dpatch by Lubomir Rintel <lkundrak@v3.sk>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Do not include statically linked libstdc++. Not a good idea if we don't need
 
6
## DP: to be binary-compatible across exotic distribution. Doesn't work with trunk
 
7
## DP: glibc heading towards 2.11 anyways. Static linking is not really supported
 
8
## DP: anyways.
 
9
 
 
10
@DPATCH@
 
11
diff -urNad virtualbox-ose-3.0.8-dfsg~/src/VBox/Additions/x11/VBoxClient/Makefile.kmk virtualbox-ose-3.0.8-dfsg/src/VBox/Additions/x11/VBoxClient/Makefile.kmk
 
12
--- virtualbox-ose-3.0.8-dfsg~/src/VBox/Additions/x11/VBoxClient/Makefile.kmk   2009-10-07 11:27:13.000000000 +0200
 
13
+++ virtualbox-ose-3.0.8-dfsg/src/VBox/Additions/x11/VBoxClient/Makefile.kmk    2009-10-07 18:44:29.962989537 +0200
 
14
@@ -62,20 +62,6 @@
 
15
        Xext Xmu
 
16
 endif
 
17
 
 
18
-#
 
19
-# Link aginst libstdc++.a. (http://www.trilithium.com/johan/2005/06/static-libstdc/).
 
20
-# (It would've been preferred to avoid features depending on libstdc++, of course...)
 
21
-#
 
22
-# Actually, this is darn annoying and will *NOT* be tolerated for any new code!
 
23
-#
 
24
-VBoxClient_LIBPATH  += $(PATH_VBoxClient)
 
25
-VBoxClient_ORDERDEPS = $(PATH_VBoxClient)/libstdc++.a
 
26
-VBoxClient_CLEAN     = $(PATH_VBoxClient)/libstdc++.a
 
27
-$$(PATH_VBoxClient)/libstdc++.a:
 
28
-       $(call MSG_L1,Forcing static libstdc++)
 
29
-       $(QUIET)$(MKDIR) -p $(@D)
 
30
-       $(QUIET)$(LN_EXT) -sf `$(TOOL_$(VBOX_GCC_TOOL)_CXX) $(TEMPLATE_VBOXGUESTR3CPPEXE_CXXFLAGS.$(KBUILD_TARGET_ARCH)) -print-file-name=libstdc++.a` $@ \
 
31
-            || $(CP_EXT) -f  `$(TOOL_$(VBOX_GCC_TOOL)_CXX) $(TEMPLATE_VBOXGUESTR3CPPEXE_CXXFLAGS.$(KBUILD_TARGET_ARCH)) -print-file-name=libstdc++.a` $@
 
32
 
 
33
 ifdef VBOX_X11_SEAMLESS_GUEST
 
34
  if defined(VBOX_WITH_TESTCASES) && !defined(VBOX_ONLY_ADDITIONS) && !defined(VBOX_ONLY_SDK)