~ubuntu-branches/ubuntu/vivid/wpasupplicant/vivid

« back to all changes in this revision

Viewing changes to debian/patches/10_orinoco_wep_key_fix.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Kel Modderman
  • Date: 2008-03-12 20:03:04 UTC
  • mfrom: (1.1.10 upstream)
  • mto: This revision was merged to the branch mainline in revision 4.
  • Revision ID: james.westby@ubuntu.com-20080312200304-4331y9wj46pdd34z
Tags: 0.6.3-1
* New upstream release.
* Drop patches applied upstream:
  - debian/patches/30_wpa_gui_qt4_eventhistoryui_rework.patch
  - debian/patches/31_wpa_gui_qt4_eventhistory_always_scrollbar.patch
  - debian/patches/32_wpa_gui_qt4_eventhistory_scroll_with_events.patch
  - debian/patches/40_dbus_ssid_data.patch
* Tidy up the clean target of debian/rules. Now that the madwifi headers are
  handled differently we no longer need to do any cleanup.
* Fix formatting error in debian/ifupdown/wpa_action.8 to make lintian
  quieter.
* Add patch to fix formatting errors in manpages build from sgml source. Use
  <emphasis> tags to hightlight keywords instead of surrounding them in
  strong quotes.
  - debian/patches/41_manpage_format_fixes.patch
* wpasupplicant binary package no longer suggests pcscd, guessnet, iproute
  or wireless-tools, nor does it recommend dhcp3-client. These are not
  needed.
* Add debian/patches/10_silence_siocsiwauth_icotl_failure.patch to disable
  ioctl failure messages that occur under normal conditions.
* Cherry pick two upstream git commits concerning the dbus interface:
  - debian/patches/11_avoid_dbus_version_namespace.patch
  - debian/patches/12_fix_potential_use_after_free.patch
* Add debian/patches/42_manpage_explain_available_drivers.patch to explain
  that not all of the driver backends are available in the provided
  wpa_supplicant binary, and that the canonical list of supported driver
  backends can be retrieved from the wpa_supplicant -h (help) output.
  (Closes: #466910)
* Add debian/patches/20_wpa_gui_qt4_disable_link_prl.patch to remove
  link_prl CONFIG compile flag added by qmake-qt4 >= 4.3.4-2 to avoid excess
  linking.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 10_orinoco_wep_key_fix.patch by Kel Modderman <kelrin@tpg.com.au>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: http://cvs.fedora.redhat.com/viewcvs/devel/wpa_supplicant/wpa_supplicant-wep-key-fix.patch
6
 
## DP: Dan Williams <dcbw@redhat.com>
7
 
 
8
 
@DPATCH@
9
 
diff -Nrup wpa_supplicant-0.5-2006-05-22.orig/driver_wext.c wpa_supplicant-0.5-2006-05-22.patched/driver_wext.c
10
 
--- wpa_supplicant-0.5-2006-05-22.orig/driver_wext.c    2006-05-21 03:32:46.000000000 +1000
11
 
+++ wpa_supplicant-0.5-2006-05-22.patched/driver_wext.c 2006-06-09 22:48:16.000000000 +1000
12
 
@@ -1565,7 +1565,7 @@ int wpa_driver_wext_set_key(void *priv, 
13
 
                memset(&iwr, 0, sizeof(iwr));
14
 
                strncpy(iwr.ifr_name, drv->ifname, IFNAMSIZ);
15
 
                iwr.u.encoding.flags = key_idx + 1;
16
 
-               iwr.u.encoding.pointer = (caddr_t) key;
17
 
+               iwr.u.encoding.pointer = (caddr_t) NULL;
18
 
                iwr.u.encoding.length = 0;
19
 
                if (ioctl(drv->ioctl_sock, SIOCSIWENCODE, &iwr) < 0) {
20
 
                        perror("ioctl[SIOCSIWENCODE] (set_tx)");