~ubuntu-branches/ubuntu/vivid/wpasupplicant/vivid

« back to all changes in this revision

Viewing changes to debian/patches/10_silence_siocsiwauth_icotl_failure.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Kel Modderman
  • Date: 2008-03-12 20:03:04 UTC
  • mfrom: (1.1.10 upstream)
  • mto: This revision was merged to the branch mainline in revision 4.
  • Revision ID: james.westby@ubuntu.com-20080312200304-4331y9wj46pdd34z
Tags: 0.6.3-1
* New upstream release.
* Drop patches applied upstream:
  - debian/patches/30_wpa_gui_qt4_eventhistoryui_rework.patch
  - debian/patches/31_wpa_gui_qt4_eventhistory_always_scrollbar.patch
  - debian/patches/32_wpa_gui_qt4_eventhistory_scroll_with_events.patch
  - debian/patches/40_dbus_ssid_data.patch
* Tidy up the clean target of debian/rules. Now that the madwifi headers are
  handled differently we no longer need to do any cleanup.
* Fix formatting error in debian/ifupdown/wpa_action.8 to make lintian
  quieter.
* Add patch to fix formatting errors in manpages build from sgml source. Use
  <emphasis> tags to hightlight keywords instead of surrounding them in
  strong quotes.
  - debian/patches/41_manpage_format_fixes.patch
* wpasupplicant binary package no longer suggests pcscd, guessnet, iproute
  or wireless-tools, nor does it recommend dhcp3-client. These are not
  needed.
* Add debian/patches/10_silence_siocsiwauth_icotl_failure.patch to disable
  ioctl failure messages that occur under normal conditions.
* Cherry pick two upstream git commits concerning the dbus interface:
  - debian/patches/11_avoid_dbus_version_namespace.patch
  - debian/patches/12_fix_potential_use_after_free.patch
* Add debian/patches/42_manpage_explain_available_drivers.patch to explain
  that not all of the driver backends are available in the provided
  wpa_supplicant binary, and that the canonical list of supported driver
  backends can be retrieved from the wpa_supplicant -h (help) output.
  (Closes: #466910)
* Add debian/patches/20_wpa_gui_qt4_disable_link_prl.patch to remove
  link_prl CONFIG compile flag added by qmake-qt4 >= 4.3.4-2 to avoid excess
  linking.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 02_debian_doc_examples.patch by Kel Modderman <kelmo@kanotixguide.org>
3
 
##
4
 
## DP: From: Jouni Malinen <j@w1.fi>
5
 
## DP: Date: Sat, 23 Feb 2008 03:36:47 +0000 (-0800)
6
 
## DP: Subject: Silence SIOCSIWAUTH ioctl failure message.
7
 
## DP: X-Git-Url: http://w1.fi/gitweb/gitweb.cgi?p=hostap.git;a=commitdiff_plain;h=8933ee9a42ae3ddba77a8ae6707396a4fed37778
8
 
## DP:
9
 
## DP: Silence SIOCSIWAUTH ioctl failure message.
10
 
## DP:
11
 
## DP: These are expected in most cases and there is no need to confuse users
12
 
## DP: with the messages in stderr (perror was used here). These are now only
13
 
## DP: shown in debug output and EOPNOTSUPP errors are silently ignored.
14
 
 
15
 
@DPATCH@
16
 
--- a/driver_wext.c
17
 
+++ b/driver_wext.c
18
 
@@ -251,9 +251,11 @@
19
 
        iwr.u.param.value = value;
20
 
 
21
 
        if (ioctl(drv->ioctl_sock, SIOCSIWAUTH, &iwr) < 0) {
22
 
-               perror("ioctl[SIOCSIWAUTH]");
23
 
-               fprintf(stderr, "WEXT auth param %d value 0x%x - ",
24
 
-                       idx, value);
25
 
+               if (errno != EOPNOTSUPP) {
26
 
+                       wpa_printf(MSG_DEBUG, "WEXT: SIOCSIWAUTH(param %d "
27
 
+                                  "value 0x%x) failed: %s)",
28
 
+                                  idx, value, strerror(errno));
29
 
+               }
30
 
                ret = errno == EOPNOTSUPP ? -2 : -1;
31
 
        }
32