~ubuntu-branches/ubuntu/wily/mutter/wily

« back to all changes in this revision

Viewing changes to debian/patches/03_link_gles2.patch

  • Committer: Bazaar Package Importer
  • Author(s): Rico Tzschichholz
  • Date: 2011-04-10 22:27:59 UTC
  • mfrom: (0.7.1 upstream) (0.3.20 experimental)
  • Revision ID: james.westby@ubuntu.com-20110410222759-o6n1i5p0unsti44n
Tags: 3.0.0-0ubuntu1
* New upstream release

* Merge with debian experimental (LP: #742458), remaining changes:
  + debian/patches/03_link_gles2.patch: Link to clutter-glx-1.0
    explicitily at the end of link flags, to bring in libGLESv2 on armel.
* debian/control.in:
  + rename gir package to gir1.2-mutter-3.0
* debian/libmutter0.symbols:
  + updated
* debian/patches:
  + fix 03_link_gles2.patch 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
## Description: add some description
2
 
## Origin/Author: add some origin or author
3
 
## Bug: bug URL
4
 
Index: mutter-2.91.90/src/Makefile.am
5
 
===================================================================
6
 
--- mutter-2.91.90.orig/src/Makefile.am 2011-03-16 13:30:00.254615402 +0200
7
 
+++ mutter-2.91.90/src/Makefile.am      2011-03-16 13:29:53.418581504 +0200
8
 
@@ -238,7 +238,7 @@
9
 
 endif
10
 
 
11
 
 EFENCE=
12
 
-mutter_LDADD=@MUTTER_LIBS@ $(EFENCE)
13
 
+mutter_LDADD=@MUTTER_LIBS@ $(EFENCE) -lclutter-glx-1.0
14
 
 mutter_LDFLAGS=-export-dynamic
15
 
 
16
 
 mutter_theme_viewer_LDADD= @MUTTER_LIBS@ libmutter-private.la
17
 
Index: mutter-2.91.90/src/Makefile.in
18
 
===================================================================
19
 
--- mutter-2.91.90.orig/src/Makefile.in 2011-03-16 13:30:00.434616293 +0200
20
 
+++ mutter-2.91.90/src/Makefile.in      2011-03-16 13:29:52.778578327 +0200
21
 
@@ -610,7 +610,7 @@
22
 
 @WITH_INTROSPECTION_TRUE@typelibdir = $(pkglibdir)
23
 
 @WITH_INTROSPECTION_TRUE@typelib_DATA = Meta-$(api_version).typelib
24
 
 EFENCE = 
25
 
-mutter_LDADD = @MUTTER_LIBS@ $(EFENCE)
26
 
+mutter_LDADD = @MUTTER_LIBS@ $(EFENCE) -lclutter-glx-1.0
27
 
 mutter_LDFLAGS = -export-dynamic
28
 
 mutter_theme_viewer_LDADD = @MUTTER_LIBS@ libmutter-private.la
29
 
 testboxes_SOURCES = include/util.h core/util.c include/boxes.h core/boxes.c core/testboxes.c
 
1
## Description: Mutter is using a GL symbol (glGetBooleanv) and not explicit linking to it.
 
2
##  The symbols is available in libGL and libGLESv2
 
3
## Origin/Author: Jani Monoses
 
4
## Bug: https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/726827
 
5
Index: mutter-2.91.92/src/Makefile.am
 
6
===================================================================
 
7
--- mutter-2.91.92.orig/src/Makefile.am
 
8
+++ mutter-2.91.92/src/Makefile.am
 
9
@@ -155,7 +155,7 @@
 
10
        $(mutter_built_sources)
 
11
 
 
12
 libmutter_la_LDFLAGS = -no-undefined
 
13
-libmutter_la_LIBADD  = $(MUTTER_LIBS)
 
14
+libmutter_la_LIBADD  = $(MUTTER_LIBS) -lclutter-glx-1.0
 
15
 
 
16
 # Headers installed for plugins; introspected information will
 
17
 # be extracted into Mutter-<version>.gir
 
18
@@ -199,7 +199,7 @@
 
19
 bin_PROGRAMS=mutter mutter-theme-viewer
 
20
 
 
21
 mutter_SOURCES = core/mutter.c
 
22
-mutter_LDADD = $(MUTTER_LIBS) libmutter.la
 
23
+mutter_LDADD = $(MUTTER_LIBS) libmutter.la -lclutter-glx-1.0
 
24
 
 
25
 if HAVE_INTROSPECTION
 
26
 include $(INTROSPECTION_MAKEFILE)
 
27
Index: mutter-2.91.92/src/Makefile.in
 
28
===================================================================
 
29
--- mutter-2.91.92.orig/src/Makefile.in
 
30
+++ mutter-2.91.92/src/Makefile.in
 
31
@@ -546,7 +546,7 @@
 
32
        $(mutter_built_sources)
 
33
 
 
34
 libmutter_la_LDFLAGS = -no-undefined
 
35
-libmutter_la_LIBADD = $(MUTTER_LIBS)
 
36
+libmutter_la_LIBADD = $(MUTTER_LIBS) -lclutter-glx-1.0
 
37
 
 
38
 # Headers installed for plugins; introspected information will
 
39
 # be extracted into Mutter-<version>.gir
 
40
@@ -588,7 +588,7 @@
 
41
        ui/theme-viewer.c
 
42
 
 
43
 mutter_SOURCES = core/mutter.c
 
44
-mutter_LDADD = $(MUTTER_LIBS) libmutter.la
 
45
+mutter_LDADD = $(MUTTER_LIBS) libmutter.la -lclutter-glx-1.0
 
46
 @HAVE_INTROSPECTION_TRUE@api_version = $(MUTTER_MAJOR_VERSION).$(MUTTER_MINOR_VERSION)
 
47
 
 
48
 # These files are in package-private directories, even though they may be used