~ubuntu-branches/ubuntu/wily/openms/wily

« back to all changes in this revision

Viewing changes to debian/patches/rpath-force-shared-libs-set-soname.patch

  • Committer: Package Import Robot
  • Author(s): Filippo Rusconi
  • Date: 2012-11-12 15:58:12 UTC
  • Revision ID: package-import@ubuntu.com-20121112155812-e6mvctvil4ko9npv
Tags: 1.9.0-1
1.9.0 First Debian package release (Closes: #691129).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Set the SONAME for the libraries. Configure not to set RPATH to any
 
2
built lib/bin object. Force building share object libraries.--- a/CMakeLists.txt
 
3
+++ b/CMakeLists.txt
 
4
@@ -38,6 +38,11 @@
 
5
 
 
6
 
 
7
 cmake_minimum_required(VERSION 2.6.3 FATAL_ERROR)
 
8
+
 
9
+# No RPATH at all in any of the binaries built here:
 
10
+set (CMAKE_SKIP_RPATH TRUE)
 
11
+MESSAGE(STATUS "CMAKE_SKIP_RPATH: ${CMAKE_SKIP_RPATH}")
 
12
+
 
13
 SET(CMAKE_ALLOW_LOOSE_LOOP_CONSTRUCTS true)
 
14
 set(CF_OPENMS_PACKAGE_VERSION "${OPENMS_PACKAGE_VERSION_MAJOR}.${OPENMS_PACKAGE_VERSION_MINOR}.${OPENMS_PACKAGE_VERSION_PATCH}" CACHE INTERNAL "OpenMS VERSION" FORCE)
 
15
 
 
16
@@ -337,15 +342,20 @@
 
17
 if (FOUND_CUDART AND MT_ENABLE_CUDA) # we need both conditions due to possible present cached entries
 
18
        CUDA_ADD_LIBRARY(OpenMS ${OpenMS_sources} ${Cuda_sources})
 
19
 else()
 
20
-       ADD_LIBRARY(OpenMS ${OpenMS_sources})
 
21
+       ADD_LIBRARY(OpenMS SHARED ${OpenMS_sources})
 
22
 endif()
 
23
 
 
24
+set_target_properties(OpenMS PROPERTIES VERSION 1.9.0 SOVERSION 1)
 
25
+
 
26
 ### OpenMS_GUI lib
 
27
-ADD_LIBRARY(OpenMS_GUI ${OpenMSVisual_sources})
 
28
+ADD_LIBRARY(OpenMS_GUI SHARED ${OpenMSVisual_sources})
 
29
 if (MSVC)
 
30
        set (GUI_lnk_flags "/FORCE:MULTIPLE /INCREMENTAL:NO /ignore:4006 /ignore:4088")
 
31
        set_target_properties(OpenMS_GUI PROPERTIES LINK_FLAGS ${GUI_lnk_flags}) ## allow multiple definitions of symbols (e.g. from template instanciations or STL-derived classes)
 
32
-endif()        
 
33
+endif()
 
34
+
 
35
+set_target_properties(OpenMS_GUI PROPERTIES VERSION 1.9.0 SOVERSION 1)
 
36
+       
 
37
 
 
38
 ## update the openms_svn_revision.h file before compiling OpenMS
 
39
 add_custom_target(svn_revision_update ALL