~matttbe/ubuntu/raring/rhythmbox/lp1010619_RB_2.98

« back to all changes in this revision

Viewing changes to debian/patches/git_scale_click.patch

  • Committer: Package Import Robot
  • Author(s): Jeremy Bicha
  • Date: 2012-11-06 20:52:57 UTC
  • mfrom: (1.1.67) (214.1.1 quantal-proposed)
  • Revision ID: package-import@ubuntu.com-20121106205257-0btjh8jqley153el
Tags: 2.98-0ubuntu1
* New upstream release (LP: #1060601)
* debian/control.in:
  - Bump minimum glib, gtk, totem-plparser, clutter, and clutter-gst
  - Drop no longer needed musicbrainz dependency
* Refreshed 09_keywords.patch
* Updated 11_fix_cd_pausing.patch with fix from git
* Dropped patches applied in new version:
  - 00git_musicbrainz5.patch
  - 08_CVE-2012-3355.patch
  - dont_free_consumed_floating_gvariant.patch
  - git_scale_click.patch
  - git_crash_during_monitor.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From a16a8bb41090233a28778e45f277e94de091f773 Mon Sep 17 00:00:00 2001
2
 
From: Jonathan Matthew <jonathan@d14n.org>
3
 
Date: Wed, 27 Jun 2012 03:04:44 +0000
4
 
Subject: header: remove left-click workaround for gtk+ 3.5+ (bug #678923)
5
 
 
6
 
GtkScale has the right behaviour now.  Keep the workaround for
7
 
older versions.
8
 
---
9
 
diff --git a/widgets/rb-header.c b/widgets/rb-header.c
10
 
index b5e8e7a..eeb4510 100644
11
 
--- a/widgets/rb-header.c
12
 
+++ b/widgets/rb-header.c
13
 
@@ -875,12 +875,14 @@ slider_press_callback (GtkWidget *widget,
14
 
        header->priv->latest_set_time = -1;
15
 
        g_object_notify (G_OBJECT (header), "slider-dragging");
16
 
 
17
 
+#if !GTK_CHECK_VERSION(3,5,0)
18
 
        /* HACK: we want the behaviour you get with the middle button, so we
19
 
         * mangle the event.  clicking with other buttons moves the slider in
20
 
         * step increments, clicking with the middle button moves the slider to
21
 
         * the location of the click.
22
 
         */
23
 
        event->button = 2;
24
 
+#endif
25
 
 
26
 
 
27
 
        return FALSE;
28
 
@@ -948,8 +950,10 @@ slider_release_callback (GtkWidget *widget,
29
 
                         GdkEventButton *event,
30
 
                         RBHeader *header)
31
 
 {
32
 
+#if !GTK_CHECK_VERSION(3,5,0)
33
 
        /* HACK: see slider_press_callback */
34
 
        event->button = 2;
35
 
+#endif
36
 
 
37
 
        if (header->priv->slider_dragging == FALSE) {
38
 
                rb_debug ("slider is not dragging");
39
 
--
40
 
cgit v0.9.0.2
41