~svn/ubuntu/oneiric/subversion/ppa

« back to all changes in this revision

Viewing changes to debian/patches/ruby-no-strict-aliasing

  • Committer: Bazaar Package Importer
  • Author(s): Matthias Klose
  • Date: 2006-12-13 17:57:16 UTC
  • mfrom: (1.1.6 upstream) (0.1.3 etch)
  • Revision ID: james.westby@ubuntu.com-20061213175716-2ysv6z4w5dpa2r2f
Tags: 1.4.2dfsg1-2ubuntu1
* Merge with Debian unstable; remaining changes:
  - Create pot file on build.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
##
 
3
## ruby-no-strict-aliasing by <peter@p12n.org>
 
4
##
 
5
## DP: Compile ruby bindings with -fno-strict-aliasing.
 
6
## DP: It seems swig is generating _really_ bad code here, or something.
 
7
## DP:
 
8
## DP: Whatever it is, this line suppresses 1323 warnings, any of which might
 
9
## DP: be real bugs with real consequences.
 
10
 
 
11
@DPATCH@
 
12
--- a/Makefile.in
 
13
+++ b/Makefile.in
 
14
@@ -122,7 +122,7 @@
 
15
 SWIG_PY_LIBS = @SWIG_PY_LIBS@
 
16
 SWIG_PL_INCLUDES = @SWIG_PL_INCLUDES@
 
17
 SWIG_RB_INCLUDES = @SWIG_RB_INCLUDES@ -I$(SWIG_SRC_DIR)/ruby/libsvn_swig_ruby
 
18
-SWIG_RB_COMPILE = @SWIG_RB_COMPILE@
 
19
+SWIG_RB_COMPILE = @SWIG_RB_COMPILE@ -fno-strict-aliasing
 
20
 SWIG_RB_LINK = @SWIG_RB_LINK@
 
21
 SWIG_RB_SITE_LIB_DIR = @SWIG_RB_SITE_LIB_DIR@
 
22
 SWIG_RB_SITE_ARCH_DIR = @SWIG_RB_SITE_ARCH_DIR@