~ubuntu-branches/ubuntu/breezy/muse/breezy

« back to all changes in this revision

Viewing changes to debian/patches/10_html_doc_cleanup.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Daniel Kobras
  • Date: 2004-02-07 15:18:22 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20040207151822-es27xxkzbcxkebjm
Tags: 0.6.3-1
* New upstream version.
* Added patches:
  + [10_alsa_init_fix] New, from upstream CVS.
    Initialize direction variable when setting Alsa parameters.
  + [10_canvas_translation_fix] New, from upstream CVS.
    Do not translate tooltips twice in canvas popup.
  + [10_checkbox_fix] New, from upstream CVS.
    Use proper set/test methods on metronome checkboxes.
  + [10_html_doc_cleanup] New.
    Fix links and HTML errors in documentation.
  + [20_allow_system_timer] New.
    The new upstream version fails by default if the real-time clock
    could not be accessed (usually the case when not running suid-root).
    This patch reverts the old behaviour of falling back to the more
    inaccurate system timer.
* Updated patches:
  + [11_PIC_fixes_fixup] Rediffed.
* Removed patches:
  + [20_no_atomic_asm] Merged upstream.
* debian/compat: Splice out debhelper compatibility level from rules file.
* debian/control: Build-depend on latest jack release by default.
  Closes: #228788
* debian/control: Bump standards version.
* debian/control: Use auto-generated debconf dependency via misc:Depends.
* debian/control: Minor tweaks to the long description.
* debian/control: Tighten fluidsynth build dependency to sane version.
* debian/muse.doc-base: New. Register HTML documentation with doc-base.
* debian/templates: Tiny rewording, and typo fix.
* debian/templates, debian/po/*: Switch to po-debconf for translations.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#!/bin/sh -e
 
2
## 10_html_doc_cleanup.dpatch by Daniel Kobras <kobras@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Remove dead links. Link to new upstream homepage. Fix a couple
 
6
## DP: of HTML errors here and there.
 
7
 
 
8
if [ $# -lt 1 ]; then
 
9
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
10
    exit 1
 
11
fi
 
12
 
 
13
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
 
14
patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
 
15
 
 
16
case "$1" in
 
17
       -patch) patch $patch_opts -p1 < $0;;
 
18
       -unpatch) patch $patch_opts -p1 -R < $0;;
 
19
        *)
 
20
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
21
                exit 1;;
 
22
esac
 
23
 
 
24
exit 0
 
25
 
 
26
@DPATCH@
 
27
diff -urNad /home/kobras/cvsdeb/Packages/muse/muse-0.6.3/share/html/getting_started.html muse-0.6.3/share/html/getting_started.html
 
28
--- /home/kobras/cvsdeb/Packages/muse/muse-0.6.3/share/html/getting_started.html        2003-10-29 11:05:32.000000000 +0100
 
29
+++ muse-0.6.3/share/html/getting_started.html  2004-02-07 14:43:58.000000000 +0100
 
30
@@ -15,8 +15,8 @@
 
31
 <pre>
 
32
        muse blues1.med
 
33
 </pre>
 
34
-Alternatively, start MusE and select <tt>File->New</tt>.  The default song
 
35
-name is <tt>default</tt> and the first time you select <tt>File->Save</tt>,
 
36
+Alternatively, start MusE and select <tt>File-&gt;New</tt>.  The default song
 
37
+name is <tt>default</tt> and the first time you select <tt>File-&gt;Save</tt>,
 
38
 MusE asks you for a real name.
 
39
 
 
40
   <li> Select a song type from the <tt>Type</tt> pulldown menu in the
 
41
diff -urNad /home/kobras/cvsdeb/Packages/muse/muse-0.6.3/share/html/index.html muse-0.6.3/share/html/index.html
 
42
--- /home/kobras/cvsdeb/Packages/muse/muse-0.6.3/share/html/index.html  2003-11-06 20:55:38.000000000 +0100
 
43
+++ muse-0.6.3/share/html/index.html    2004-02-07 14:41:37.000000000 +0100
 
44
@@ -6,10 +6,10 @@
 
45
 written by Werner Schweer and is published under the
 
46
 <a href="COPYING.html"> GNU General Public License</a>.
 
47
 The latest release of MusE can be found at the MusE hompage:
 
48
-<a href="http://muse.seh.de/">http://muse.seh.de/</a>.
 
49
+<a href="http://lmuse.sourceforge.net/">http://lmuse.sourceforge.net/</a>.
 
50
 
 
51
 <p>
 
52
-<h2>1. <a href="introduction.html">Introduction</a></h2>
 
53
+<h2>1. Introduction (still to be written)</h2>
 
54
 
 
55
 <p>
 
56
 <h2>2. <a href="installation.html">Installation</a></h2>
 
57
@@ -35,7 +35,7 @@
 
58
   <li>4.2.1 The Left Pane
 
59
   <li>4.2.1.1 Track Info
 
60
   <li>4.2.2 The Right Pane
 
61
-  <li>4.2.3 The Button Bar & Menus
 
62
+  <li>4.2.3 The Button Bar &amp; Menus
 
63
   <li>4.3 The Pianoroll
 
64
   <li>4.4 The Control Editor
 
65
   <li>4.4.1 Managing controls
 
66
@@ -54,5 +54,5 @@
 
67
 
 
68
 
 
69
 <p>
 
70
-<h2>XXX. <a href="glossary.html">Glossary</a></h2>
 
71
+<h2>Glossary (still to be written)</h2>
 
72
 </qt>
 
73
diff -urNad /home/kobras/cvsdeb/Packages/muse/muse-0.6.3/share/html/installation.html muse-0.6.3/share/html/installation.html
 
74
--- /home/kobras/cvsdeb/Packages/muse/muse-0.6.3/share/html/installation.html   2003-10-29 11:05:32.000000000 +0100
 
75
+++ muse-0.6.3/share/html/installation.html     2004-02-07 14:42:45.000000000 +0100
 
76
@@ -5,7 +5,7 @@
 
77
 <p>
 
78
 <h2>2.1 How to Obtain MusE</h2>
 
79
 MusE is available at the MusE Homepage, located at
 
80
-<a href="http://muse.seh.de/">http://muse.seh.de/</a>.
 
81
+<a href="http://lmuse.sourceforge.net/">http://lmuse.sourceforge.net/</a>.
 
82
 Download the latest non-beta release and follow the
 
83
 installation instructions below.
 
84
 
 
85
diff -urNad /home/kobras/cvsdeb/Packages/muse/muse-0.6.3/share/html/window_ref.html muse-0.6.3/share/html/window_ref.html
 
86
--- /home/kobras/cvsdeb/Packages/muse/muse-0.6.3/share/html/window_ref.html     2003-11-06 21:27:36.000000000 +0100
 
87
+++ muse-0.6.3/share/html/window_ref.html       2004-02-07 14:47:53.000000000 +0100
 
88
@@ -81,7 +81,7 @@
 
89
 <p>
 
90
 Operations that can be performed on the left pane:
 
91
 <table border=1>
 
92
-<th> <strong>Track Functions </th> <th>&nbsp;</th>
 
93
+<th> <strong>Track Functions </strong></th> <th>&nbsp;</th>
 
94
 <tr><td>Select Track<td>
 
95
   <ul>
 
96
     <li>Left Mouse Button
 
97
@@ -128,12 +128,12 @@
 
98
   </ul>
 
99
 <tr><td>Mute Track<td>
 
100
   <ul>
 
101
-    <li> click with left mouse button on �M� field in
 
102
+    <li> click with left mouse button on "M" field in
 
103
          Tracklist
 
104
   </ul>
 
105
 <tr><td>Solo Track<td>
 
106
   <ul>
 
107
-    <li> click �Solo� button
 
108
+    <li> click "Solo" button
 
109
   </ul>
 
110
 </table>
 
111
 
 
112
@@ -154,7 +154,7 @@
 
113
 Operations that can be performed on the right pane:
 
114
 <p>
 
115
 <table border=1>
 
116
-<tr><td><b>To do this...<td><b>...Do this
 
117
+<tr><td><b>To do this...</b><td><b>...Do this</b>
 
118
 <tr><td>Select Part<td>Left Click
 
119
 <tr><td>Select multiple parts<td>Shift + left click
 
120
 <tr><td>Select all parts on track<td>Ctrl + left click
 
121
@@ -190,15 +190,15 @@
 
122
 Pressing the 'ctrl'-button in the lower left corner of the pianoroll opens the controller editor.
 
123
 Keyboard shortcuts and other things that can be used in the pianoroll:
 
124
 <table border=1>
 
125
-<tr><td><b>To do this...<td><b>...Do this
 
126
+<tr><td><b>To do this...</b><td><b>...Do this</b>
 
127
 <tr><td>Change current position<td>Key left, Key right
 
128
 <tr><td>Undo last change<td>Ctrl+Z
 
129
 <tr><td>Select all events in current part<td>Ctrl+A
 
130
 <tr><td>Select all events with a certain pitch<td>Ctrl key + Left click on event
 
131
 <tr><td>Insert silence<td>Insert key
 
132
-<tr><td>Change quantization & stick to value btwn 1-1/64th<td>Key 1-Key 7
 
133
-<tr><td>Toggle triplets on/off in quantization & stick to<td>T-key
 
134
-<tr><td>Toggle period (long notes?) on/off in quantization & stick to<td>Period key
 
135
+<tr><td>Change quantization &amp; stick to value btwn 1-1/64th<td>Key 1-Key 7
 
136
+<tr><td>Toggle triplets on/off in quantization &amp; stick to<td>T-key
 
137
+<tr><td>Toggle period (long notes?) on/off in quantization &amp; stick to<td>Period key
 
138
 <tr><td>Change event color-mode<td>E-key
 
139
 <tr><td>Move locators to beginning and end of selected events<td>Alt+P
 
140
 </table>
 
141
@@ -260,7 +260,7 @@
 
142
 Since the output not (A-note) is generally the interesting one, changing the E-note is not particularly useful and this option might be removed in the future)
 
143
 
 
144
 <table border="1">
 
145
-<tr><td><b>To do this...<td><b>...do that
 
146
+<tr><td><b>To do this...</b><td><b>...do that</b>
 
147
 <tr><td>Toggle mute<td>Left click in the mute-column for the selected instrument
 
148
 <tr><td>Change instrument name<td>Double click in the sound column for the selected instrument
 
149
 <tr><td>Change quantization<td>Right/middle mouse click in the QNT-column for the selected instrument