~ubuntu-branches/ubuntu/gutsy/plotutils/gutsy

« back to all changes in this revision

Viewing changes to debian/patches/04_cast_to_char.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Floris Bruynooghe
  • Date: 2006-06-10 22:30:09 UTC
  • mfrom: (3.1.1 dapper)
  • Revision ID: james.westby@ubuntu.com-20060610223009-lfgb9ceyzjykj3z1
Tags: 2.4.1-15
* 14_manpage_spline.dpatch: correct long option of -n (Closes: #247208).
* debian/control: changed maintainer email address, old will expire soon.
* Changed libpng12-0-dev (virtual) to libpng12-dev (real) in Build-Depends.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 04_cast_to_char.dpatch by  <Floris Bruynooghe <fb102@soton.ac.uk>>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Adds a cast to (char*).
 
6
 
 
7
@DPATCH@
 
8
diff -urNad plotutils-2.4.1/libplot/g_write.c /tmp/dpep.eL2Tpn/plotutils-2.4.1/libplot/g_write.c
 
9
--- plotutils-2.4.1/libplot/g_write.c   2005-05-06 20:16:38.603358003 +0100
 
10
+++ /tmp/dpep.eL2Tpn/plotutils-2.4.1/libplot/g_write.c  2005-05-06 20:22:41.194211664 +0100
 
11
@@ -40,7 +40,7 @@
 
12
     }
 
13
 #ifdef LIBPLOTTER
 
14
   else if (data->outstream)
 
15
-    data->outstream->write(c, n);
 
16
+    data->outstream->write((char*)c, n);
 
17
 #endif
 
18
 }
 
19
 
 
20
diff -urNad plotutils-2.4.1/libplot/i_rle.c /tmp/dpep.eL2Tpn/plotutils-2.4.1/libplot/i_rle.c
 
21
--- plotutils-2.4.1/libplot/i_rle.c     1999-06-27 17:58:10.000000000 +0100
 
22
+++ /tmp/dpep.eL2Tpn/plotutils-2.4.1/libplot/i_rle.c    2005-05-06 20:23:49.530251054 +0100
 
23
@@ -78,7 +78,7 @@
 
24
   else if (rle->outstream)
 
25
     {
 
26
       rle->outstream->put ((unsigned char)(rle->oblen));
 
27
-      rle->outstream->write (&(rle->oblock[0]), rle->oblen);
 
28
+      rle->outstream->write ((char*)&(rle->oblock[0]), rle->oblen);
 
29
     }
 
30
 #endif  
 
31
 
 
32
diff -urNad plotutils-2.4.1/libplot/n_write.c /tmp/dpep.eL2Tpn/plotutils-2.4.1/libplot/n_write.c
 
33
--- plotutils-2.4.1/libplot/n_write.c   2005-05-06 20:16:38.605357562 +0100
 
34
+++ /tmp/dpep.eL2Tpn/plotutils-2.4.1/libplot/n_write.c  2005-05-06 20:29:00.867515857 +0100
 
35
@@ -208,7 +208,7 @@
 
36
                  linebuf[pos++] = '0';
 
37
                if (pos >= MAX_PBM_PIXELS_PER_LINE || i == (width - 1))
 
38
                  {
 
39
-                   stream->write (linebuf, pos);
 
40
+                   stream->write ((char*)linebuf, pos);
 
41
                    stream->put ('\n');
 
42
 
 
43
                    pos = 0;
 
44
@@ -253,7 +253,7 @@
 
45
                  rowbuf[bytecount++] = outbyte;
 
46
                }
 
47
              /* emit row of bytes */
 
48
-             stream->write (rowbuf, bytecount);
 
49
+             stream->write ((char*)rowbuf, bytecount);
 
50
            }
 
51
 
 
52
          free (rowbuf);
 
53
@@ -366,7 +366,7 @@
 
54
                num_pixels++;
 
55
                if (num_pixels >= MAX_PGM_PIXELS_PER_LINE || i == (width - 1))
 
56
                  {
 
57
-                   stream->write (linebuf, pos);
 
58
+                   stream->write ((char*)linebuf, pos);
 
59
                    stream->put ('\n');
 
60
 
 
61
                    num_pixels = 0;
 
62
@@ -392,7 +392,7 @@
 
63
            {
 
64
              for (i = 0; i < width; i++)
 
65
                rowbuf[i] = pixmap[j][i].u.rgb[0];
 
66
-             stream->write (rowbuf, width);
 
67
+             stream->write ((char*)rowbuf, width);
 
68
            }
 
69
          free (rowbuf);
 
70
        }
 
71
@@ -514,7 +514,7 @@
 
72
                num_pixels++;
 
73
                if (num_pixels >= MAX_PPM_PIXELS_PER_LINE || i == (width - 1))
 
74
                  {
 
75
-                   stream->write (linebuf, pos);
 
76
+                   stream->write ((char*)linebuf, pos);
 
77
                    stream->put ('\n');
 
78
 
 
79
                    num_pixels = 0;
 
80
@@ -542,7 +542,7 @@
 
81
              for (i = 0; i < width; i++)
 
82
                for (component = 0; component < 3; component++)
 
83
                  rowbuf[3 * i + component] = pixmap[j][i].u.rgb[component];
 
84
-             stream->write (rowbuf, 3 * width);
 
85
+             stream->write ((char*)rowbuf, 3 * width);
 
86
            }
 
87
          free (rowbuf);
 
88
        }
 
89
diff -urNad plotutils-2.4.1/libplot/z_write.c /tmp/dpep.eL2Tpn/plotutils-2.4.1/libplot/z_write.c
 
90
--- plotutils-2.4.1/libplot/z_write.c   2005-05-06 20:16:38.605357562 +0100
 
91
+++ /tmp/dpep.eL2Tpn/plotutils-2.4.1/libplot/z_write.c  2005-05-06 20:29:36.338054057 +0100
 
92
@@ -484,7 +484,7 @@
 
93
   ostream *stream;
 
94
 
 
95
   stream = (ostream *)png_get_io_ptr (png_ptr);
 
96
-  stream->write (data, length);
 
97
+  stream->write ((char*)data, length);
 
98
 }
 
99
 
 
100
 static void