~ubuntu-branches/ubuntu/gutsy/plotutils/gutsy

« back to all changes in this revision

Viewing changes to debian/patches/06_makefile_am.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Floris Bruynooghe
  • Date: 2006-06-10 22:30:09 UTC
  • mfrom: (3.1.1 dapper)
  • Revision ID: james.westby@ubuntu.com-20060610223009-lfgb9ceyzjykj3z1
Tags: 2.4.1-15
* 14_manpage_spline.dpatch: correct long option of -n (Closes: #247208).
* debian/control: changed maintainer email address, old will expire soon.
* Changed libpng12-0-dev (virtual) to libpng12-dev (real) in Build-Depends.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 06_makefile_am.dpatch by  <Floris Bruynooghe <fb102@soton.ac.uk>>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Update toplevel Makefile.am.
 
6
 
 
7
@DPATCH@
 
8
 
 
9
--- plotutils-2.4.1.orig/Makefile.am
 
10
+++ plotutils-2.4.1/Makefile.am
 
11
@@ -13,16 +13,16 @@
 
12
 # package, by default we don't build and install it as a standalone
 
13
 # library.  (It's always compiled into libplot and libplotter, though.)
 
14
 
 
15
-if NO_LIBPLOTTER
 
16
-ADD_LIBPLOTTER =
 
17
-else
 
18
+if ENABLE_LIBPLOTTER
 
19
 ADD_LIBPLOTTER = pic2plot libplotter
 
20
+else
 
21
+ADD_LIBPLOTTER =
 
22
 endif
 
23
 
 
24
-if NO_LIBXMI
 
25
-ADD_LIBXMI =
 
26
-else
 
27
+if ENABLE_LIBXMI
 
28
 ADD_LIBXMI = libxmi
 
29
+else
 
30
+ADD_LIBXMI =
 
31
 endif
 
32
 
 
33
 SUBDIRS = lib spline double ode ode-examples libplot $(ADD_LIBXMI) plot tek2plot plotfont graph $(ADD_LIBPLOTTER) include info doc fonts test