~ubuntu-branches/ubuntu/jaunty/gimp/jaunty-security

« back to all changes in this revision

Viewing changes to debian/patches/02_help-crash.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastien Bacher
  • Date: 2008-10-10 00:13:42 UTC
  • mfrom: (1.1.16 upstream)
  • Revision ID: james.westby@ubuntu.com-20081010001342-uja9qine9uybggd9
Tags: 2.6.1-1ubuntu1
* Sync new bugfix version on debian (lp: #280345, #280848)
* debian/patches/02_help-message.patch,
  debian/patches/03_gimp.desktop.in.in.patch:
  - updated some strings for ubuntu
* debian/rules:
  - updated translation templates

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: app/widgets/gimphelp.c
2
 
===================================================================
3
 
--- app/widgets/gimphelp.c      (revision 27111)
4
 
+++ app/widgets/gimphelp.c      (revision 27113)
5
 
@@ -503,13 +503,13 @@
6
 
   *domain_names = g_new0 (gchar *, n_domains + 1);
7
 
   *domain_uris  = g_new0 (gchar *, n_domains + 1);
8
 
 
9
 
-  *domain_names[0] = g_strdup ("http://www.gimp.org/help");
10
 
-  *domain_uris[0]  = gimp_help_get_default_domain_uri (gimp);
11
 
+  (*domain_names)[0] = g_strdup ("http://www.gimp.org/help");
12
 
+  (*domain_uris)[0]  = gimp_help_get_default_domain_uri (gimp);
13
 
 
14
 
   for (i = 0; i < n_domains; i++)
15
 
     {
16
 
-      *domain_names[i + 1] = plug_in_domains[i];
17
 
-      *domain_uris[i + 1]  = plug_in_uris[i];
18
 
+      (*domain_names)[i + 1] = plug_in_domains[i];
19
 
+      (*domain_uris)[i + 1]  = plug_in_uris[i];
20
 
     }
21
 
 
22
 
   g_free (plug_in_domains);
23
 
Index: app/plug-in/gimppluginprocframe.c
24
 
===================================================================
25
 
--- app/plug-in/gimppluginprocframe.c   (revision 27111)
26
 
+++ app/plug-in/gimppluginprocframe.c   (revision 27113)
27
 
@@ -75,7 +75,7 @@
28
 
 
29
 
   proc_frame->main_context       = g_object_ref (context);
30
 
   proc_frame->context_stack      = NULL;
31
 
-  proc_frame->procedure          = GIMP_PROCEDURE (procedure);
32
 
+  proc_frame->procedure          = procedure ? g_object_ref (procedure) : NULL;
33
 
   proc_frame->main_loop          = NULL;
34
 
   proc_frame->return_vals        = NULL;
35
 
   proc_frame->progress           = progress ? g_object_ref (progress) : NULL;
36
 
@@ -118,6 +118,12 @@
37
 
       proc_frame->main_context = NULL;
38
 
     }
39
 
 
40
 
+  if (proc_frame->procedure)
41
 
+    {
42
 
+      g_object_unref (proc_frame->procedure);
43
 
+      proc_frame->procedure = NULL;
44
 
+    }
45
 
+
46
 
   if (proc_frame->return_vals)
47
 
     {
48
 
       g_value_array_free (proc_frame->return_vals);