~ubuntu-branches/ubuntu/natty/bluefish/natty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/05_fix_449288_hlt_pattern_dialog.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Daniel Leidert (dale)
  • Date: 2010-06-29 21:40:10 UTC
  • mfrom: (1.1.6 upstream) (5.1.2 sid)
  • Revision ID: james.westby@ubuntu.com-20100629214010-2oxygudqcstn3zc6
Tags: 2.0.1-1
* New upstream release - the first release of the 2.0 series for Debian
  (closes: #570731; LP: #540126). This release fixes these reported issues:
  - Better settings handling (closes: #548272).
  - Improved filebrowser (LP: #45927).
  - Improved syntax highlighting engine (LP: #108628).
  - Improved file operations (LP: #181110).
  - Translated menu descriptions (LP: #371318, #371322). The chosen menu
    name is fine.
  - Improved browser commands and handling (LP: #158891, #348408).
* Updated and adjusted packaging files.
* debian/bluefish_icon.xpm: Renamed to debian/bluefish.xpm.
* debian/bluefish.install: Adjusted.
* debian/bluefish.menu (icon): Adjusted.
* debian/bluefish-data.install, debian/bluefish-plugins.install: Added.
* debian/control: Added bluefish-data, bluefish-dbg and bluefish-plugins.
  (Build-Depends): Dropped deprecated build-dependencies libaspell-dev,
  libgnomeui-dev, libgnomevfs2-dev, libpcre3-dev and dpatch. Added intltool,
  libtool, libenchant-dev and libgucharmap2-dev.
  (Standards-Version): Bumped to 3.8.4.
  (Depends, Suggests): Adjusted. Added gvfs-backends as dependency.
* debian/copyright: Updated.
* debian/rules: Rewritten. Dropped dpatch.
  (LDFLAGS): Dropped -Wl,-z,defs because of plugins.
  (config.status:): Adjusted configure switches.
  (install): Install to debian/tmp and list missing files.
  (binary-indep): Added for bluefish-data.
  (binary-arch): Adjusted. Put debugging symbols into bluefish-dbg.
* debian/watch: Added support for RCs.
* debian/README.Debian: Dropped (useless with 2.0).
* debian/README.source: Dropped together with dpatch.
* debian/patches/: Dropped (obsolete).
* debian/reportbug/: Dropped.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 05_fix_449288_hlt_pattern_dialog.dpatch by Jim Hayward,
3
 
##     Daniel Leidert (dale) <daniel.leidert@wgdd.de>
4
 
##
5
 
## All lines beginning with `## DP:' are a description of the patch.
6
 
## DP: With Gtk 2.12 many people observed, that no highlighting pattern are
7
 
## DP:   shown in the dialog. This might be because of a Gtk bug and the fact,
8
 
## DP:   that GtkOptionMenu has been deprecated some time ago. This fix adds a
9
 
## DP:   workaround.
10
 
## DP:
11
 
## DP: Many thanks to Jim Hayward for the patch.
12
 
## DP:
13
 
## DP: <URL:http://bugs.debian.org/449288>
14
 
## DP: <URL:http://bugzilla.gnome.org/show_bug.cgi?id=498954>
15
 
 
16
 
@DPATCH@
17
 
diff -urNad trunk~/src/preferences.c trunk/src/preferences.c
18
 
--- trunk~/src/preferences.c    2006-02-13 05:16:30.000000000 +0100
19
 
+++ trunk/src/preferences.c     2008-01-20 14:20:33.000000000 +0100
20
 
@@ -164,7 +164,7 @@
21
 
        GtkWidget *check;
22
 
        GtkWidget *radio[9];
23
 
        gchar **curstrarr;
24
 
-       const gchar *selected_filetype;
25
 
+       gchar *selected_filetype;
26
 
 } Thighlightpatterndialog;
27
 
 
28
 
 typedef struct {
29
 
@@ -912,12 +912,12 @@
30
 
 }
31
 
 
32
 
 static void highlightpattern_fill_from_selected_filetype(Tprefdialog *pd) {
33
 
-       DEBUG_MSG("highlightpattern_popmenu_activate, applied changes, about to clear liststore\n");
34
 
+       DEBUG_MSG("highlightpattern_fill_from_selected_filetype, applied changes, about to clear liststore\n");
35
 
        gtk_list_store_clear(GTK_LIST_STORE(pd->hpd.lstore));
36
 
        if (pd->hpd.selected_filetype) {
37
 
                GList *tmplist;
38
 
                tmplist = g_list_first(pd->lists[highlight_patterns]);
39
 
-               DEBUG_MSG("highlightpattern_popmenu_activate, about to fill for filetype %s (tmplist=%p)\n",pd->hpd.selected_filetype,tmplist);
40
 
+               DEBUG_MSG("highlightpattern_fill_from_selected_filetype, about to fill for filetype %s (tmplist=%p)\n",pd->hpd.selected_filetype,tmplist);
41
 
                /* fill list model here */
42
 
                while (tmplist) {
43
 
                        gchar **strarr =(gchar **)tmplist->data;
44
 
@@ -925,7 +925,7 @@
45
 
                                DEBUG_MSG("found entry with filetype %s\n",strarr[0]);
46
 
                                if (strcmp(strarr[0], pd->hpd.selected_filetype)==0) {
47
 
                                        GtkTreeIter iter;
48
 
-                                       DEBUG_MSG("highlightpattern_popmenu_activate, appending pattern %s with filetype %s\n",strarr[1],strarr[0]);
49
 
+                                       DEBUG_MSG("highlightpattern_fill_from_selected_filetype, appending pattern %s with filetype %s\n",strarr[1],strarr[0]);
50
 
                                        gtk_list_store_append(GTK_LIST_STORE(pd->hpd.lstore), &iter);
51
 
                                        gtk_list_store_set(GTK_LIST_STORE(pd->hpd.lstore), &iter, 0, strarr[1], -1);
52
 
                                }
53
 
@@ -951,7 +951,9 @@
54
 
        highlightpattern_apply_changes(pd);
55
 
        pd->hpd.curstrarr = NULL;
56
 
        if (menuitem) {
57
 
-               pd->hpd.selected_filetype = gtk_label_get_text(GTK_LABEL(GTK_BIN(menuitem)->child));
58
 
+               if (pd->hpd.selected_filetype)
59
 
+                       g_free (pd->hpd.selected_filetype);
60
 
+               pd->hpd.selected_filetype = g_strdup (gtk_label_get_text(GTK_LABEL(GTK_BIN(menuitem)->child)));
61
 
        }
62
 
        highlightpattern_fill_from_selected_filetype(pd);
63
 
 }
64
 
@@ -1211,6 +1213,7 @@
65
 
                
66
 
                select = gtk_tree_view_get_selection(GTK_TREE_VIEW(pd->hpd.lview));
67
 
                g_signal_connect(G_OBJECT(select), "changed",G_CALLBACK(highlightpattern_selection_changed_cb),pd);
68
 
+               gtk_tree_selection_set_mode (select, GTK_SELECTION_SINGLE);
69
 
        }
70
 
 
71
 
        vbox3 = gtk_vbox_new(FALSE, 2);
72
 
@@ -1809,6 +1812,9 @@
73
 
        pd->lists[browsers] = NULL;
74
 
        pd->lists[external_commands] = NULL;
75
 
 
76
 
+       if (pd->hpd.selected_filetype)
77
 
+               g_free (pd->hpd.selected_filetype);
78
 
+
79
 
 /*     select = gtk_tree_view_get_selection(GTK_TREE_VIEW(pd->ftd.lview));
80
 
        g_signal_handlers_destroy(G_OBJECT(select));*/
81
 
        DEBUG_MSG("preferences_destroy_lcb, destroying handlers for lstore %p\n",pd->ftd.lstore);