~ubuntu-branches/ubuntu/natty/lirc/natty

« back to all changes in this revision

Viewing changes to debian/patches/21_atiusb

  • Committer: Bazaar Package Importer
  • Author(s): Mario Limonciello, Jeremy Yoder, Mario Limonciello
  • Date: 2009-10-12 21:16:10 UTC
  • mfrom: (1.2.9 upstream)
  • Revision ID: james.westby@ubuntu.com-20091012211610-z63bnon17ahmxgd1
Tags: 0.8.6-0ubuntu1
[ Jeremy Yoder ]
* Update to LIRC 0.8.6 release. (LP: #432678)
  - added support for ENE KB3926 revision B/C/D (ENE0100) CIR port
    (found on some notebooks, e.g: Acer Aspire 5720G, HP Pavilion dv5)
    (Maxim Levitsky)
  - New parameter for lircd: --repeat-max
  - merged 1st-gen mceusb device support into lirc_mceusb2,
    renamed lirc_mceusb2 to lirc_mceusb
  - added support for putting iMON receviers into MCE/RC6 mode
  - added input subsystem mouse device support to iMON driver
  - improved iMON driver to handle dual-interface iMON devices
    via a single lirc device, reducing configuration complexity
  - added support for more iMON devices, including proper support
    for touchscreen iMON devices (Rene Harder)
  - improved iMON driver including touchscreen support
  - Linux input support added to lircmd
  - added support for IT8720 CIR port
  - added support for XMP protocol
* Cleanup more_remotes.hwdb
* TODO:  Make changes to the "lircd.conf.atiusb" and
  "lircd.conf.hauppauge" files PATCHES instead of duplicates
* TODO:  Submit "lircd.conf.atiusb" and
  "lircd.conf.hauppauge" file patches upstream again
* Changed lirc init script to create socket in /var/run/lirc/lircd
  as is the new default, but also create a symlink /dev/lircd
  to point to it.  This makes all clients happy, old and new.
* Fix bug in dkms.conf.in, forgot to increment array number
  when adding ene0100 driver.
* Added the extra "Debian-only" remotes and transmitters back
  in, but in a different way.  I created a subdirectory 
  "debian/extras" and copy that to /usr/share/lirc/extras.
  This avoids patching the source.
  NOTE: CONFIG FILES IN BOTH LOCATIONS WILL USE THE "extras"
  VERSION.  DUPLICATE LINES IN lirc.hwdb AND extras/remotes.hwdb
  WILL USE THE extras/remotes.hwdb VERSION.  TRY TO AVOID THIS.
* Added support to build new ene0100 driver
* Update debian/lircd.init.d to reflect new default
  PID location in /var/run/lirc
* Update debian/lircd.init.d to force socket to /dev/lircd
  rather than the new default of /var/run/lirc/lircd
* Add support for new lirc-extras package to
  debian/lirc.postinst
* Remove /etc/lircd.conf link to /etc/lirc since
  0.8.6 defaults to /etc/lirc/lircd.conf now
* Drop 04_man_pages patch, included in upstream
* Drop 16_lirc-gpio in favor of a sed line in debian/rules
* Drop 28_irrecord_resume_support - Doesn't work
  according to upstream
* Drop 36_remove_extra_tekram in favor of a minor
  tweak to debian/lirc.postinst to ignore duplicates
* Drop extra remote control/transmitter patches, move to lirc-extras:
  - 21_atiusb
  - 22_hauppauge_novat_500
  - 23_remove_md8800
  - 24_freecom_dvbt
  - 26_transmitter_lircd.conf
  - 30_medion_md1_remote
  - 31_hauppauge_hvr_1100
  - 32_radioshack_15_2116_remote
  - 33_asus_mycinema_remote
  - 34_nebula_digitaltv_remote
  - 35_general_deviniput
  - 37_msi_tv_anywhere
  - 38_encore_enltv
* Cleaned up a few lintian warnings

[ Mario Limonciello ]
* lirc.init.d:
  - Merge a bunch of whitespace cleanup from debian.
* control:
  - Merge whitespace cleanup from debian.
  - Drop breaks on udev.  We don't have any older version of udev in karmic.
* copyright:
  - Sync from debian.
* watch:
  - Sync from debian.
* links:
  - Don't link to a transmitterdb, this should be provided by lirc-extras.
* rules:
  - Install extra changelog, as mentioned in debian's debian/rules.
* dkms.conf.in:
  - Drop bashisms. (LP: #445175)
* lirc.postinst:
  - On upgrades from earlier versions, require the user to reconfigure
    their remote and transmitter.
* lirc-modules-source.postinst:
  - Update to use the DKMS common postinst template.
 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 21_atiusb.dpatch by Mario Limonciello <superm1@ubuntu.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Make ATI Remotes have their own menu item and add snapstream support (LP: #140060)
6
 
 
7
 
@DPATCH@
8
 
Index: lirc-0.8.5/doc/lirc.hwdb
9
 
===================================================================
10
 
--- lirc-0.8.5.orig/doc/lirc.hwdb       2009-06-15 01:52:37.000000000 -0500
11
 
+++ lirc-0.8.5/doc/lirc.hwdb    2009-06-15 01:53:45.000000000 -0500
12
 
@@ -117,9 +117,9 @@
13
 
 ADSTech USBX-707 USB IR Blaster;usbx;none;hw_usbx;adstech/lircd.conf.usbx-707;
14
 
 Apple Mac mini USB IR Receiver;macmini;none;hw_macmini;apple/lircd.conf.macmini;
15
 
 Asus DH USB Remote;asusdh;none;hw_asusdh;asus/lircd.conf.asusdh;
16
 
-ATI/NVidia/X10 I & II RF Remote;atiusb;lirc_dev lirc_atiusb;hw_default;atiusb/lircd.conf.atiusb;
17
 
-ATI/NVidia/X10 RF Remote (userspace);atilibusb;none;hw_atilibusb;atiusb/lircd.conf.atilibusb;
18
 
-Awox RF/IR Remote (userspace);awlibusb;none;hw_awlibusb;awlibusb/lircd.conf.awlibusb;
19
 
+ATI/NVidia X10 RF (kernel);atiusb;lirc_dev lirc_atiusb;hw_default;atiusb/lircd.conf.atiusb;
20
 
+ATI/NVidia X10 RF (userspace);atilibusb;none;hw_atilibusb;atiusb/lircd.conf.atilibusb;
21
 
+Snapstream X10 RF;atiusb;lirc_dev lirc_atiusb;hw_default;atiusb/lircd.conf.atiusb;Awox RF/IR Remote (userspace);awlibusb;none;hw_awlibusb;awlibusb/lircd.conf.awlibusb;
22
 
 Creative USB IR Receiver (SB0540);sb0540;none;hw_sb0540;creative/lircd.conf.alsa_usb;
23
 
 CommandIR Multi-IR Transceiver (userspace);commandir;none;hw_commandir;hauppauge/lircd.conf.hauppauge;
24
 
 Dign HV5 HTPC IR/VFD Module;sasem;lirc_dev lirc_sasem;hw_default;sasem/lircd.conf.sasem;
25
 
Index: lirc-0.8.5/remotes/atiusb/lircd.conf.atiusb
26
 
===================================================================
27
 
--- lirc-0.8.5.orig/remotes/atiusb/lircd.conf.atiusb    2008-03-16 08:59:29.000000000 -0500
28
 
+++ lirc-0.8.5/remotes/atiusb/lircd.conf.atiusb 2009-06-15 01:52:43.000000000 -0500
29
 
@@ -191,7 +191,7 @@
30
 
 # this config file was automatically generated
31
 
 # using lirc-0.7.0-CVS(atiusb) on Sat May 15 10:44:51 2004
32
 
 #
33
 
-# contributed by Jurgen Kramer 
34
 
+# contributed by Jurgen Kramer
35
 
 #
36
 
 # brand: ATI
37
 
 # model no. of remote control: 5000023600
38
 
@@ -365,7 +365,7 @@
39
 
 # matching MythTV configuration file at http://wendy.seltzer.org/mythtv/lircrc
40
 
 #
41
 
 #
42
 
-# brand:       X-10 Lola                       
43
 
+# brand:       X-10 Lola
44
 
 # model no. of remote control:  UR89A
45
 
 # devices being controlled by this remote: mythtv
46
 
 #
47
 
@@ -379,7 +379,7 @@
48
 
 
49
 
   one             0     0
50
 
   zero            0     0
51
 
-  
52
 
+
53
 
   pre_data_bits   8
54
 
   pre_data       0x14
55
 
   post_data_bits  16
56
 
@@ -525,10 +525,10 @@
57
 
 # contributed by Martin Tomasek <mtd@centrum.cz>
58
 
 #
59
 
 # brand: ATI Remote Wonder
60
 
-# model no. of remote control: 
61
 
+# model no. of remote control:
62
 
 # devices being controlled by this remote: ATI USB Receiver (X10).
63
 
 #
64
 
-# * remote is set to channel 1, driver reports channel 16. don't know 
65
 
+# * remote is set to channel 1, driver reports channel 16. don't know
66
 
 # which is true.
67
 
 
68
 
 #
69
 
@@ -615,7 +615,7 @@
70
 
 # contributed by Phil Speights
71
 
 #
72
 
 # brand: nvidia
73
 
-# model no. of remote control: UR88A 
74
 
+# model no. of remote control: UR88A
75
 
 # devices being controlled by this remote: nvidia personal cinema
76
 
 #
77
 
 
78
 
@@ -875,10 +875,10 @@
79
 
 # this config file was automatically generated
80
 
 # using lirc-0.7.0(any) on Sun Jan 16 14:58:13 2005
81
 
 #
82
 
-# contributed by 
83
 
+# contributed by
84
 
 #
85
 
 # brand:                       Niveus
86
 
-# model no. of remote control: 
87
 
+# model no. of remote control:
88
 
 # devices being controlled by this remote: Niveus X10
89
 
 #
90
 
 
91
 
@@ -1024,7 +1024,7 @@
92
 
         Info            0x84af
93
 
         Menu            0x6e99
94
 
         left            0x729d
95
 
-        up_0            0x4d78  
96
 
+        up_0            0x4d78
97
 
         up_1            0x4e79
98
 
         up_2            0x4f7a
99
 
         up_3            0x507b
100
 
@@ -1064,7 +1064,7 @@
101
 
         Record          0x7ca7
102
 
         FastForward     0x7ba6
103
 
 
104
 
-    end codes  
105
 
+    end codes
106
 
 end remote
107
 
 
108
 
 
109
 
@@ -1076,7 +1076,7 @@
110
 
 #
111
 
 # brand: MEDION X10 RF
112
 
 # model no. of remote control: remote P/N:20014752, receiver P/N:20014751
113
 
-# devices being controlled by this remote: 
114
 
+# devices being controlled by this remote:
115
 
 #
116
 
 
117
 
 begin remote
118
 
@@ -1387,7 +1387,7 @@
119
 
 # this config file was automatically generated
120
 
 # using lirc-0.8.0(atiusb) on Mon Dec 11 20:45:22 2006
121
 
 #
122
 
-# contributed by Wim Lemmers 
123
 
+# contributed by Wim Lemmers
124
 
 #
125
 
 # brand:                       Medion
126
 
 # model no. of remote control: OR24E RF MCE Remote Control
127
 
@@ -1469,7 +1469,7 @@
128
 
 #
129
 
 # contributed by Harald Wild - www.wild-technology.de
130
 
 #
131
 
-# brand: Q-Sonic Master Remote PC / TV 
132
 
+# brand: Q-Sonic Master Remote PC / TV
133
 
 # model no. of remote control: Art.Nr. PE-9999
134
 
 # frequency: 433.92 MHz
135
 
 # distributor Germany: PEARL AGENCY - www.pearl.de
136
 
@@ -1701,9 +1701,9 @@
137
 
 # this config file was automatically generated
138
 
 # using lirc-0.8.2-CVS(atilibusb) on Fri Jun  8 13:19:29 2007
139
 
 #
140
 
-# contributed by 
141
 
+# contributed by
142
 
 #
143
 
-# brand:                       
144
 
+# brand:
145
 
 # model no. of remote control: ATI/X10 RF USB Remote Control v. 2.2.1
146
 
 # devices being controlled by this remote:
147
 
 #
148
 
@@ -1936,6 +1936,120 @@
149
 
 
150
 
 end remote
151
 
 
152
 
+begin remote
153
 
+
154
 
+name Snapstream Firefly
155
 
+bits 40
156
 
+eps 30
157
 
+aeps 100
158
 
+
159
 
+one 0 0
160
 
+zero 0 0
161
 
+gap 219964
162
 
+toggle_bit 0
163
 
+
164
 
+
165
 
+begin codes
166
 
+MAXI 0x0000001481AC0000
167
 
+MAXI 0x00000014012C0000
168
 
+CLOSE 0x00000014D7020000
169
 
+CLOSE 0x0000001457820000
170
 
+1 0x00000014628D0000
171
 
+1 0x00000014E20D0000
172
 
+2 0x00000014E30E0000
173
 
+2 0x00000014638E0000
174
 
+3 0x00000014648F0000
175
 
+3 0x00000014E40F0000
176
 
+4 0x00000014E5100000
177
 
+4 0x0000001465900000
178
 
+5 0x0000001466910000
179
 
+5 0x00000014E6110000
180
 
+6 0x00000014E7120000
181
 
+6 0x0000001467920000
182
 
+7 0x0000001468930000
183
 
+7 0x00000014E8130000
184
 
+8 0x00000014E9140000
185
 
+8 0x0000001469940000
186
 
+9 0x000000146A950000
187
 
+9 0x00000014EA150000
188
 
+0 0x00000014EC170000
189
 
+0 0x000000146C970000
190
 
+BACK 0x000000146B960000
191
 
+BACK 0x00000014EB160000
192
 
+ENT 0x00000014ED180000
193
 
+ENT 0x000000146D980000
194
 
+VOL+ 0x000000145E890000
195
 
+VOL+ 0x00000014DE090000
196
 
+VOL- 0x000000145D880000
197
 
+VOL- 0x00000014DD080000
198
 
+MUTE 0x000000145F8A0000
199
 
+MUTE 0x00000014DF0A0000
200
 
+FIREFLY 0x0000001455800000
201
 
+FIREFLY 0x00000014D5000000
202
 
+CH+ 0x00000014608B0000
203
 
+CH+ 0x00000014E00B0000
204
 
+CH- 0x00000014618C0000
205
 
+CH- 0x00000014E10C0000
206
 
+INFO 0x0000001483AE0000
207
 
+INFO 0x00000014032E0000
208
 
+OPTION 0x0000001484AF0000
209
 
+OPTION 0x00000014042F0000
210
 
+UP 0x000000146F9A0000
211
 
+UP 0x00000014EF1A0000
212
 
+LEFT 0x00000014729D0000
213
 
+LEFT 0x00000014F21D0000
214
 
+DOWN 0x0000001477A20000
215
 
+DOWN 0x00000014F7220000
216
 
+RIGHT 0x00000014749F0000
217
 
+RIGHT 0x00000014F41F0000
218
 
+OK 0x00000014739E0000
219
 
+OK 0x00000014F31E0000
220
 
+MENU 0x00000014719C0000
221
 
+MENU 0x00000014F11C0000
222
 
+EXIT 0x0000001475A00000
223
 
+EXIT 0x00000014F5200000
224
 
+REC 0x00000014FC270000
225
 
+REC 0x000000147CA70000
226
 
+PLAY 0x00000014FA250000
227
 
+PLAY 0x000000147AA50000
228
 
+STOP 0x00000014FD280000
229
 
+STOP 0x000000147DA80000
230
 
+REW 0x00000014F9240000
231
 
+REW 0x0000001479A40000
232
 
+FWD 0x00000014FB260000
233
 
+FWD 0x000000147BA60000
234
 
+PREV 0x00000014002B0000
235
 
+PREV 0x0000001480AB0000
236
 
+PAUSE 0x00000014FE290000
237
 
+PAUSE 0x000000147EA90000
238
 
+NEXT 0x00000014FF2A0000
239
 
+NEXT 0x000000147FAA0000
240
 
+MUSIC 0x00000014DB060000
241
 
+MUSIC 0x000000145B860000
242
 
+PHOTOS 0x00000014DA050000
243
 
+PHOTOS 0x000000145A850000
244
 
+DVD 0x00000014D9040000
245
 
+DVD 0x0000001459840000
246
 
+TV 0x00000014D8030000
247
 
+TV 0x0000001458830000
248
 
+VIDEO 0x00000014DC070000
249
 
+VIDEO 0x000000145C870000
250
 
+HELP 0x00000014D6010000
251
 
+HELP 0x0000001456810000
252
 
+MOUSE 0x00000014022D0000
253
 
+MOUSE 0x0000001482AD0000
254
 
+A 0x00000014EE190000
255
 
+A 0x000000146E990000
256
 
+B 0x00000014F01B0000
257
 
+B 0x00000014709B0000
258
 
+C 0x00000014F6210000
259
 
+C 0x0000001476A10000
260
 
+D 0x00000014F8230000
261
 
+D 0x0000001478A30000
262
 
+
263
 
+end codes
264
 
+
265
 
+end remote
266
 
 
267
 
 #
268
 
 # this config file was automatically generated