~ubuntu-branches/ubuntu/natty/lirc/natty

« back to all changes in this revision

Viewing changes to debian/patches/24_freecom_dvbt

  • Committer: Bazaar Package Importer
  • Author(s): Mario Limonciello, Jeremy Yoder, Mario Limonciello
  • Date: 2009-10-12 21:16:10 UTC
  • mfrom: (1.2.9 upstream)
  • Revision ID: james.westby@ubuntu.com-20091012211610-z63bnon17ahmxgd1
Tags: 0.8.6-0ubuntu1
[ Jeremy Yoder ]
* Update to LIRC 0.8.6 release. (LP: #432678)
  - added support for ENE KB3926 revision B/C/D (ENE0100) CIR port
    (found on some notebooks, e.g: Acer Aspire 5720G, HP Pavilion dv5)
    (Maxim Levitsky)
  - New parameter for lircd: --repeat-max
  - merged 1st-gen mceusb device support into lirc_mceusb2,
    renamed lirc_mceusb2 to lirc_mceusb
  - added support for putting iMON receviers into MCE/RC6 mode
  - added input subsystem mouse device support to iMON driver
  - improved iMON driver to handle dual-interface iMON devices
    via a single lirc device, reducing configuration complexity
  - added support for more iMON devices, including proper support
    for touchscreen iMON devices (Rene Harder)
  - improved iMON driver including touchscreen support
  - Linux input support added to lircmd
  - added support for IT8720 CIR port
  - added support for XMP protocol
* Cleanup more_remotes.hwdb
* TODO:  Make changes to the "lircd.conf.atiusb" and
  "lircd.conf.hauppauge" files PATCHES instead of duplicates
* TODO:  Submit "lircd.conf.atiusb" and
  "lircd.conf.hauppauge" file patches upstream again
* Changed lirc init script to create socket in /var/run/lirc/lircd
  as is the new default, but also create a symlink /dev/lircd
  to point to it.  This makes all clients happy, old and new.
* Fix bug in dkms.conf.in, forgot to increment array number
  when adding ene0100 driver.
* Added the extra "Debian-only" remotes and transmitters back
  in, but in a different way.  I created a subdirectory 
  "debian/extras" and copy that to /usr/share/lirc/extras.
  This avoids patching the source.
  NOTE: CONFIG FILES IN BOTH LOCATIONS WILL USE THE "extras"
  VERSION.  DUPLICATE LINES IN lirc.hwdb AND extras/remotes.hwdb
  WILL USE THE extras/remotes.hwdb VERSION.  TRY TO AVOID THIS.
* Added support to build new ene0100 driver
* Update debian/lircd.init.d to reflect new default
  PID location in /var/run/lirc
* Update debian/lircd.init.d to force socket to /dev/lircd
  rather than the new default of /var/run/lirc/lircd
* Add support for new lirc-extras package to
  debian/lirc.postinst
* Remove /etc/lircd.conf link to /etc/lirc since
  0.8.6 defaults to /etc/lirc/lircd.conf now
* Drop 04_man_pages patch, included in upstream
* Drop 16_lirc-gpio in favor of a sed line in debian/rules
* Drop 28_irrecord_resume_support - Doesn't work
  according to upstream
* Drop 36_remove_extra_tekram in favor of a minor
  tweak to debian/lirc.postinst to ignore duplicates
* Drop extra remote control/transmitter patches, move to lirc-extras:
  - 21_atiusb
  - 22_hauppauge_novat_500
  - 23_remove_md8800
  - 24_freecom_dvbt
  - 26_transmitter_lircd.conf
  - 30_medion_md1_remote
  - 31_hauppauge_hvr_1100
  - 32_radioshack_15_2116_remote
  - 33_asus_mycinema_remote
  - 34_nebula_digitaltv_remote
  - 35_general_deviniput
  - 37_msi_tv_anywhere
  - 38_encore_enltv
* Cleaned up a few lintian warnings

[ Mario Limonciello ]
* lirc.init.d:
  - Merge a bunch of whitespace cleanup from debian.
* control:
  - Merge whitespace cleanup from debian.
  - Drop breaks on udev.  We don't have any older version of udev in karmic.
* copyright:
  - Sync from debian.
* watch:
  - Sync from debian.
* links:
  - Don't link to a transmitterdb, this should be provided by lirc-extras.
* rules:
  - Install extra changelog, as mentioned in debian's debian/rules.
* dkms.conf.in:
  - Drop bashisms. (LP: #445175)
* lirc.postinst:
  - On upgrades from earlier versions, require the user to reconfigure
    their remote and transmitter.
* lirc-modules-source.postinst:
  - Update to use the DKMS common postinst template.
 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 24_freecom_dvbt.dpatch by Mario Limonciello <superm1@ubuntu.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Adds support for a freecom dvb-t card (LP: #152539).
6
 
 
7
 
@DPATCH@
8
 
diff -urNad lirc-0.8.3~/doc/lirc.hwdb lirc-0.8.3/doc/lirc.hwdb
9
 
--- lirc-0.8.3~/doc/lirc.hwdb   2008-05-10 16:47:09.000000000 -0500
10
 
+++ lirc-0.8.3/doc/lirc.hwdb    2008-05-10 16:47:55.000000000 -0500
11
 
@@ -73,6 +73,7 @@
12
 
 FlyVideo 98 (card=30);flyvideo;devinput;hw_default;life-view/lircd.conf.flyvideo;
13
 
 FlyVideo 98/FM /2000S (card=56);flyvideo;devinput;hw_default;life-view/lircd.conf.flyvideo;
14
 
 Flyvideo 98FM (LR50Q) / Typhoon TView TV/FM Tuner (card=36);flyvideo;devinput;hw_default;life-view/lircd.conf.flyvideo;
15
 
+Freecom DVB-T USB Stick;devinput;none;hw_default;freecom/lircd.conf.freeconf
16
 
 Hauppauge TV card;hauppauge;lirc_dev lirc_i2c;hw_default;hauppauge/lircd.conf.hauppauge;
17
 
 Hauppauge Nova-T 500;devinput;none;hw_devinput;hauppauge/lircd.conf.hauppauge_novat500;
18
 
 Hauppauge HVR-1300;hauppauge;lirc_dev lirc_i2c;hw_default;hauppauge/lircd.conf.hauppauge;
19
 
diff -urNad lirc-0.8.3~/remotes/freecom/lircd.conf.freeconf lirc-0.8.3/remotes/freecom/lircd.conf.freeconf
20
 
--- lirc-0.8.3~/remotes/freecom/lircd.conf.freeconf     1969-12-31 18:00:00.000000000 -0600
21
 
+++ lirc-0.8.3/remotes/freecom/lircd.conf.freeconf      2008-05-10 16:47:09.000000000 -0500
22
 
@@ -0,0 +1,35 @@
23
 
+#Freecom DVB-T Stick
24
 
+#By Nico Rdo
25
 
+
26
 
+begin remote
27
 
+  name Freecom_DVB-T_USB
28
 
+  bits 16
29
 
+  eps 30
30
 
+  aeps 100
31
 
+  one 0 0
32
 
+  zero 0 0
33
 
+  pre_data_bits 16
34
 
+  pre_data 0x8001
35
 
+  gap 237493
36
 
+  toggle_bit 0
37
 
+      begin codes
38
 
+          POWER 0x0074
39
 
+          MUTE 0x0071
40
 
+          0 0x000B
41
 
+          1 0x0002
42
 
+          2 0x0003
43
 
+          3 0x0004
44
 
+          4 0x0005
45
 
+          5 0x0006
46
 
+          6 0x0007
47
 
+          7 0x0008
48
 
+          8 0x0009
49
 
+          9 0x000A
50
 
+          VOL_UP 0x0073
51
 
+          VOL_DOWN 0x0072
52
 
+          CH_UP 0x0192
53
 
+          CH_DOWN 0x0193
54
 
+          ZOOM 0x0174
55
 
+          JUMP 0x0161
56
 
+      end codes
57
 
+end remote