~ubuntu-branches/ubuntu/natty/lirc/natty

« back to all changes in this revision

Viewing changes to debian/patches/38_encore_enltv

  • Committer: Bazaar Package Importer
  • Author(s): Mario Limonciello, Jeremy Yoder, Mario Limonciello
  • Date: 2009-10-12 21:16:10 UTC
  • mfrom: (1.2.9 upstream)
  • Revision ID: james.westby@ubuntu.com-20091012211610-z63bnon17ahmxgd1
Tags: 0.8.6-0ubuntu1
[ Jeremy Yoder ]
* Update to LIRC 0.8.6 release. (LP: #432678)
  - added support for ENE KB3926 revision B/C/D (ENE0100) CIR port
    (found on some notebooks, e.g: Acer Aspire 5720G, HP Pavilion dv5)
    (Maxim Levitsky)
  - New parameter for lircd: --repeat-max
  - merged 1st-gen mceusb device support into lirc_mceusb2,
    renamed lirc_mceusb2 to lirc_mceusb
  - added support for putting iMON receviers into MCE/RC6 mode
  - added input subsystem mouse device support to iMON driver
  - improved iMON driver to handle dual-interface iMON devices
    via a single lirc device, reducing configuration complexity
  - added support for more iMON devices, including proper support
    for touchscreen iMON devices (Rene Harder)
  - improved iMON driver including touchscreen support
  - Linux input support added to lircmd
  - added support for IT8720 CIR port
  - added support for XMP protocol
* Cleanup more_remotes.hwdb
* TODO:  Make changes to the "lircd.conf.atiusb" and
  "lircd.conf.hauppauge" files PATCHES instead of duplicates
* TODO:  Submit "lircd.conf.atiusb" and
  "lircd.conf.hauppauge" file patches upstream again
* Changed lirc init script to create socket in /var/run/lirc/lircd
  as is the new default, but also create a symlink /dev/lircd
  to point to it.  This makes all clients happy, old and new.
* Fix bug in dkms.conf.in, forgot to increment array number
  when adding ene0100 driver.
* Added the extra "Debian-only" remotes and transmitters back
  in, but in a different way.  I created a subdirectory 
  "debian/extras" and copy that to /usr/share/lirc/extras.
  This avoids patching the source.
  NOTE: CONFIG FILES IN BOTH LOCATIONS WILL USE THE "extras"
  VERSION.  DUPLICATE LINES IN lirc.hwdb AND extras/remotes.hwdb
  WILL USE THE extras/remotes.hwdb VERSION.  TRY TO AVOID THIS.
* Added support to build new ene0100 driver
* Update debian/lircd.init.d to reflect new default
  PID location in /var/run/lirc
* Update debian/lircd.init.d to force socket to /dev/lircd
  rather than the new default of /var/run/lirc/lircd
* Add support for new lirc-extras package to
  debian/lirc.postinst
* Remove /etc/lircd.conf link to /etc/lirc since
  0.8.6 defaults to /etc/lirc/lircd.conf now
* Drop 04_man_pages patch, included in upstream
* Drop 16_lirc-gpio in favor of a sed line in debian/rules
* Drop 28_irrecord_resume_support - Doesn't work
  according to upstream
* Drop 36_remove_extra_tekram in favor of a minor
  tweak to debian/lirc.postinst to ignore duplicates
* Drop extra remote control/transmitter patches, move to lirc-extras:
  - 21_atiusb
  - 22_hauppauge_novat_500
  - 23_remove_md8800
  - 24_freecom_dvbt
  - 26_transmitter_lircd.conf
  - 30_medion_md1_remote
  - 31_hauppauge_hvr_1100
  - 32_radioshack_15_2116_remote
  - 33_asus_mycinema_remote
  - 34_nebula_digitaltv_remote
  - 35_general_deviniput
  - 37_msi_tv_anywhere
  - 38_encore_enltv
* Cleaned up a few lintian warnings

[ Mario Limonciello ]
* lirc.init.d:
  - Merge a bunch of whitespace cleanup from debian.
* control:
  - Merge whitespace cleanup from debian.
  - Drop breaks on udev.  We don't have any older version of udev in karmic.
* copyright:
  - Sync from debian.
* watch:
  - Sync from debian.
* links:
  - Don't link to a transmitterdb, this should be provided by lirc-extras.
* rules:
  - Install extra changelog, as mentioned in debian's debian/rules.
* dkms.conf.in:
  - Drop bashisms. (LP: #445175)
* lirc.postinst:
  - On upgrades from earlier versions, require the user to reconfigure
    their remote and transmitter.
* lirc-modules-source.postinst:
  - Update to use the DKMS common postinst template.
 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 38_encore_enltv.dpatch by Mario Limonciello <superm1@ubuntu.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Adds support for Encore ENLTV Remote (LP: #274087)
6
 
 
7
 
@DPATCH@
8
 
diff -urNad lirc-0.8.4a~/doc/lirc.hwdb lirc-0.8.4a/doc/lirc.hwdb
9
 
--- lirc-0.8.4a~/doc/lirc.hwdb  2008-11-08 20:06:04.000000000 -0600
10
 
+++ lirc-0.8.4a/doc/lirc.hwdb   2008-11-08 20:06:04.000000000 -0600
11
 
@@ -70,6 +70,7 @@
12
 
 Chronos Video Shuttle II (card=35);chronos;devinput;hw_default;chronos/lircd.conf.chronos;
13
 
 Creative BreakOut-Box;breakoutbox;lirc_dev lirc_i2c;hw_default;creative/lircd.conf.breakoutbox;
14
 
 Dynalink Magic TView (card=48);cph03x;devinput;hw_default;cph03x/lircd.conf.cph03x;
15
 
+Encore ELTV-FM;encore;lirc_dev lirc_i2c;hw_default;encore/enltv.conf;
16
 
 FlyVideo II (card=8);flyvideo;devinput;hw_default;life-view/lircd.conf.flyvideo;
17
 
 FlyVideo 98 (card=30);flyvideo;devinput;hw_default;life-view/lircd.conf.flyvideo;
18
 
 FlyVideo 98/FM /2000S (card=56);flyvideo;devinput;hw_default;life-view/lircd.conf.flyvideo;
19
 
diff -urNad lirc-0.8.4a~/remotes/encore/enltv.conf lirc-0.8.4a/remotes/encore/enltv.conf
20
 
--- lirc-0.8.4a~/remotes/encore/enltv.conf      1969-12-31 18:00:00.000000000 -0600
21
 
+++ lirc-0.8.4a/remotes/encore/enltv.conf       2008-11-08 20:06:41.000000000 -0600
22
 
@@ -0,0 +1,66 @@
23
 
+begin remote
24
 
+  name            enltv
25
 
+  bits            16
26
 
+  eps             30
27
 
+  aeps            100
28
 
+  one             0 0
29
 
+  zero            0 0
30
 
+  gap             195847
31
 
+  pre_data_bits   16
32
 
+  pre_data        0x8001
33
 
+
34
 
+  begin codes
35
 
+       next            0x0197
36
 
+       ok              0x001C
37
 
+       vol_down        0x00AE
38
 
+       09              0x0067
39
 
+       08              0x006C
40
 
+       07              0x0069
41
 
+       hide            0x006A
42
 
+       winstart        0x0066
43
 
+       recall          0x0175
44
 
+       v_set           0x0179
45
 
+       ch_down         0x0189
46
 
+       music           0x0188
47
 
+       tv/av           0x016F
48
 
+       <--             0x0001
49
 
+       desktop         0x0020
50
 
+       06              0x000F
51
 
+       04              0x00E3
52
 
+       -->             0x008B
53
 
+       05              0x0174
54
 
+       timeshift       0x0167
55
 
+       record          0x00A7
56
 
+       pause_c         0x00CF
57
 
+       stop            0x0080
58
 
+       next2stop       0x00D4
59
 
+       00              0x00A8
60
 
+       fastforward     0x00D0
61
 
+       menu            0x019C
62
 
+       skipforward     0x0197
63
 
+       ch_up           0x016C
64
 
+       pause           0x00D5
65
 
+       dvdlang         0x0170
66
 
+       dvdtext         0x0184
67
 
+       shut            0x0190
68
 
+       main            0x0175
69
 
+       sap             0x0161
70
 
+       teletext        0x0094
71
 
+       ap1             0x018E
72
 
+       ap2             0x018F
73
 
+       ap4             0x0191
74
 
+       03              0x0002
75
 
+       2               0x0003
76
 
+       -/--            0x0004
77
 
+       snap            0x0005
78
 
+       5               0x0006
79
 
+       mute            0x0007
80
 
+       7               0x0008
81
 
+       8               0x0009
82
 
+       9               0x0004
83
 
+       02              0x000A
84
 
+       v_def           0x000B
85
 
+       01              0x018B
86
 
+
87
 
+  end codes
88
 
+end remote