~ubuntu-branches/ubuntu/natty/lirc/natty

« back to all changes in this revision

Viewing changes to debian/patches/30_medion_md1_remote

  • Committer: Bazaar Package Importer
  • Author(s): Mario Limonciello, Jeremy Yoder, Mario Limonciello
  • Date: 2009-10-12 21:16:10 UTC
  • mfrom: (1.2.9 upstream)
  • Revision ID: james.westby@ubuntu.com-20091012211610-z63bnon17ahmxgd1
Tags: 0.8.6-0ubuntu1
[ Jeremy Yoder ]
* Update to LIRC 0.8.6 release. (LP: #432678)
  - added support for ENE KB3926 revision B/C/D (ENE0100) CIR port
    (found on some notebooks, e.g: Acer Aspire 5720G, HP Pavilion dv5)
    (Maxim Levitsky)
  - New parameter for lircd: --repeat-max
  - merged 1st-gen mceusb device support into lirc_mceusb2,
    renamed lirc_mceusb2 to lirc_mceusb
  - added support for putting iMON receviers into MCE/RC6 mode
  - added input subsystem mouse device support to iMON driver
  - improved iMON driver to handle dual-interface iMON devices
    via a single lirc device, reducing configuration complexity
  - added support for more iMON devices, including proper support
    for touchscreen iMON devices (Rene Harder)
  - improved iMON driver including touchscreen support
  - Linux input support added to lircmd
  - added support for IT8720 CIR port
  - added support for XMP protocol
* Cleanup more_remotes.hwdb
* TODO:  Make changes to the "lircd.conf.atiusb" and
  "lircd.conf.hauppauge" files PATCHES instead of duplicates
* TODO:  Submit "lircd.conf.atiusb" and
  "lircd.conf.hauppauge" file patches upstream again
* Changed lirc init script to create socket in /var/run/lirc/lircd
  as is the new default, but also create a symlink /dev/lircd
  to point to it.  This makes all clients happy, old and new.
* Fix bug in dkms.conf.in, forgot to increment array number
  when adding ene0100 driver.
* Added the extra "Debian-only" remotes and transmitters back
  in, but in a different way.  I created a subdirectory 
  "debian/extras" and copy that to /usr/share/lirc/extras.
  This avoids patching the source.
  NOTE: CONFIG FILES IN BOTH LOCATIONS WILL USE THE "extras"
  VERSION.  DUPLICATE LINES IN lirc.hwdb AND extras/remotes.hwdb
  WILL USE THE extras/remotes.hwdb VERSION.  TRY TO AVOID THIS.
* Added support to build new ene0100 driver
* Update debian/lircd.init.d to reflect new default
  PID location in /var/run/lirc
* Update debian/lircd.init.d to force socket to /dev/lircd
  rather than the new default of /var/run/lirc/lircd
* Add support for new lirc-extras package to
  debian/lirc.postinst
* Remove /etc/lircd.conf link to /etc/lirc since
  0.8.6 defaults to /etc/lirc/lircd.conf now
* Drop 04_man_pages patch, included in upstream
* Drop 16_lirc-gpio in favor of a sed line in debian/rules
* Drop 28_irrecord_resume_support - Doesn't work
  according to upstream
* Drop 36_remove_extra_tekram in favor of a minor
  tweak to debian/lirc.postinst to ignore duplicates
* Drop extra remote control/transmitter patches, move to lirc-extras:
  - 21_atiusb
  - 22_hauppauge_novat_500
  - 23_remove_md8800
  - 24_freecom_dvbt
  - 26_transmitter_lircd.conf
  - 30_medion_md1_remote
  - 31_hauppauge_hvr_1100
  - 32_radioshack_15_2116_remote
  - 33_asus_mycinema_remote
  - 34_nebula_digitaltv_remote
  - 35_general_deviniput
  - 37_msi_tv_anywhere
  - 38_encore_enltv
* Cleaned up a few lintian warnings

[ Mario Limonciello ]
* lirc.init.d:
  - Merge a bunch of whitespace cleanup from debian.
* control:
  - Merge whitespace cleanup from debian.
  - Drop breaks on udev.  We don't have any older version of udev in karmic.
* copyright:
  - Sync from debian.
* watch:
  - Sync from debian.
* links:
  - Don't link to a transmitterdb, this should be provided by lirc-extras.
* rules:
  - Install extra changelog, as mentioned in debian's debian/rules.
* dkms.conf.in:
  - Drop bashisms. (LP: #445175)
* lirc.postinst:
  - On upgrades from earlier versions, require the user to reconfigure
    their remote and transmitter.
* lirc-modules-source.postinst:
  - Update to use the DKMS common postinst template.
 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 30_medion_md1_remote.dpatch by Mario Limonciello <superm1@ubuntu.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Add support for the Medion MD1-NBC Remote (LP: #192392)
6
 
 
7
 
@DPATCH@
8
 
diff -urNad lirc-0.8.3~/doc/lirc.hwdb lirc-0.8.3/doc/lirc.hwdb
9
 
--- lirc-0.8.3~/doc/lirc.hwdb   2008-05-10 16:58:32.000000000 -0500
10
 
+++ lirc-0.8.3/doc/lirc.hwdb    2008-05-10 16:59:39.000000000 -0500
11
 
@@ -127,6 +127,7 @@
12
 
 Home Electronics Tira USB device;tira;none;hw_tira;;
13
 
 Igor Cesko's USB IR Receiver;igorplugusb;lirc_dev lirc_igorplugusb;hw_default;;
14
 
 Iguanaworks USB IR Transceiver;iguanaIR;none;hw_iguanaIR;;
15
 
+Medion MD1 NBC;atilibusb;none;hw_atilibusb;medion/md1-nbc.conf;
16
 
 IRLink VS USB IR Receiver;irlink;none;hw_irlink;;
17
 
 PCMAK USB receiver;pcmak_usb;none;hw_pcmak;pcmak/lircd.conf.pcmak;
18
 
 Remotec Multimedia PC Remote BW6130;bw6130;none;hw_bw6130;remotec/lircd.conf.BW6130;
19
 
diff -urNad lirc-0.8.3~/remotes/medion/md1-nbc.conf lirc-0.8.3/remotes/medion/md1-nbc.conf
20
 
--- lirc-0.8.3~/remotes/medion/md1-nbc.conf     1969-12-31 18:00:00.000000000 -0600
21
 
+++ lirc-0.8.3/remotes/medion/md1-nbc.conf      2008-05-10 16:58:32.000000000 -0500
22
 
@@ -0,0 +1,65 @@
23
 
+begin remote
24
 
+  name  medion
25
 
+  bits           16
26
 
+  eps            30
27
 
+  aeps          100
28
 
+  one             0     0
29
 
+  zero            0     0
30
 
+  pre_data_bits   8
31
 
+  pre_data       0x14
32
 
+  post_data_bits  16
33
 
+  post_data      0x0
34
 
+  gap          219967
35
 
+  toggle_bit_mask 0x80800000
36
 
+
37
 
+      begin codes
38
 
+          1                        0xE20D
39
 
+          2                        0x638E
40
 
+          3                        0xE40F
41
 
+          4                        0x6590
42
 
+          5                        0xE611
43
 
+          6                        0x6792
44
 
+          7                        0xE813
45
 
+          8                        0x6994
46
 
+          9                        0xEA15
47
 
+          0                        0x6C97
48
 
+          Play                     0xFA25
49
 
+          Pause                    0x7EA9
50
 
+          Stop                     0xFD28
51
 
+          Record                   0x7CA7
52
 
+          SkipNext                 0xF823
53
 
+          SkipPrior                0x76A1
54
 
+          Forward                  0xFB26
55
 
+          Rewind                   0x79A4
56
 
+          snapshot                 0xED18
57
 
+          red                      0x87B2
58
 
+          yellow                   0x0934
59
 
+          blue                     0x8AB5
60
 
+          green                    0x0833
61
 
+          Mute                     0x5580
62
 
+          return                   0xF11C
63
 
+          VolUp                    0x5E89
64
 
+          VolDown                  0xDD08
65
 
+          ChanUp                   0x608B
66
 
+          ChanDown                 0xE10C
67
 
+          menu                     0x6E99
68
 
+          back                     0xF520
69
 
+          Left                     0x729D
70
 
+          Right                    0xF41F
71
 
+          Up                       0xCDF8
72
 
+          Down                     0x4570
73
 
+          tv                       0x81AC
74
 
+          Videos                   0x022D
75
 
+          DVD                      0x5984
76
 
+          Guide                    0xEB16
77
 
+          Music                    0x5B86
78
 
+          Radio                    0x032E
79
 
+          book                     0x86B1
80
 
+          Pictures                 0xDA05
81
 
+          info                     0x84AF
82
 
+          Power                    0xD702
83
 
+          ok                       0x709B
84
 
+          enter                    0xF31E
85
 
+      end codes
86
 
+
87
 
+end remote