~ubuntu-branches/ubuntu/oneiric/mozc/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/protoc.patch

  • Committer: Bazaar Package Importer
  • Author(s): Nobuhiro Iwamatsu
  • Date: 2010-07-14 03:26:47 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20100714032647-13qjisj6m8cm8jdx
Tags: 0.12.410.102-1
* New upstream release (Closes: #588971).
  - Add mozc-server, mozc-utils-gui and scim-mozc packages.
* Update debian/rules.
  Add --gypdir option to build_mozc.py.
* Update debian/control.
  - Bumped standards-version to 3.9.0.
  - Update description.
* Add mozc icon (Closes: #588972).
* Add patch which revises issue 18.
  ibus_mozc_issue18.patch
* kFreeBSD build support.
  support_kfreebsd.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
# Copyright Nobuhiro Iwamatsu <iwamatsu@debian.org>
2
 
3
 
# Change to use the debian package
4
 
 
5
 
--- a/dictionary/dictionary.gyp 2010-05-12 05:12:21.000000000 +0900
6
 
+++ b/dictionary/dictionary.gyp 2010-05-12 05:14:25.000000000 +0900
7
 
@@ -105,7 +105,7 @@
8
 
           'action': [
9
 
             'python', '../build_tools/run_after_chdir.py',
10
 
             '<(DEPTH)',
11
 
-            '<(relative_dir)/<(mozc_build_tools_dir)/protoc<(EXECUTABLE_SUFFIX)',
12
 
+            'protoc<(EXECUTABLE_SUFFIX)',
13
 
             '<(relative_dir)/<(RULE_INPUT_NAME)',
14
 
             '--cpp_out=<(proto_out_dir)',
15
 
           ],
16
 
--- a/session/session.gyp       2010-05-12 05:13:56.000000000 +0900
17
 
+++ b/session/session.gyp       2010-05-12 05:14:16.000000000 +0900
18
 
@@ -114,7 +114,7 @@
19
 
           'action': [
20
 
             'python', '../build_tools/run_after_chdir.py',
21
 
             '<(DEPTH)',
22
 
-            '<(relative_dir)/<(mozc_build_tools_dir)/protoc<(EXECUTABLE_SUFFIX)',
23
 
+            'protoc<(EXECUTABLE_SUFFIX)',
24
 
             '<(relative_dir)/<(RULE_INPUT_NAME)',
25
 
             '--cpp_out=<(proto_out_dir)',
26
 
           ],
27
 
--- a/ipc/ipc.gyp       2010-05-11 05:40:51.000000000 +0900
28
 
+++ b/ipc/ipc.gyp       2010-05-12 05:15:18.000000000 +0900
29
 
@@ -78,7 +78,7 @@
30
 
           'action': [
31
 
             'python', '../build_tools/run_after_chdir.py',
32
 
             '<(DEPTH)',
33
 
-            '<(relative_dir)/<(mozc_build_tools_dir)/protoc<(EXECUTABLE_SUFFIX)',
34
 
+            'protoc<(EXECUTABLE_SUFFIX)',
35
 
             '<(relative_dir)/<(RULE_INPUT_NAME)',
36
 
             '--cpp_out=<(proto_out_dir)',
37
 
           ],
38
 
--- a/prediction/prediction.gyp 2010-05-12 05:15:46.000000000 +0900
39
 
+++ b/prediction/prediction.gyp 2010-05-12 05:15:58.000000000 +0900
40
 
@@ -169,7 +169,7 @@
41
 
           'action': [
42
 
             'python', '../build_tools/run_after_chdir.py',
43
 
             '<(DEPTH)',
44
 
-            '<(relative_dir)/<(mozc_build_tools_dir)/protoc<(EXECUTABLE_SUFFIX)',
45
 
+            'protoc<(EXECUTABLE_SUFFIX)',
46
 
             '<(relative_dir)/<(RULE_INPUT_NAME)',
47
 
             '--cpp_out=<(proto_out_dir)',
48
 
           ],
49
 
--- a/usage_stats/usage_stats.gyp       2010-05-12 05:22:07.000000000 +0900
50
 
+++ b/usage_stats/usage_stats.gyp       2010-05-12 05:22:21.000000000 +0900
51
 
@@ -97,7 +97,7 @@
52
 
           'action': [
53
 
             'python', '../build_tools/run_after_chdir.py',
54
 
             '<(DEPTH)',
55
 
-            '<(relative_dir)/<(mozc_build_tools_dir)/protoc<(EXECUTABLE_SUFFIX)',
56
 
+            'protoc<(EXECUTABLE_SUFFIX)',
57
 
             '<(relative_dir)/<(RULE_INPUT_NAME)',
58
 
             '--cpp_out=<(proto_out_dir)',
59
 
           ],