~ubuntu-branches/ubuntu/precise/gnome-do/precise-proposed

« back to all changes in this revision

Viewing changes to debian/patches/02_use_cli_for_wrapper.diff

  • Committer: Bazaar Package Importer
  • Author(s): Christopher James Halse Rogers
  • Date: 2011-02-15 21:50:02 UTC
  • mfrom: (1.1.10 upstream)
  • mto: This revision was merged to the branch mainline in revision 24.
  • Revision ID: james.westby@ubuntu.com-20110215215002-85d0069su39rh04k
Tags: 0.8.4-1
* The long fortold release
  + Fixes a threadsafety issue resulting in 100% CPU usage (Closes: 565591,
    LP: #450852).
  + Proxies all keyring calls to the GTK main thread, as required by the new
    gnome-keyring (Closes: 603876, LP: #553643)
* debian/patches/00_bundledlibs.dpatch:
* debian/rules:
  + Upstream has dropped bundled gmcs binary; now 100% DFSG-free, so we don't
    have to repack the tarball or patch the buildsystem.
* debian/patches/03_disable_docky.dpatch:
  + Drop.  Docky is now gone in the upstream tarball.
* debian/rules:
* debian/control:
* debian/patches/*:
  + Switch to quilt to harmonise with other pkg-cli-* packages.
* debian/control:
  + Drop recommends on gnome-do-docklets.  Docky is now a separate package,
    so the docklets are useless for Do.
  + Bump Breaks on gnome-do-plugins to 0.8.3.  Do no longer provides the Wink
    library, which has been imported into the 0.8.3 do-plugins sources.
  + Bump standards-version; no changes needed.
  + Migrate to git and update VCS fields appropriately

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 02_use_cli_for_wrapper.dpatch by Christopher James Halse Rogers <raof@ubuntu.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Use /usr/bin/cli for the wrapper script instead of calling mono
 
6
## DP: directly.
 
7
## DP: For cli policy conformance.
 
8
 
 
9
@DPATCH@
 
10
diff -urNad gnome-do-0.8.3.1+dfsg~/Do/gnome-do.in gnome-do-0.8.3.1+dfsg/Do/gnome-do.in
 
11
--- gnome-do-0.8.3.1+dfsg~/Do/gnome-do.in       2009-12-08 16:21:50.000000000 +1100
 
12
+++ gnome-do-0.8.3.1+dfsg/Do/gnome-do.in        2009-12-09 12:01:25.200827672 +1100
 
13
@@ -18,8 +18,8 @@
 
14
 
 
15
 # If Do is not running, run it.
 
16
 if pgrep -u "`id -u`" '^gnome-do$' >/dev/null; then
 
17
-       mono "$GNOME_DO_EXE" "$@"
 
18
+       /usr/bin/cli "$GNOME_DO_EXE" "$@"
 
19
 fi
 
20
 while [ "$?" -eq "20" ]; do
 
21
-       mono "$GNOME_DO_EXE" "$@"
 
22
+       /usr/bin/cli "$GNOME_DO_EXE" "$@"
 
23
 done