~ubuntu-branches/ubuntu/precise/mutt/precise

« back to all changes in this revision

Viewing changes to debian/patches/features/trash-folder

  • Committer: Package Import Robot
  • Author(s): أحمد المحمودي (Ahmed El-Mahmoudy)
  • Date: 2010-12-17 14:28:28 UTC
  • mfrom: (16.2.3 experimental)
  • Revision ID: package-import@ubuntu.com-20101217142828-ve8yy0xf1zomtnx9
Tags: 1.5.21-1ubuntu1
* Merge with Debian experimental (LP: #691512), remaining changes:
  + debian/control, debian/patches/debian-specific/build_doc_adjustments.diff:
    Use w3m (main) instead of elinks (universe) for generating documentation.
  + Drop libtokyocabinet-dev (universe) from Build-Depends, use always
    libgdbm-dev and also use gdbm for the header cache backend. (lp: #607448)

Show diffs side-by-side

added added

removed removed

Lines of Context:
46
46
  - Fixed indentation of "appended" in mutt.h.
47
47
 
48
48
== END PATCH
49
 
Index: mutt/commands.c
50
 
===================================================================
51
 
--- mutt.orig/commands.c        2009-06-25 12:35:37.000000000 +0200
52
 
+++ mutt/commands.c     2009-06-25 12:35:48.000000000 +0200
53
 
@@ -716,6 +716,7 @@
 
49
--- a/commands.c
 
50
+++ b/commands.c
 
51
@@ -717,6 +717,7 @@
54
52
     if (option (OPTDELETEUNTAG))
55
53
       mutt_set_flag (Context, h, M_TAG, 0);
56
54
   }
58
56
   
59
57
   return 0;
60
58
 }
61
 
Index: mutt/flags.c
62
 
===================================================================
63
 
--- mutt.orig/flags.c   2009-06-25 12:35:37.000000000 +0200
64
 
+++ mutt/flags.c        2009-06-25 12:35:48.000000000 +0200
 
59
--- a/flags.c
 
60
+++ b/flags.c
65
61
@@ -65,7 +65,13 @@
66
62
       {
67
63
        h->deleted = 0;
95
91
     case M_NEW:
96
92
 
97
93
       if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
98
 
Index: mutt/globals.h
99
 
===================================================================
100
 
--- mutt.orig/globals.h 2009-06-25 12:35:44.000000000 +0200
101
 
+++ mutt/globals.h      2009-06-25 12:35:48.000000000 +0200
 
94
--- a/globals.h
 
95
+++ b/globals.h
102
96
@@ -139,6 +139,7 @@
103
97
 WHERE char *Status;
104
98
 WHERE char *Tempdir;
107
101
 WHERE char *Username;
108
102
 WHERE char *Visual;
109
103
 WHERE char *XtermTitle;
110
 
Index: mutt/imap/message.c
111
 
===================================================================
112
 
--- mutt.orig/imap/message.c    2009-06-25 12:35:37.000000000 +0200
113
 
+++ mutt/imap/message.c 2009-06-25 12:35:48.000000000 +0200
114
 
@@ -867,6 +867,7 @@
 
104
--- a/imap/message.c
 
105
+++ b/imap/message.c
 
106
@@ -876,6 +876,7 @@
115
107
         if (ctx->hdrs[n]->tagged)
116
108
         {
117
109
           mutt_set_flag (ctx, ctx->hdrs[n], M_DELETE, 1);
119
111
           if (option (OPTDELETEUNTAG))
120
112
             mutt_set_flag (ctx, ctx->hdrs[n], M_TAG, 0);
121
113
         }
122
 
@@ -874,6 +875,7 @@
 
114
@@ -883,6 +884,7 @@
123
115
     else
124
116
     {
125
117
       mutt_set_flag (ctx, h, M_DELETE, 1);
127
119
       if (option (OPTDELETEUNTAG))
128
120
         mutt_set_flag (ctx, h, M_TAG, 0);
129
121
     }
130
 
Index: mutt/init.h
131
 
===================================================================
132
 
--- mutt.orig/init.h    2009-06-25 12:35:44.000000000 +0200
133
 
+++ mutt/init.h 2009-06-25 12:35:48.000000000 +0200
134
 
@@ -3180,6 +3180,16 @@
 
122
--- a/init.h
 
123
+++ b/init.h
 
124
@@ -3195,6 +3195,16 @@
135
125
   ** by \fIyou\fP.  The sixth character is used to indicate when a mail
136
126
   ** was sent to a mailing-list you subscribe to.
137
127
   */
148
138
 #ifdef USE_SOCKET
149
139
   { "tunnel",            DT_STR, R_NONE, UL &Tunnel, UL 0 },
150
140
   /*
151
 
Index: mutt/mutt.h
152
 
===================================================================
153
 
--- mutt.orig/mutt.h    2009-06-25 12:35:44.000000000 +0200
154
 
+++ mutt/mutt.h 2009-06-25 12:35:48.000000000 +0200
 
141
--- a/mutt.h
 
142
+++ b/mutt.h
155
143
@@ -187,6 +187,7 @@
156
144
   M_DELETE,
157
145
   M_UNDELETE,
160
148
   M_FLAG,
161
149
   M_TAG,
162
150
   M_UNTAG,
163
 
@@ -702,6 +703,7 @@
 
151
@@ -707,6 +708,7 @@
164
152
   unsigned int mime : 1;               /* has a MIME-Version header? */
165
153
   unsigned int flagged : 1;            /* marked important? */
166
154
   unsigned int tagged : 1;
168
156
   unsigned int deleted : 1;
169
157
   unsigned int changed : 1;
170
158
   unsigned int attach_del : 1;                 /* has an attachment marked for deletion */
171
 
@@ -874,6 +876,7 @@
 
159
@@ -879,6 +881,7 @@
172
160
   int new;                     /* how many new messages? */
173
161
   int unread;                  /* how many unread messages? */
174
162
   int deleted;                 /* how many deleted messages */
176
164
   int flagged;                 /* how many flagged messages */
177
165
   int msgnotreadyet;           /* which msg "new" in pager, -1 if none */
178
166
 
179
 
Index: mutt/muttlib.c
180
 
===================================================================
181
 
--- mutt.orig/muttlib.c 2009-06-25 12:35:37.000000000 +0200
182
 
+++ mutt/muttlib.c      2009-06-25 12:35:48.000000000 +0200
183
 
@@ -1460,7 +1460,9 @@
 
167
--- a/muttlib.c
 
168
+++ b/muttlib.c
 
169
@@ -1515,7 +1515,9 @@
184
170
 
185
171
   if (magic > 0 && !mx_access (s, W_OK))
186
172
   {
191
177
     {
192
178
       snprintf (tmp, sizeof (tmp), _("Append messages to %s?"), s);
193
179
       if ((rc = mutt_yesorno (tmp, M_YES)) == M_NO)
194
 
Index: mutt/mx.c
195
 
===================================================================
196
 
--- mutt.orig/mx.c      2009-06-25 12:35:37.000000000 +0200
197
 
+++ mutt/mx.c   2009-06-25 12:35:48.000000000 +0200
198
 
@@ -773,6 +773,53 @@
 
180
--- a/mx.c
 
181
+++ b/mx.c
 
182
@@ -776,6 +776,53 @@
199
183
   return rc;
200
184
 }
201
185
 
249
233
 /* save changes and close mailbox */
250
234
 int mx_close_mailbox (CONTEXT *ctx, int *index_hint)
251
235
 {
252
 
@@ -909,6 +956,7 @@
 
236
@@ -912,6 +959,7 @@
253
237
          if (mutt_append_message (&f, ctx, ctx->hdrs[i], 0, CH_UPDATE_LEN) == 0)
254
238
          {
255
239
            mutt_set_flag (ctx, ctx->hdrs[i], M_DELETE, 1);
257
241
          }
258
242
          else
259
243
          {
260
 
@@ -931,6 +979,14 @@
 
244
@@ -936,6 +984,14 @@
261
245
     return 0;
262
246
   }
263
247
   
272
256
 #ifdef USE_IMAP
273
257
   /* allow IMAP to preserve the deleted flag across sessions */
274
258
   if (ctx->magic == M_IMAP)
275
 
@@ -1130,6 +1186,12 @@
 
259
@@ -1133,6 +1189,12 @@
276
260
   msgcount = ctx->msgcount;
277
261
   deleted = ctx->deleted;
278
262
 
285
269
 #ifdef USE_IMAP
286
270
   if (ctx->magic == M_IMAP)
287
271
     rc = imap_sync_mailbox (ctx, purge, index_hint);
288
 
Index: mutt/postpone.c
289
 
===================================================================
290
 
--- mutt.orig/postpone.c        2009-06-25 12:35:37.000000000 +0200
291
 
+++ mutt/postpone.c     2009-06-25 12:35:48.000000000 +0200
292
 
@@ -276,6 +276,9 @@
 
272
--- a/postpone.c
 
273
+++ b/postpone.c
 
274
@@ -277,6 +277,9 @@
293
275
   /* finished with this message, so delete it. */
294
276
   mutt_set_flag (PostContext, h, M_DELETE, 1);
295
277