~ubuntu-branches/ubuntu/quantal/sysstat/quantal

« back to all changes in this revision

Viewing changes to debian/patches/00-Makefile.patch

  • Committer: Bazaar Package Importer
  • Author(s): Dave Walker (Daviey)
  • Date: 2011-02-09 17:10:56 UTC
  • mfrom: (1.1.19 upstream) (2.1.11 sid)
  • Revision ID: james.westby@ubuntu.com-20110209171056-ep8aecyxtppsrbnf
Tags: 9.1.7-2ubuntu1
* debian/patches/cflags-ordering.patch: Re-arrange CFLAGS in 
  ./Makefile.in to resolve FTBFS. (LP: #716043)
* debian/control: Updated maintainer, as per policy.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Makefile fixes.
2
2
 
3
 
--- sysstat-9.0.6.1.orig/Makefile.in
4
 
+++ sysstat-9.0.6.1/Makefile.in
5
 
@@ -52,7 +52,6 @@
6
 
 endif
7
 
 MAN1_DIR = $(MAN_DIR)/man1
8
 
 MAN8_DIR = $(MAN_DIR)/man8
9
 
-
10
 
 ifndef DOC_DIR
11
 
 DOC_DIR = @docdir@
12
 
 endif
13
 
@@ -61,9 +60,9 @@
 
3
Index: sysstat/Makefile.in
 
4
===================================================================
 
5
--- sysstat.orig/Makefile.in    2011-02-06 15:40:07.000000000 +0100
 
6
+++ sysstat/Makefile.in 2011-02-07 00:13:26.000000000 +0100
 
7
@@ -61,9 +61,9 @@
14
8
 SYSCONFIG_DIR = @SYSCONFIG_DIR@
15
9
 
16
10
 # Compiler flags
17
11
-CFLAGS = @CFLAGS@ -Wall -Wstrict-prototypes -pipe -O2
18
 
+CFLAGS = @CFLAGS@ -Wall -Wstrict-prototypes -pipe 
 
12
+CFLAGS = @CFLAGS@ -Wall -Wstrict-prototypes -pipe
19
13
 DFLAGS = @DFLAGS@
20
14
-LFLAGS =  -s
21
15
+LFLAGS = @LDFLAGS@
22
 
 # DFLAGS may already contain SMP_RACE definition
23
16
 DFLAGS += -DSA_DIR=\"$(SA_DIR)\" -DSADC_PATH=\"$(SADC_PATH)\"
24
17
 
25
 
@@ -210,8 +209,9 @@
 
18
 # Commands
 
19
@@ -219,8 +219,9 @@
26
20
 locales:
27
21
 endif
28
22
 
29
23
-nls/sysstat.pot: $(wildcard *.c)
30
24
-       $(XGETTEXT) -o $@ -k_ --msgid-bugs-address="sysstat <at> orange.fr" $^
31
 
+.PHONY: nls/sysstat.pot
 
25
+#.PHONY: nls/sysstat.pot
32
26
+nls/sysstat.pot: | $(wildcard *.c)
33
27
+       $(XGETTEXT) -o $@ -k_ --msgid-bugs-address="sysstat <at> orange.fr" $|
34
28
 
35
29
 # Phony targets
36
30
 .PHONY: clean distclean install install_base install_all uninstall \
37
 
@@ -319,7 +319,7 @@
 
31
@@ -253,9 +254,6 @@
 
32
        $(INSTALL_DATA) $(MANGRPARG) man/nfsiostat.1 $(DESTDIR)$(MAN1_DIR)
 
33
        rm -f $(DESTDIR)$(MAN1_DIR)/cifsiostat.1*
 
34
        $(INSTALL_DATA) $(MANGRPARG) man/cifsiostat.1 $(DESTDIR)$(MAN1_DIR)
 
35
-ifeq ($(INSTALL_ISAG),y)
 
36
-       $(INSTALL_DATA) $(MANGRPARG) contrib/isag/isag.1 $(DESTDIR)$(MAN1_DIR)
 
37
-endif
 
38
 ifeq ($(COMPRESS_MANPG),y)
 
39
        $(ZIP) $(DESTDIR)$(MAN8_DIR)/sa1.8
 
40
        $(ZIP) $(DESTDIR)$(MAN8_DIR)/sa2.8
 
41
@@ -332,8 +330,15 @@
 
42
        $(INSTALL_DATA) nls/zh_TW.gmo $(DESTDIR)$(NLS_DIR)/zh_TW/LC_MESSAGES/$(PACKAGE).mo
 
43
 endif
 
44
 
 
45
-install_base: all sa1 sa2 sysstat.sysconfig install_man install_nls \
 
46
-       contrib/isag/isag
 
47
+install_isag: contrib/isag/isag
 
48
+ifeq ($(INSTALL_ISAG),y)
 
49
+       mkdir -p $(DESTDIR)$(BIN_DIR)
 
50
+       mkdir -p $(DESTDIR)$(MAN1_DIR)
 
51
+       $(INSTALL_BIN) contrib/isag/isag $(DESTDIR)$(BIN_DIR)
 
52
+       $(INSTALL_DATA) $(MANGRPARG) contrib/isag/isag.1 $(DESTDIR)$(MAN1_DIR)
 
53
+endif
 
54
+
 
55
+install_base: all sa1 sa2 sysstat.sysconfig install_man install_nls install_isag
 
56
        mkdir -p $(DESTDIR)$(SA_LIB_DIR)
 
57
        mkdir -p $(DESTDIR)$(SA_DIR)
 
58
 ifeq ($(CLEAN_SA_DIR),y)
 
59
@@ -342,7 +347,7 @@
38
60
        -rmdir --ignore-fail-on-non-empty $(DESTDIR)$(SA_DIR)/[0-9]?????
39
61
 endif
40
62
        mkdir -p $(DESTDIR)$(BIN_DIR)
43
65
        mkdir -p $(DESTDIR)$(SYSCONFIG_DIR)
44
66
        $(INSTALL_BIN) sa1 $(DESTDIR)$(SA_LIB_DIR)
45
67
        $(INSTALL_BIN) sa2 $(DESTDIR)$(SA_LIB_DIR)
46
 
@@ -335,12 +335,12 @@
 
68
@@ -354,18 +359,15 @@
 
69
        $(INSTALL_BIN) pidstat $(DESTDIR)$(BIN_DIR)
 
70
        $(INSTALL_BIN) nfsiostat $(DESTDIR)$(BIN_DIR)
 
71
        $(INSTALL_BIN) cifsiostat $(DESTDIR)$(BIN_DIR)
 
72
-ifeq ($(INSTALL_ISAG),y)
 
73
-       $(INSTALL_BIN) contrib/isag/isag $(DESTDIR)$(BIN_DIR)
 
74
-endif
47
75
        $(INSTALL_DATA) sysstat.ioconf $(DESTDIR)$(SYSCONFIG_DIR)
48
76
        $(INSTALL_DATA) sysstat.sysconfig $(DESTDIR)$(SYSCONFIG_DIR)/sysstat
49
77
 ifeq ($(INSTALL_DOC),y)
61
89
+#      $(INSTALL_DATA) *.lsm $(DESTDIR)$(DOC_DIR)
62
90
 endif
63
91
 
64
 
 install_all: install_base crontab sysstat \
65
 
@@ -542,7 +542,7 @@
66
 
        rm -f sadc sar sadf iostat mpstat pidstat *.o *.a core TAGS
 
92
 install_all: install_base cron/crontab sysstat \
 
93
@@ -578,7 +580,7 @@
 
94
        rm -f sadc sar sadf iostat mpstat pidstat nfsiostat cifsiostat *.o *.a core TAGS
67
95
        find nls -name "*.gmo" -exec rm -f {} \;
68
96
 
69
97
-almost-distclean: clean nls/sysstat.pot
70
 
+almost-distclean: clean 
71
 
        rm -f sa1 sa2 sysstat crontab version.h sysconfig.h
72
 
        rm -f sysstat.sysconfig sysstat.crond sysstat.cron.daily
73
 
        rm -f sysstat.cron.hourly sysstat.crond.sample sysstat.crond.sample.in
 
98
+almost-distclean: clean
 
99
        rm -f sa1 sa2 sysstat cron/crontab version.h sysconfig.h
 
100
        rm -f sysstat.sysconfig cron/sysstat.crond cron/sysstat.cron.daily
 
101
        rm -f cron/sysstat.cron.hourly cron/sysstat.crond.sample cron/sysstat.crond.sample.in