~ubuntu-branches/ubuntu/quantal/virtinst/quantal-proposed

« back to all changes in this revision

Viewing changes to debian/patches/0001-fix-path-to-hvmloader.patch

  • Committer: Bazaar Package Importer
  • Author(s): Marc Deslauriers
  • Date: 2011-02-01 15:40:11 UTC
  • mfrom: (1.3.16 experimental)
  • Revision ID: james.westby@ubuntu.com-20110201154011-op0nusgc240xajvb
Tags: 0.500.5-1ubuntu1
* Merge from debian experimental. Remaining changes:
  - debian/patches/9001_Ubuntu.patch:
     + Updated to add maverick and natty to OS list and enable virtio
       for them.
  - debian/patches/9003-fix-path-to-hvmloader-in-testsuite.patch: adjust
    testsuite for 0001-fix-path-to-hvmloader.patch and
    0002-Fix-path-to-pygrub.patch. (refreshed)
  - debian/control: added acl package to depends.
  - Demote virt-viewer to Suggests, as it's in universe.
  - Recommends libvirt-bin
* Removed patches:
  - debian/patches/9002-libvirt_disk_format.patch: Upstream.

Show diffs side-by-side

added added

removed removed

Lines of Context:
4
4
 
5
5
Closes: #487682
6
6
---
7
 
 virtinst/FullVirtGuest.py |    2 +-
 
7
 virtinst/Installer.py |    2 +-
8
8
 1 files changed, 1 insertions(+), 1 deletions(-)
9
9
 
10
 
diff --git a/virtinst/FullVirtGuest.py b/virtinst/FullVirtGuest.py
11
 
index 2e4d1bf..8ca2e1a 100644
12
 
--- a/virtinst/FullVirtGuest.py
13
 
+++ b/virtinst/FullVirtGuest.py
14
 
@@ -66,7 +66,7 @@ class FullVirtGuest(Guest):
15
 
                     self.emulator = "/usr/lib/xen/bin/qemu-dm"
16
 
 
17
 
         if (not self.loader) and self.type == "xen":
18
 
-            self.loader = "/usr/lib/xen/boot/hvmloader"
19
 
+            self.loader = "/usr/lib/xen-default/boot/hvmloader"
20
 
 
21
 
         # Add a default console device
22
 
         dev = VirtualCharDevice.get_dev_instance(self.conn,
 
10
diff --git a/virtinst/Installer.py b/virtinst/Installer.py
 
11
index a0373ea..e77e54d 100644
 
12
--- a/virtinst/Installer.py
 
13
+++ b/virtinst/Installer.py
 
14
@@ -286,7 +286,7 @@ class Installer(XMLBuilderDomain.XMLBuilderDomain):
 
15
         arch = self.arch
 
16
         loader = self.loader
 
17
         if not loader and ishvm and self.type == "xen":
 
18
-            loader = "/usr/lib/xen/boot/hvmloader"
 
19
+            loader = "/usr/lib/xen-default/boot/hvmloader"
 
20
 
 
21
         if not isinstall and not ishvm and not self.bootconfig.kernel:
 
22
             return "<bootloader>%s</bootloader>" % _util.pygrub_path(conn)
23
23
--