~ubuntu-branches/ubuntu/quantal/virtinst/quantal-proposed

« back to all changes in this revision

Viewing changes to debian/patches/0004-virt-install-Fix-CDROM-attach-for-windows-installs.patch

  • Committer: Bazaar Package Importer
  • Author(s): Marc Deslauriers
  • Date: 2011-02-01 15:40:11 UTC
  • mfrom: (1.3.16 experimental)
  • Revision ID: james.westby@ubuntu.com-20110201154011-op0nusgc240xajvb
Tags: 0.500.5-1ubuntu1
* Merge from debian experimental. Remaining changes:
  - debian/patches/9001_Ubuntu.patch:
     + Updated to add maverick and natty to OS list and enable virtio
       for them.
  - debian/patches/9003-fix-path-to-hvmloader-in-testsuite.patch: adjust
    testsuite for 0001-fix-path-to-hvmloader.patch and
    0002-Fix-path-to-pygrub.patch. (refreshed)
  - debian/control: added acl package to depends.
  - Demote virt-viewer to Suggests, as it's in universe.
  - Recommends libvirt-bin
* Removed patches:
  - debian/patches/9002-libvirt_disk_format.patch: Upstream.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Cole Robinson <crobinso@redhat.com>
2
 
Date: Wed, 23 Jun 2010 11:34:16 -0400
3
 
Subject: [PATCH] virt-install: Fix CDROM attach for windows installs
4
 
 
5
 
We were unintentionally dropping the CDROM device for the 2nd stage of the
6
 
install.
7
 
 
8
 
Origin: upstream, http://hg.fedorahosted.org/hg/python-virtinst/rev/e5ab15cd4c24
9
 
---
10
 
 virtinst/Guest.py |    7 ++++---
11
 
 1 files changed, 4 insertions(+), 3 deletions(-)
12
 
 
13
 
diff --git a/virtinst/Guest.py b/virtinst/Guest.py
14
 
index c6a19c9..f6bceea 100644
15
 
--- a/virtinst/Guest.py
16
 
+++ b/virtinst/Guest.py
17
 
@@ -758,6 +758,10 @@ class Guest(object):
18
 
     ############################
19
 
 
20
 
     def _prepare_install(self, meter):
21
 
+        # Empty install dev list
22
 
+        # Warning: moving this to cleanup_install breaks continue_install
23
 
+        self._install_devices = []
24
 
+
25
 
         # Initialize install device list
26
 
         self._install_devices = self.get_all_devices()[:]
27
 
 
28
 
@@ -774,9 +778,6 @@ class Guest(object):
29
 
         self._set_defaults(self._get_install_devs)
30
 
 
31
 
     def _cleanup_install(self):
32
 
-        # Empty install dev list
33
 
-        self._install_devices = []
34
 
-
35
 
         self._installer.cleanup()
36
 
 
37
 
     def _create_devices(self, progresscb):