~ubuntu-branches/ubuntu/saucy/cairo-dock-plug-ins/saucy

« back to all changes in this revision

Viewing changes to debian/patches/01-ubuntuone-fix_upstream-version-2.3.0~2.1.patch

  • Committer: Matthieu Baerts
  • Date: 2011-08-09 19:51:45 UTC
  • mfrom: (1.1.12 upstream)
  • mto: This revision was merged to the branch mainline in revision 21.
  • Revision ID: matttbe@gmail.com-20110809195145-6t55jtykipujuyn5
* New upstream release. (LP: #823514)
* Upstream (short) ChangeLog:
 - The Power-Manager applet has been rewritten to work on any plateform.
 - Compiz-icon applet has been replaced by Composite-Manager.
 - Improved integration in the XFCE, LXDE and GNOME3 desktop.
 - Logout is now working even if there is no/an unknow session manager.
 - Several new DBus methods lets you interact on the dock more easily.
 - Added the possibility to shutdown/logout with GMenu.
 - Improved Status-Notifier and added its own watcher.
 - Added a new applet: Impulse (still need testing).
 - Fixed a few bugs as usual.
* debian/patches:
 - Removed all patches (they was already unapplied).
* debian/copyright:
 - Updated with new files/directory.
* debian/cairo-dock-plug-ins.install:
 - Added status-notifier-watcher used by Status-Notifier applet.
* debian/control:
 - Updated the version of cairo-dock-[core;data;dev].
 - Bump Standard-Version to 3.9.2.
 - Added fftw3, pulse (Impulse) and upower-glib (Logout)
    as new dependences for the build process.
 - Added indicator-[me;messages] as new recommendations
    for cairo-dock-plug-ins (needed for [Me;Messaging]Menu applets).
 - Removed gawk from the build dependences list (no longer needed).
* cairo-dock-plug-ins package needs to be recompiled (LP: #811579)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Matthieu Baerts <matttbe@gmail.com>
2
 
Subject: dnd2share: UbuntuOne backend: wait for the end of the sync before publishing the link (to avoid a crash of u1sdtool)
3
 
Origin: upstream, http://bazaar.launchpad.net/~cairo-dock-team/cairo-dock-plug-ins/2.3.x/revision/1939
4
 
Bug: http://www.glx-dock.org/tt_task.php?p=2&t=187
5
 
Forwarded: yes
6
 
 
7
 
Index: cairo-dock-plug-ins/CMakeLists.txt
8
 
===================================================================
9
 
--- cairo-dock-plug-ins.orig/CMakeLists.txt     2011-05-21 01:52:06.786633847 +0200
10
 
+++ cairo-dock-plug-ins/CMakeLists.txt  2011-05-21 01:52:49.006695762 +0200
11
 
@@ -299,7 +299,7 @@
12
 
 
13
 
 ############# DND2SHARE #################
14
 
 set (GETTEXT_DND2SHARE ${GETTEXT_PLUGINS})
15
 
-set (VERSION_DND2SHARE "1.0.5")
16
 
+set (VERSION_DND2SHARE "1.0.6")
17
 
 set (PACKAGE_DND2SHARE "cd-dnd2share")
18
 
 set (dnd2sharedatadir "${pluginsdatadir}/dnd2share")
19
 
 configure_file (${CMAKE_CURRENT_SOURCE_DIR}/dnd2share/data/dnd2share.conf.in ${CMAKE_CURRENT_BINARY_DIR}/dnd2share/data/dnd2share.conf)
20
 
Index: cairo-dock-plug-ins/dnd2share/src/applet-backend-ubuntuone.c
21
 
===================================================================
22
 
--- cairo-dock-plug-ins.orig/dnd2share/src/applet-backend-ubuntuone.c   2011-05-21 01:52:06.806633864 +0200
23
 
+++ cairo-dock-plug-ins/dnd2share/src/applet-backend-ubuntuone.c        2011-05-21 01:52:49.006695762 +0200
24
 
@@ -54,8 +54,10 @@
25
 
                return;
26
 
        }
27
 
        
28
 
-       // On recupere l'URL (dispo tout de suite, sinon il faudra boucler en testant 'dropbox status' jusqu'a avoir 'Idle').
29
 
-       cCommand= g_strdup_printf ("u1sdtool --publish-file \"%s\"", cLocalFilePath);
30
 
+       // We wait for the end of the sync
31
 
+       cairo_dock_launch_command_sync ("u1sdtool --wait");
32
 
+       // We publish the file and we read the output message
33
 
+       cCommand = g_strdup_printf ("u1sdtool --publish-file \"%s\"", cLocalFilePath);
34
 
        cd_debug ("commande u2 : %s", cCommand);
35
 
        gchar *cResult = cairo_dock_launch_command_sync (cCommand);
36
 
        g_free (cCommand);