~ubuntu-branches/ubuntu/trusty/gnome-main-menu/trusty

« back to all changes in this revision

Viewing changes to debian/patches/0001-Drop-usage-of-libgnome-2.0-and-libgnomeui-2.0.patch

  • Committer: Bazaar Package Importer
  • Author(s): Julian Andres Klode, Julian Andres Klode, Josselin Mouette
  • Date: 2011-03-14 19:09:51 UTC
  • mfrom: (1.1.7 upstream) (2.1.12 sid)
  • Revision ID: james.westby@ubuntu.com-20110314190951-kfrk4hocrw1pk0ow
Tags: 0.9.16-1
[ Julian Andres Klode ]
* New upstream release:
  - All patches merged upstream (except for default-applications.diff)
  - Correctly links against libxml2 (Closes: #611550)
* default-applications.diff: remove the firefox change (upstream now)

[ Josselin Mouette ]
* Drop type-handling usage. Closes: #587880.
* Bump standards version accordingly.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 38bddf5d6a2051967b3daaa5239204e7050b3261 Mon Sep 17 00:00:00 2001
2
 
From: Julian Andres Klode <jak@debian.org>
3
 
Date: Wed, 5 May 2010 16:57:44 +0200
4
 
Subject: [PATCH 1/6] Drop usage of libgnome-2.0 and libgnomeui-2.0
5
 
 
6
 
Drop the complete usage of libgnome-2.0 and libgnomeui-2.0
7
 
from main-menu.c and remove them from the list of used modules
8
 
in configure.in
9
 
 
10
 
https://bugzilla.gnome.org/show_bug.cgi?id=591001
11
 
---
12
 
 configure.in              |    2 +-
13
 
 main-menu/src/main-menu.c |   10 +++++++---
14
 
 2 files changed, 8 insertions(+), 4 deletions(-)
15
 
 
16
 
diff --git a/configure.in b/configure.in
17
 
index 2f61406..c2a47ce 100644
18
 
--- a/configure.in
19
 
+++ b/configure.in
20
 
@@ -53,7 +53,7 @@ if test "x$NM_GLIB" = "x"; then
21
 
        PKG_CHECK_EXISTS(libnm_glib, [ NM_GLIB=libnm_glib ], [ AC_ERROR(cannot find NetworkManager Glib library) ])
22
 
 fi
23
 
 
24
 
-PKG_CHECK_MODULES(MAIN_MENU, [ $COMMON_MODULES libpanelapplet-2.0 gnome-desktop-2.0 gconf-2.0 libgtop-2.0 libgnome-2.0 libgnomeui-2.0 dbus-glib-1 NetworkManager $NM_GLIB >= 0.7.0 libnm-util >= 0.7.0 x11 hal-storage cairo ])
25
 
+PKG_CHECK_MODULES(MAIN_MENU, [ $COMMON_MODULES libpanelapplet-2.0 gnome-desktop-2.0 gconf-2.0 libgtop-2.0 dbus-glib-1 NetworkManager $NM_GLIB >= 0.7.0 libnm-util >= 0.7.0 x11 hal-storage cairo ])
26
 
 
27
 
 AC_CHECK_HEADERS(iwlib.h, [ AC_CHECK_LIB(iw, iw_sockets_open, have_iwlib=yes, have_iwlib=no, -lm)], have_iwlib=no)
28
 
 
29
 
diff --git a/main-menu/src/main-menu.c b/main-menu/src/main-menu.c
30
 
index 476805b..15f20cd 100644
31
 
--- a/main-menu/src/main-menu.c
32
 
+++ b/main-menu/src/main-menu.c
33
 
@@ -24,7 +24,6 @@
34
 
 
35
 
 #include <glib.h>
36
 
 #include <panel-applet.h>
37
 
-#include <libgnomeui/libgnomeui.h>
38
 
 #include <string.h>
39
 
 #include <libslab/slab.h>
40
 
 
41
 
@@ -43,7 +42,10 @@ PANEL_APPLET_BONOBO_FACTORY ("OAFIID:GNOME_MainMenu_Factory", PANEL_TYPE_APPLET,
42
 
 static gboolean
43
 
 main_menu_applet_init (PanelApplet *applet, const gchar *iid, gpointer user_data)
44
 
 {
45
 
-       gchar *argv [1] = { "slab" };
46
 
+       int argc = 1;
47
 
+       gchar *_argv [1] = { "slab" };
48
 
+       // Needed for calling gtk_init.
49
 
+       gchar **argv = _argv;
50
 
 
51
 
        libslab_checkpoint_init (CHECKPOINT_CONFIG_BASENAME, CHECKPOINT_FILE_BASENAME);
52
 
 
53
 
@@ -65,7 +67,9 @@ main_menu_applet_init (PanelApplet *applet, const gchar *iid, gpointer user_data
54
 
        textdomain (GETTEXT_PACKAGE);
55
 
 #endif
56
 
 
57
 
-       gnome_program_init (PACKAGE, VERSION, LIBGNOMEUI_MODULE, 1, argv, NULL, NULL);
58
 
+       gtk_init (&argc, &argv);
59
 
+       g_set_prgname (PACKAGE);
60
 
+       g_set_application_name (_("GNOME Main Menu"));
61
 
 
62
 
        libslab_checkpoint ("Migrating old configurations");
63
 
        move_system_area_to_new_set ();
64
 
1.7.1
65