~ubuntu-branches/ubuntu/trusty/lifelines/trusty

« back to all changes in this revision

Viewing changes to debian/patches/005_Makefile.in.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Felipe Augusto van de Wiel (faw)
  • Date: 2007-05-23 23:49:53 UTC
  • mfrom: (3.1.3 edgy)
  • Revision ID: james.westby@ubuntu.com-20070523234953-ogno9rnbmth61i7p
Tags: 3.0.50-2etch1
* Changing docs/ll-reportmanual.xml and docs/ll-userguide.xml to fix
  documentation build problems (Closes: #418347).

* lifelines-reports
  - Adding a dependency to lifelines >= 3.0.50 to prevent file conflict.
    (Closes: #405500).

* Updating French translation. Thanks to Bernard Adrian. (Closes: #356671).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
## 005_Makefile.in.dpatch by <felipe@cathedrallabs.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Removing INSTALL COPYING LICENSE 
 
6
 
 
7
if [ $# -lt 1 ]; then
 
8
    echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
 
9
    exit 1
 
10
fi
 
11
 
 
12
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
 
13
patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
 
14
 
 
15
case "$1" in
 
16
    -patch) patch -p1 ${patch_opts} < $0;;
 
17
    -unpatch) patch -R -p1 ${patch_opts} < $0;;
 
18
    *)
 
19
        echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
 
20
        exit 1;;
 
21
esac
 
22
 
 
23
exit 0
 
24
 
 
25
@DPATCH@
 
26
 
 
27
--- lifelines-3.0.50.orig/Makefile.in
 
28
+++ lifelines-3.0.50/Makefile.in
 
29
@@ -41,7 +41,7 @@
 
30
 DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
 
31
        $(srcdir)/Makefile.in $(srcdir)/config.h.in \
 
32
        $(top_srcdir)/configure $(top_srcdir)/intl/Makefile.in \
 
33
-       ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS \
 
34
+       ABOUT-NLS AUTHORS ChangeLog NEWS \
 
35
        build/autotools/README build/autotools/config.guess \
 
36
        build/autotools/config.rpath build/autotools/config.sub \
 
37
        build/autotools/depcomp build/autotools/install-sh \
 
38
@@ -219,7 +219,7 @@
 
39
 # intl must come before src since we link with it!
 
40
 SUBDIRS = build intl po win32 src docs reports tt
 
41
 EXTRA_DIST = .linesrc lines.cfg lines.cfg.input \
 
42
-             COPYING LICENSE INSTALL NEWS README AUTHORS ABOUT-NLS \
 
43
+             NEWS README AUTHORS ABOUT-NLS \
 
44
              README.AUTOCONF README.DEVELOPERS README.INTERNATIONAL \
 
45
              README.LAYOUT README.MAINTAINERS
 
46