~ubuntu-branches/ubuntu/trusty/sound-juicer/trusty

« back to all changes in this revision

Viewing changes to debian/patches/01_lpi.patch

  • Committer: Bazaar Package Importer
  • Author(s): Pedro Fragoso
  • Date: 2009-02-13 16:57:30 UTC
  • mfrom: (1.1.37 upstream)
  • Revision ID: james.westby@ubuntu.com-20090213165730-zehs2hnzj2pso94k
Tags: 2.25.3-0ubuntu1
* New upstream release (LP: #329134)
  - Put the disc number in the file name
  - Support multiple genres
  - Use libcanberra for event sounds
  - Handle custom patterns in the prefs dialog
  - Remove Musicbrainz data if the track data is changed
  - Fix disc number editing logic
* debian/control.in:
  - Bump libgstreamer0.10-dev to 0.10.15
  - Build-dep on libcanberra-gtk-dev 
  - Also depend on libcanberra-gtk0
* debian/debian/patches/01_lpi.patch, 
  debian/patches/02_autoconf.patch:
  - Refreshed for the new upstream

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Nur -x '*.orig' -x '*~' sound-juicer-2.25.2/configure.in sound-juicer-2.25.2.new/configure.in
2
 
--- sound-juicer-2.25.2/configure.in    2009-02-03 11:29:31.000000000 +0000
3
 
+++ sound-juicer-2.25.2.new/configure.in        2009-02-03 15:26:05.000000000 +0000
 
1
diff -Nur -x '*.orig' -x '*~' sound-juicer-2.25.3/configure.in sound-juicer-2.25.3.new/configure.in
 
2
--- sound-juicer-2.25.3/configure.in    2009-02-13 16:38:17.000000000 +0000
 
3
+++ sound-juicer-2.25.3.new/configure.in        2009-02-13 17:04:40.000000000 +0000
4
4
@@ -52,7 +52,7 @@
5
5
 # LIBS="$oldlibs"
6
6
 
7
7
 # Find the UI libraries
8
 
-PKG_CHECK_MODULES(UI, gtk+-2.0 >= 2.14  libglade-2.0  gconf-2.0 gio-2.0 gmodule-export-2.0 dbus-glib-1)
9
 
+PKG_CHECK_MODULES(UI, gtk+-2.0 >= 2.14  launchpad-integration libglade-2.0  gconf-2.0 gio-2.0 gmodule-export-2.0 dbus-glib-1)
 
8
-PKG_CHECK_MODULES(UI, gtk+-2.0 >= 2.14  libglade-2.0  gconf-2.0 gio-2.0 gmodule-export-2.0 dbus-glib-1 libcanberra-gtk)
 
9
+PKG_CHECK_MODULES(UI, gtk+-2.0 >= 2.14  launchpad-integration libglade-2.0  gconf-2.0 gio-2.0 gmodule-export-2.0 dbus-glib-1 libcanberra-gtk)
10
10
 AC_SUBST(UI_CFLAGS)
11
11
 AC_SUBST(UI_LIBS)
12
12
 
13
 
diff -Nur -x '*.orig' -x '*~' sound-juicer-2.25.2/src/sj-main.c sound-juicer-2.25.2.new/src/sj-main.c
14
 
--- sound-juicer-2.25.2/src/sj-main.c   2009-02-03 11:29:00.000000000 +0000
15
 
+++ sound-juicer-2.25.2.new/src/sj-main.c       2009-02-03 15:24:50.000000000 +0000
 
13
diff -Nur -x '*.orig' -x '*~' sound-juicer-2.25.3/src/sj-main.c sound-juicer-2.25.3.new/src/sj-main.c
 
14
--- sound-juicer-2.25.3/src/sj-main.c   2009-02-10 21:21:34.000000000 +0000
 
15
+++ sound-juicer-2.25.3.new/src/sj-main.c       2009-02-13 17:04:07.000000000 +0000
16
16
@@ -37,6 +37,8 @@
17
17
 #include <profiles/gnome-media-profiles.h>
18
18
 #include <gst/gst.h>
22
22
 #include "bacon-message-connection.h"
23
23
 #include "gconf-bridge.h"
24
24
 #include "sj-about.h"
25
 
@@ -1591,6 +1593,8 @@
 
25
@@ -1625,6 +1627,8 @@
26
26
   GtkTreeSelection *selection;
27
27
   char *device = NULL, **uris = NULL;
28
28
   GOptionContext *ctx;
31
31
   const GOptionEntry entries[] = {
32
32
     { "auto-start", 'a', 0, G_OPTION_ARG_NONE, &autostart, N_("Start extracting immediately"), NULL },
33
33
     { "play", 'p', 0, G_OPTION_ARG_NONE, &autoplay, N_("Start playing immediately"), NULL},
34
 
@@ -1704,6 +1708,9 @@
 
34
@@ -1741,6 +1745,9 @@
35
35
   duplicate = glade_xml_get_widget (glade, "duplicate_menuitem");
36
36
   eject = glade_xml_get_widget (glade, "eject");
37
37