~ubuntu-branches/ubuntu/vivid/nethack/vivid

« back to all changes in this revision

Viewing changes to debian/patches/0008-Use-usr-share-pixmaps-nethack-for-pretty-pictures.patch

  • Committer: Package Import Robot
  • Author(s): Vincent Cheng, Bernhard R. Link, Vincent Cheng
  • Date: 2012-06-11 00:47:38 UTC
  • mfrom: (3.1.9 sid)
  • Revision ID: package-import@ubuntu.com-20120611004738-3fy8b3wi0j45y2oq
Tags: 3.4.3-14
* Team upload.

[ Bernhard R. Link ]
* switch to "3.0 (quilt)"
* bump Standards-Version
* modernize debian/rules:
- use dpkg-buildflags
- support build-arch/-indep
- make parallel safe
- don't avoid make errors
* add patch so it can compile with -Werror=format-security
* drop no longer needed patches (-qt and -gnome are gone)
* don't use /dev/null as install template (Closes: 644647)
* drop nethack-common menu (both -console and -x11 have one)

[ Vincent Cheng ]
* Adopt package. (Closes: #673584)
  - Change Maintainer to Debian Games Team.
  - Add myself to Uploaders.
* Modify 0006-Common-config.h-for-all-binary-packages.patch to enable
  AUTOPICKUP_EXCEPTIONS. (Closes: #329318)
* Modify 0011-Pasi-Kallinen-s-patch-to-add-colors-to-inventory-ite.patch
  and 0017-Debian-and-Linux-specifics-defined-in-unixconf.h.patch; add
  0021-fix-kfreebsd-ftbfs.patch to fix FTBFS on kfreebsd.
* Convert debian/copyright to DEP-5 machine-readable format.
* Use dh_lintian to install overrides instead of manually installing them
  in debian/rules.
* Add watch file.
* Add Homepage field in debian/control.
* Add Vcs-* fields in debian/control.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 77d8972a0dfdd46bd7ad3661e0d0a2f39b8a253f Mon Sep 17 00:00:00 2001
 
2
From: Joshua Kwan <joshk@triplehelix.org>
 
3
Date: Thu, 24 Sep 2009 14:21:19 -0700
 
4
Subject: Use /usr/share/pixmaps/nethack/ for pretty pictures.
 
5
 
 
6
---
 
7
 win/X11/winX.c |    4 ++--
 
8
 1 file changed, 2 insertions(+), 2 deletions(-)
 
9
 
 
10
diff --git a/win/X11/winX.c b/win/X11/winX.c
 
11
index 14f0e90..1c5d49b 100644
 
12
--- a/win/X11/winX.c
 
13
+++ b/win/X11/winX.c
 
14
@@ -919,12 +919,12 @@ static XtResource resources[] = {
 
15
     { "message_lines", "Message_lines", XtRInt, sizeof(int),
 
16
       XtOffset(AppResources *,message_lines), XtRString, "12" },
 
17
     { "pet_mark_bitmap", "Pet_mark_bitmap", XtRString, sizeof(String),
 
18
-      XtOffset(AppResources *,pet_mark_bitmap), XtRString, "pet_mark.xbm" },
 
19
+      XtOffset(AppResources *,pet_mark_bitmap), XtRString, PIXMAPDIR "pet_mark.xbm" },
 
20
     { "pet_mark_color", "Pet_mark_color", XtRPixel, sizeof(XtRPixel),
 
21
       XtOffset(AppResources *,pet_mark_color), XtRString, "Red" },
 
22
 #ifdef GRAPHIC_TOMBSTONE
 
23
     { "tombstone", "Tombstone", XtRString, sizeof(String),
 
24
-      XtOffset(AppResources *,tombstone), XtRString, "rip.xpm" },
 
25
+      XtOffset(AppResources *,tombstone), XtRString, PIXMAPDIR "rip.xpm" },
 
26
     { "tombtext_x", "Tombtext_x", XtRInt, sizeof(int),
 
27
       XtOffset(AppResources *,tombtext_x), XtRString, "155" },
 
28
     { "tombtext_y", "Tombtext_y", XtRInt, sizeof(int),