~ubuntu-branches/ubuntu/vivid/nethack/vivid

« back to all changes in this revision

Viewing changes to debian/patches/10_gnome_add_quiver.dpatch

  • Committer: Package Import Robot
  • Author(s): Vincent Cheng, Bernhard R. Link, Vincent Cheng
  • Date: 2012-06-11 00:47:38 UTC
  • mfrom: (3.1.9 sid)
  • Revision ID: package-import@ubuntu.com-20120611004738-3fy8b3wi0j45y2oq
Tags: 3.4.3-14
* Team upload.

[ Bernhard R. Link ]
* switch to "3.0 (quilt)"
* bump Standards-Version
* modernize debian/rules:
- use dpkg-buildflags
- support build-arch/-indep
- make parallel safe
- don't avoid make errors
* add patch so it can compile with -Werror=format-security
* drop no longer needed patches (-qt and -gnome are gone)
* don't use /dev/null as install template (Closes: 644647)
* drop nethack-common menu (both -console and -x11 have one)

[ Vincent Cheng ]
* Adopt package. (Closes: #673584)
  - Change Maintainer to Debian Games Team.
  - Add myself to Uploaders.
* Modify 0006-Common-config.h-for-all-binary-packages.patch to enable
  AUTOPICKUP_EXCEPTIONS. (Closes: #329318)
* Modify 0011-Pasi-Kallinen-s-patch-to-add-colors-to-inventory-ite.patch
  and 0017-Debian-and-Linux-specifics-defined-in-unixconf.h.patch; add
  0021-fix-kfreebsd-ftbfs.patch to fix FTBFS on kfreebsd.
* Convert debian/copyright to DEP-5 machine-readable format.
* Use dh_lintian to install overrides instead of manually installing them
  in debian/rules.
* Add watch file.
* Add Homepage field in debian/control.
* Add Vcs-* fields in debian/control.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
## 10_gnome_add_quiver.dpatch by Joshua Kwan <joshk@triplehelix.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Add a 'Quiver/Ready' option to the GNOME UI menu.
6
 
 
7
 
if [ $# -ne 1 ]; then
8
 
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
9
 
    exit 1
10
 
fi
11
 
case "$1" in
12
 
    -patch) patch -f --no-backup-if-mismatch -p1 < $0;;
13
 
    -unpatch) patch -f --no-backup-if-mismatch -R -p1 < $0;;
14
 
    *)
15
 
        echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
16
 
        exit 1;;
17
 
esac
18
 
 
19
 
exit 0
20
 
 
21
 
--- a/win/gnome/gnmain.c~       2003-10-06 23:39:19.000000000 -0700
22
 
+++ b/win/gnome/gnmain.c        2003-10-06 23:38:39.000000000 -0700
23
 
@@ -361,6 +361,12 @@
24
 
               ghack_accelerator_selected, 
25
 
               GINT_TO_POINTER('t'), NULL, GNOME_APP_PIXMAP_NONE, NULL, 't',0
26
 
           },
27
 
+           {
28
 
+               GNOME_APP_UI_ITEM, N_("Quiver/Ready"),
29
 
+               N_("ready or quiver some ammunition"),
30
 
+               ghack_accelerator_selected,
31
 
+               GINT_TO_POINTER('Q'), NULL, GNOME_APP_PIXMAP_NONE, NULL, 'Q',0
32
 
+           },
33
 
           { 
34
 
               GNOME_APP_UI_ITEM, N_("Open Door"), 
35
 
               N_("open a door"),