~ubuntu-branches/ubuntu/vivid/samba/vivid

« back to all changes in this revision

Viewing changes to debian/patches/bug_605728_upstream_7791.patch

  • Committer: Package Import Robot
  • Author(s): Chuck Short
  • Date: 2011-12-21 13:18:04 UTC
  • mfrom: (0.39.21 sid)
  • Revision ID: package-import@ubuntu.com-20111221131804-xtlr39wx6njehxxr
Tags: 2:3.6.1-3ubuntu1
* Merge from Debian testing.  Remaining changes:
  + debian/patches/VERSION.patch:
    - set SAMBA_VERSION_SUFFIX to Ubuntu.
  + debian/patches/error-trans.fix-276472:
    - Add the translation of Unix Error code -ENOTSUP to NT Error Code
    - NT_STATUS_NOT_SUPPORTED to prevent the Permission denied error.
  + debian/smb.conf:
    - add "(Samba, Ubuntu)" to server string.
    - comment out the default [homes] share, and add a comment about
      "valid users = %S" to show users how to restrict access to
      \\server\username to only username.
    - Set 'usershare allow guests', so that usershare admins are 
      allowed to create public shares in addition to authenticated
      ones.
    - add map to guest = Bad user, maps bad username to guest access.
  + debian/samba-common.config:
    - Do not change priority to high if dhclient3 is installed.
    - Use priority medium instead of high for the workgroup question.
  + debian/control:
    - Don't build against or suggest ctdb.
    - Add dependency on samba-common-bin to samba.
  + Add ufw integration:
    - Created debian/samba.ufw.profile
    - debian/rules, debian/samba.dirs, debian/samba.files: install
      profile
    - debian/control: have samba suggest ufw
  + Add apport hook:
    - Created debian/source_samba.py.
    - debian/rules, debian/samba.dirs, debian/samba-common-bin.files: install
  + Switch to upstart:
    - Add debian/samba.{nmbd,smbd}.upstart.
  + debian/samba.logrotate, debian/samba-common.dhcp, debian/samba.if-up:
    - Make them upstart compatible
  + debian/samba.postinst: 
    - Avoid scary pdbedit warnings on first import.
  + debian/samba-common.postinst: Add more informative error message for
    the case where smb.conf was manually deleted
  + debian/patches/fix-debuglevel-name-conflict.patch: don't use 'debug_level'
    as a global variable name in an NSS module 
  + Dropped:
    - debian/patches/error-trans.fix-276472
    - debian/patches/fix-debuglevel-name-conflict.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 2a9eaf741d8c169b8f06ee6498a6879acc654506 Mon Sep 17 00:00:00 2001
2
 
From: Jeremy Allison <jra@samba.org>
3
 
Date: Thu, 11 Nov 2010 09:44:21 -0800
4
 
Subject: [PATCH] Fix bug #7791 - gvfsd-smb (Gnome vfs) fails to copy files from a SMB share using SMB signing.
5
 
 
6
 
The underlying problem is that the old code invoked by cli_write() increments
7
 
cli->mid directly when issuing outstanding writes. This should now be done only
8
 
in libsmb/clientgen.c to make metze's new signing engine works correctly. Just
9
 
deleting this code fixes the problem.
10
 
 
11
 
Jeremy.
12
 
---
13
 
 source3/libsmb/clireadwrite.c |    7 ++-----
14
 
 1 files changed, 2 insertions(+), 5 deletions(-)
15
 
 
16
 
diff --git a/source3/libsmb/clireadwrite.c b/source3/libsmb/clireadwrite.c
17
 
index 6342de4..1f5f925 100644
18
 
--- a/source3/libsmb/clireadwrite.c
19
 
+++ b/source3/libsmb/clireadwrite.c
20
 
@@ -704,8 +704,7 @@ static bool cli_issue_write(struct cli_state *cli,
21
 
                                off_t offset,
22
 
                                uint16 mode,
23
 
                                const char *buf,
24
 
-                               size_t size,
25
 
-                               int i)
26
 
+                               size_t size)
27
 
 {
28
 
        char *p;
29
 
        bool large_writex = false;
30
 
@@ -779,8 +778,6 @@ static bool cli_issue_write(struct cli_state *cli,
31
 
                cli_setup_bcc(cli, p+size);
32
 
        }
33
 
 
34
 
-       SSVAL(cli->outbuf,smb_mid,cli->mid + i);
35
 
-
36
 
        show_msg(cli->outbuf);
37
 
        if (direct_writes) {
38
 
                /* For direct writes we now need to write the data
39
 
@@ -829,7 +826,7 @@ ssize_t cli_write(struct cli_state *cli,
40
 
                        if (!cli_issue_write(cli, fnum, offset + bsent,
41
 
                                        write_mode,
42
 
                                        buf + bsent,
43
 
-                                       size1, issued))
44
 
+                                       size1))
45
 
                                return -1;
46
 
                        issued++;
47
 
                }
48
 
1.7.3.1
49