~ubuntu-branches/ubuntu/wily/scim/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/10_gtk-immodule-install-dir.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Rolf Leggewie
  • Date: 2010-08-11 18:28:44 UTC
  • mfrom: (3.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20100811182844-rnn95k63cwehtm75
Tags: 1.4.9-5
* debian/copyright: add my copyright
* debian/control: update to standard 3.9.1, no further changes necessary

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 10_gtk-immodule-install-dir.dpatch by Ming Hua <minghua@rice.edu>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
##
6
 
## DP: Change the gtk immodule installation directory from
7
 
## DP: /usr/lib/gtk-2.0/immodules/ to
8
 
## DP: /usr/lib/gtk-2.0/$(GTK_BINARY_VERSION)/immodules/.
9
 
## DP:
10
 
## DP: The GTK+ IM module should be installed in the ABI-specific
11
 
## DP: directory instead of the general one to avoid ABI mismatch during
12
 
## DP: GTK+ ABI upgrade.
13
 
## DP:
14
 
## DP: Since GTK+ 2.10, Debian has changed the way to handle the ABI for
15
 
## DP: IM modules and GdkPixbuf loaders.  For IM modules, the
16
 
## DP: /usr/sbin/update-gtk-immodules tool is deprecated and the IM
17
 
## DP: module information is not stored in /etc/gtk-2.0/gtk.immodules
18
 
## DP: anymore.  The debhelper program dh_gtkmodules should be used
19
 
## DP: instead to update the IM module information.
20
 
## DP:
21
 
## DP: NOTE:  This patch only changes configure.ac and the change
22
 
## DP: necessary for configure is incorporated in
23
 
## DP: 90_relibtoolize.dpatch.  If the relibtoolize patch is removed,
24
 
## DP: this patch should change configure as well.
25
 
 
26
 
@DPATCH@
27
 
diff -urNad scim-1.4.7~/configure.ac scim-1.4.7/configure.ac
28
 
--- scim-1.4.7~/configure.ac    2007-06-26 09:31:57.000000000 -0500
29
 
+++ scim-1.4.7/configure.ac     2007-06-26 18:00:43.000000000 -0500
30
 
@@ -235,7 +235,7 @@
31
 
   if test -z "$GTK_LIBDIR)"; then
32
 
     GTK_LIBDIR="$libdir"
33
 
   fi
34
 
-  GTK_IM_MODULEDIR=$GTK_LIBDIR/gtk-2.0/immodules
35
 
+  GTK_IM_MODULEDIR=$GTK_LIBDIR/gtk-2.0/$GTK_BINARY_VERSION/immodules
36
 
   AC_SUBST(GTK_LIBDIR)
37
 
   AC_SUBST(GTK_IM_MODULEDIR)
38
 
   AC_SUBST(GTK_VERSION)