~ubuntu-branches/ubuntu/wily/scim/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/10_remove-deprecated-desktop-entry.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Rolf Leggewie
  • Date: 2010-08-11 18:28:44 UTC
  • mfrom: (3.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20100811182844-rnn95k63cwehtm75
Tags: 1.4.9-5
* debian/copyright: add my copyright
* debian/control: update to standard 3.9.1, no further changes necessary

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 10_remove-deprecated-desktop-entry.dpatch by Ming Hua <minghua-guest@users.alioth.debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
##
6
 
## DP: The freedesktop standard desktop entry location [1] is
7
 
## DP: /usr/share/applications/, so we stop installing scim-setup.desktop into
8
 
## DP: /usr/share/control-center-2.0/capplets/.
9
 
## DP:
10
 
## DP: NOTE:  This patch only changes extras/setup/Makefile.am, and the change
11
 
## DP: necessary for extras/setup/Makefile.in is incorporated in
12
 
## DP: 90_relibtoolize.dpatch.  If the relibtoolize patch is removed, this
13
 
## DP: patch should change extras/setup/Makefile.in as well.
14
 
## DP:
15
 
## DP: 1. For example, see
16
 
## DP:    http://standards.freedesktop.org/menu-spec/1.0/ar01s02.html
17
 
 
18
 
@DPATCH@
19
 
diff -urNad scim-1.4.7~/extras/setup/Makefile.am scim-1.4.7/extras/setup/Makefile.am
20
 
--- scim-1.4.7~/extras/setup/Makefile.am        2007-06-26 09:31:50.000000000 -0500
21
 
+++ scim-1.4.7/extras/setup/Makefile.am 2007-07-22 01:56:58.000000000 -0500
22
 
@@ -68,9 +68,6 @@
23
 
 desktopdir       = $(datadir)/applications
24
 
 desktop_in_files = scim-setup.desktop.in
25
 
 desktop_DATA     = $(desktop_in_files:.desktop.in=.desktop)
26
 
-
27
 
-gnomeccdir       = $(datadir)/control-center-2.0/capplets
28
 
-gnomecc_DATA     = $(desktop_in_files:.desktop.in=.desktop)
29
 
 endif
30
 
 
31
 
 EXTRA_DIST = $(desktop_in_files) scim-setup.in