~ubuntu-branches/ubuntu/wily/scim/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/28_scim-1.4.7-xim-wrong-format.patch

  • Committer: Bazaar Package Importer
  • Author(s): Rolf Leggewie
  • Date: 2010-08-11 18:28:44 UTC
  • mfrom: (3.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20100811182844-rnn95k63cwehtm75
Tags: 1.4.9-5
* debian/copyright: add my copyright
* debian/control: update to standard 3.9.1, no further changes necessary

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Ikuya Awashiro <ikuya@fruitsbasket.info>
 
2
Status: applied upstream in r257, can be dropped past 1.4.9
 
3
Description: Fix incorrect XIM_QUERY_EXTENSION_REPLY message
 
4
https://bugzilla.redhat.com/show_bug.cgi?id=457566
 
5
--- a/modules/FrontEnd/IMdkit/i18nIMProto.c
 
6
+++ b/modules/FrontEnd/IMdkit/i18nIMProto.c
 
7
@@ -106,11 +106,11 @@
 
8
 
 
9
 static XimFrameRec ext_fr[] =
 
10
 {
 
11
-    _FRAME(BIT16),             /* extension major-opcode */
 
12
-    _FRAME(BIT16),             /* extension minor-opcode */
 
13
+    _FRAME(BIT8),              /* extension major-opcode */
 
14
+    _FRAME(BIT8),              /* extension minor-opcode */
 
15
     _FRAME(BIT16),             /* length of extension name */
 
16
     _FRAME(BARRAY),            /* extension name */
 
17
-    _PAD4(2),
 
18
+    _PAD4(1),
 
19
     _FRAME(EOL),
 
20
 };
 
21