~ubuntu-branches/ubuntu/wily/scim/wily-proposed

« back to all changes in this revision

Viewing changes to debian/patches/70_fix-disappeared-status-icon.patch

  • Committer: Bazaar Package Importer
  • Author(s): Rolf Leggewie
  • Date: 2010-08-11 18:28:44 UTC
  • mfrom: (3.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20100811182844-rnn95k63cwehtm75
Tags: 1.4.9-5
* debian/copyright: add my copyright
* debian/control: update to standard 3.9.1, no further changes necessary

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Mingxi Wu <fengshenx@gmail.com>
 
2
Status: commited upstream in r277, can be dropped past 1.4.9
 
3
Fixes:: https://bugs.launchpad.net/bugs/475800 and others
 
4
--- a/extras/panel/scim_panel_gtk.cpp
 
5
+++ b/extras/panel/scim_panel_gtk.cpp
 
6
@@ -1074,11 +1074,13 @@
 
7
 #ifdef GDK_WINDOWING_X11
 
8
     // Add an event filter function to observe X root window's properties.
 
9
     GdkWindow *root_window = gdk_get_default_root_window ();
 
10
+    GdkEventMask event_mask;
 
11
 #if GDK_MULTIHEAD_SAFE
 
12
     if (_current_screen)
 
13
         root_window = gdk_screen_get_root_window (_current_screen);
 
14
 #endif
 
15
-    gdk_window_set_events (root_window, (GdkEventMask)GDK_PROPERTY_NOTIFY);
 
16
+    event_mask = (GdkEventMask) (gdk_window_get_events (root_window) | GDK_PROPERTY_NOTIFY);
 
17
+    gdk_window_set_events (root_window, event_mask);
 
18
     gdk_window_add_filter (root_window, ui_event_filter, NULL);
 
19
 #endif
 
20
 
 
21
@@ -1325,9 +1327,11 @@
 
22
 
 
23
 #ifdef GDK_WINDOWING_X11
 
24
         GdkWindow *root_window = gdk_get_default_root_window ();
 
25
+        GdkEventMask event_mask;
 
26
         if (_current_screen)
 
27
             root_window = gdk_screen_get_root_window (_current_screen);
 
28
-        gdk_window_set_events (root_window, (GdkEventMask)GDK_PROPERTY_NOTIFY);
 
29
+        event_mask = (GdkEventMask) (gdk_window_get_events (root_window) | GDK_PROPERTY_NOTIFY);
 
30
+        gdk_window_set_events (root_window, event_mask);
 
31
         gdk_window_add_filter (root_window, ui_event_filter, NULL);
 
32
 #endif
 
33