~ubuntu-dev/ubuntu/lucid/mutt/lucid-201002110857

« back to all changes in this revision

Viewing changes to debian/patches/features/purge-message

  • Committer: Bazaar Package Importer
  • Author(s): Antonio Radici
  • Date: 2009-06-14 20:53:18 UTC
  • mfrom: (1.3.1 upstream)
  • mto: (2.1.3 squeeze)
  • mto: This revision was merged to the branch mainline in revision 22.
  • Revision ID: james.westby@ubuntu.com-20090614205318-wf0sqy1o3km636li
Tags: 1.5.20-1
* New upstream release, includes the following features:
  + Bounced messages contains From: headers (Closes: 93268)
  + Attachments displayed based on Content-Disposition (Closes: 199709)
  + fcc to a mailbox does not raise the 'new' flag (Closes: 209390)
  + '!' supported as suffix in gpg keys (Closes: 277945)
  + failed attachment saving shows an error message (Closes: 292350)
  + inline signed messages sent honouring $send_charset (Closes: 307819)
  + support for <clear-flag> and <set-flag> in the pager (Closes: 436007)
  + fcc_attach is a quad option (Closes: 478861)
  + Content-Description header not included in reply (Closes: 500766)
  + imap_sync_mailbox fix for a segfault (Closes: 516364)
  + better threading support with particular Message-ID's (Closes: 520735)
  + no crash on IMAP folder refresh (Closes: 528465)
  + undisclosed-recipients not passed in the envelope (Closes: 529090)
* debian/patches/series:
  + commented all references to upstream/*, they should be included in 1.5.20
  + removed debian-specific/529838-gnutls-autoconf.patch, ditto
  + removed misc/manpage-typos.patch, ditto 
  + modified misc/hyphen-as-minus.patch, a big part was integrated upstream
  + features/trash-folder: do not reupload messages to $trash if IMAP is used
    (Closes: #448241)
  + added misc/hg.pmdef.debugtime, see upstream #3263
* debian/control: added DM-Upload-Allowed: yes

Show diffs side-by-side

added added

removed removed

Lines of Context:
26
26
  - Fixed indentation of "purged" in mutt.h.
27
27
 
28
28
== END PATCH
29
 
Index: trash/OPS
30
 
===================================================================
31
 
--- trash.orig/OPS      2006-12-12 14:15:02.000000000 +0100
32
 
+++ trash/OPS   2007-02-15 19:39:57.479112576 +0100
33
 
@@ -140,6 +140,7 @@ OP_PREV_ENTRY "move to the previous entr
 
29
--- a/OPS
 
30
+++ b/OPS
 
31
@@ -141,6 +141,7 @@
34
32
 OP_PREV_LINE "scroll up one line"
35
33
 OP_PREV_PAGE "move to the previous page"
36
34
 OP_PRINT "print the current entry"
38
36
 OP_QUERY "query external program for addresses"
39
37
 OP_QUERY_APPEND "append new query results to current results"
40
38
 OP_QUIT "save changes to mailbox and quit"
41
 
Index: trash/curs_main.c
42
 
===================================================================
43
 
--- trash.orig/curs_main.c      2006-12-12 14:15:02.000000000 +0100
44
 
+++ trash/curs_main.c   2007-02-15 19:39:57.480112424 +0100
45
 
@@ -1778,6 +1778,7 @@ int mutt_index_menu (void)
 
39
--- a/curs_main.c
 
40
+++ b/curs_main.c
 
41
@@ -1823,6 +1823,7 @@
46
42
        MAYBE_REDRAW (menu->redraw);
47
43
        break;
48
44
 
50
46
       case OP_DELETE:
51
47
 
52
48
        CHECK_MSGCOUNT;
53
 
@@ -1788,6 +1789,7 @@ int mutt_index_menu (void)
 
49
@@ -1833,6 +1834,7 @@
54
50
        if (tag)
55
51
        {
56
52
          mutt_tag_set_flag (M_DELETE, 1);
58
54
          if (option (OPTDELETEUNTAG))
59
55
            mutt_tag_set_flag (M_TAG, 0);
60
56
          menu->redraw = REDRAW_INDEX;
61
 
@@ -1795,6 +1797,8 @@ int mutt_index_menu (void)
 
57
@@ -1840,6 +1842,8 @@
62
58
        else
63
59
        {
64
60
          mutt_set_flag (Context, CURHDR, M_DELETE, 1);
67
63
          if (option (OPTDELETEUNTAG))
68
64
            mutt_set_flag (Context, CURHDR, M_TAG, 0);
69
65
          if (option (OPTRESOLVE))
70
 
@@ -2088,11 +2092,13 @@ int mutt_index_menu (void)
 
66
@@ -2136,11 +2140,13 @@
71
67
        if (tag)
72
68
        {
73
69
          mutt_tag_set_flag (M_DELETE, 0);
81
77
          if (option (OPTRESOLVE) && menu->current < Context->vcount - 1)
82
78
          {
83
79
            menu->current++;
84
 
@@ -2113,9 +2119,11 @@ int mutt_index_menu (void)
 
80
@@ -2161,9 +2167,11 @@
85
81
        CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
86
82
 
87
83
        rc = mutt_thread_set_flag (CURHDR, M_DELETE, 0,
95
91
        {
96
92
          if (option (OPTRESOLVE))
97
93
          {
98
 
Index: trash/flags.c
99
 
===================================================================
100
 
--- trash.orig/flags.c  2007-02-15 19:38:00.433906152 +0100
101
 
+++ trash/flags.c       2007-02-15 19:39:57.480112424 +0100
102
 
@@ -105,6 +105,16 @@ void _mutt_set_flag (CONTEXT *ctx, HEADE
 
94
--- a/flags.c
 
95
+++ b/flags.c
 
96
@@ -104,6 +104,16 @@
103
97
       }
104
98
       break;
105
99
 
116
110
     case M_NEW:
117
111
 
118
112
       if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
119
 
Index: trash/functions.h
120
 
===================================================================
121
 
--- trash.orig/functions.h      2005-09-18 13:16:40.000000000 +0200
122
 
+++ trash/functions.h   2007-02-15 19:39:57.481112272 +0100
123
 
@@ -103,6 +103,7 @@ struct binding_t OpMain[] = {
 
113
--- a/functions.h
 
114
+++ b/functions.h
 
115
@@ -120,6 +120,7 @@
124
116
   { "toggle-write",            OP_TOGGLE_WRITE,                "%" },
125
117
   { "next-thread",             OP_MAIN_NEXT_THREAD,            "\016" },
126
118
   { "next-subthread",          OP_MAIN_NEXT_SUBTHREAD,         "\033n" },
128
120
   { "query",                   OP_QUERY,                       "Q" },
129
121
   { "quit",                    OP_QUIT,                        "q" },
130
122
   { "reply",                   OP_REPLY,                       "r" },
131
 
@@ -189,6 +190,7 @@ struct binding_t OpPager[] = {
 
123
@@ -209,6 +210,7 @@
132
124
   { "print-message",   OP_PRINT,                       "p" },
133
125
   { "previous-thread", OP_MAIN_PREV_THREAD,            "\020" },
134
126
   { "previous-subthread",OP_MAIN_PREV_SUBTHREAD,       "\033p" },
136
128
   { "quit",            OP_QUIT,                        "Q" },
137
129
   { "exit",            OP_EXIT,                        "q" },
138
130
   { "reply",           OP_REPLY,                       "r" },
139
 
Index: trash/mutt.h
140
 
===================================================================
141
 
--- trash.orig/mutt.h   2007-02-15 19:38:00.435905848 +0100
142
 
+++ trash/mutt.h        2007-02-15 19:40:38.768835584 +0100
143
 
@@ -201,6 +201,7 @@ enum
 
131
--- a/mutt.h
 
132
+++ b/mutt.h
 
133
@@ -188,6 +188,7 @@
144
134
   M_UNDELETE,
145
135
   M_DELETED,
146
136
   M_APPENDED,
148
138
   M_FLAG,
149
139
   M_TAG,
150
140
   M_UNTAG,
151
 
@@ -705,6 +706,7 @@ typedef struct header
 
141
@@ -705,6 +706,7 @@
152
142
   unsigned int flagged : 1;            /* marked important? */
153
143
   unsigned int tagged : 1;
154
144
   unsigned int appended : 1;           /* has been saved */
156
146
   unsigned int deleted : 1;
157
147
   unsigned int changed : 1;
158
148
   unsigned int attach_del : 1;                 /* has an attachment marked for deletion */
159
 
Index: trash/mx.c
160
 
===================================================================
161
 
--- trash.orig/mx.c     2007-02-15 19:38:00.436905696 +0100
162
 
+++ trash/mx.c  2007-02-15 19:39:57.482112120 +0100
163
 
@@ -852,6 +852,7 @@ static int trash_append (CONTEXT *ctx)
 
149
--- a/mx.c
 
150
+++ b/mx.c
 
151
@@ -803,6 +803,7 @@
164
152
     {
165
153
       for (i = 0 ; i < ctx->msgcount ; i++)
166
154
        if (ctx->hdrs[i]->deleted && !ctx->hdrs[i]->appended
168
156
            && mutt_append_message (ctx_trash, ctx, ctx->hdrs[i], 0, 0) == -1)
169
157
          {
170
158
            mx_close_mailbox (ctx_trash, NULL);
171
 
Index: trash/pager.c
172
 
===================================================================
173
 
--- trash.orig/pager.c  2006-12-12 14:15:03.000000000 +0100
174
 
+++ trash/pager.c       2007-02-15 19:39:57.482112120 +0100
175
 
@@ -2254,12 +2254,15 @@ search_next:
 
159
--- a/pager.c
 
160
+++ b/pager.c
 
161
@@ -2316,12 +2316,15 @@
176
162
        MAYBE_REDRAW (redraw);
177
163
        break;
178
164
 
188
174
         if (option (OPTDELETEUNTAG))
189
175
          mutt_set_flag (Context, extra->hdr, M_TAG, 0);
190
176
        redraw = REDRAW_STATUS | REDRAW_INDEX;
191
 
@@ -2572,6 +2575,7 @@ search_next:
 
177
@@ -2648,6 +2651,7 @@
192
178
        CHECK_ACL(M_ACL_DELETE, _("undelete message"));
193
179
 
194
180
        mutt_set_flag (Context, extra->hdr, M_DELETE, 0);
196
182
        redraw = REDRAW_STATUS | REDRAW_INDEX;
197
183
        if (option (OPTRESOLVE))
198
184
        {
199
 
@@ -2587,9 +2591,11 @@ search_next:
 
185
@@ -2663,9 +2667,11 @@
200
186
        CHECK_ACL(M_ACL_DELETE, _("undelete message(s)"));
201
187
 
202
188
        r = mutt_thread_set_flag (extra->hdr, M_DELETE, 0,
209
195
        {
210
196
          if (option (OPTRESOLVE))
211
197
          {
212
 
Index: trash/pattern.c
213
 
===================================================================
214
 
--- trash.orig/pattern.c        2007-01-25 21:44:41.000000000 +0100
215
 
+++ trash/pattern.c     2007-02-15 19:39:57.483111968 +0100
216
 
@@ -1338,8 +1338,10 @@ int mutt_pattern_func (int op, char *pro
 
198
--- a/pattern.c
 
199
+++ b/pattern.c
 
200
@@ -1347,8 +1347,10 @@
217
201
       {
218
202
        switch (op)
219
203
        {
225
209
            mutt_set_flag (Context, Context->hdrs[Context->v2r[i]], M_DELETE, 
226
210
                          (op == M_DELETE));
227
211
            break;
228
 
--- a/PATCHES
229
 
+++ b/PATCHES
230
 
@@ -0,0 +1 @@
231
 
+patch-1.5.13.cd.purge_message.3.4