~valavanisalex/ubuntu/oneiric/inkscape/inkscape_0.48.1-2ubuntu4

« back to all changes in this revision

Viewing changes to debian/patches/20_fix_glib_and_gxx43_ftbfs.patch

  • Committer: Bazaar Package Importer
  • Author(s): Kees Cook, Kees Cook, Ted Gould
  • Date: 2008-02-10 14:20:16 UTC
  • mfrom: (1.1.6 upstream)
  • Revision ID: james.westby@ubuntu.com-20080210142016-vcnb2zqyhszu0xvb
Tags: 0.46~pre1-0ubuntu1
[ Kees Cook ]
* debian/control:
  - add libgtkspell-dev build-dep to gain GtkSpell features (LP: #183547).
  - update Standards version (no changes needed).
  - add Vcs and Homepage fields.
  - switch to new python-lxml dep.
* debian/{control,rules}: switch from dpatch to quilt for more sanity.
* debian/patches/20_fix_glib_and_gxx43_ftbfs.patch:
  - merged against upstream fixes.
  - added additional fixes for newly written code.
* debian/rules: enable parallel building.

[ Ted Gould ]
* Updating POTFILES.in to make it so things build correctly.
* debian/control:
  - add ImageMagick++ and libboost-dev to build-deps

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: inkscape-0.46~pre1/src/xml/composite-node-observer.h
 
2
===================================================================
 
3
--- inkscape-0.46~pre1.orig/src/xml/composite-node-observer.h   2008-02-10 23:44:28.000000000 -0800
 
4
+++ inkscape-0.46~pre1/src/xml/composite-node-observer.h        2008-02-10 23:44:55.000000000 -0800
 
5
@@ -15,6 +15,7 @@
 
6
 #ifndef SEEN_INKSCAPE_XML_COMPOSITE_NODE_OBSERVER_H
 
7
 #define SEEN_INKSCAPE_XML_COMPOSITE_NODE_OBSERVER_H
 
8
 
 
9
+#include <glib/gtestutils.h>
 
10
 #include "gc-managed.h"
 
11
 #include "xml/node-observer.h"
 
12
 #include "util/list-container.h"
 
13
Index: inkscape-0.46~pre1/src/libavoid/makepath.cpp
 
14
===================================================================
 
15
--- inkscape-0.46~pre1.orig/src/libavoid/makepath.cpp   2008-02-10 23:44:27.000000000 -0800
 
16
+++ inkscape-0.46~pre1/src/libavoid/makepath.cpp        2008-02-10 23:44:55.000000000 -0800
 
17
@@ -273,7 +273,7 @@
 
18
 {
 
19
     Router *router = src->_router;
 
20
 
 
21
-    double unseen = (double) INT_MAX;
 
22
+    double unseen = (double) __INT_MAX__;
 
23
 
 
24
     // initialize arrays
 
25
     VertInf *finish = router->vertices.end();
 
26
Index: inkscape-0.46~pre1/src/livarot/float-line.cpp
 
27
===================================================================
 
28
--- inkscape-0.46~pre1.orig/src/livarot/float-line.cpp  2008-02-10 23:44:27.000000000 -0800
 
29
+++ inkscape-0.46~pre1/src/livarot/float-line.cpp       2008-02-10 23:44:55.000000000 -0800
 
30
@@ -12,6 +12,7 @@
 
31
 #ifdef faster_flatten
 
32
 # include <cmath>  // std::abs(float)
 
33
 #endif
 
34
+#include <stdio.h>
 
35
 #include "livarot/float-line.h"
 
36
 #include "livarot/int-line.h"
 
37
 #include <cstdio>
 
38
Index: inkscape-0.46~pre1/src/libnr/nr-maybe.h
 
39
===================================================================
 
40
--- inkscape-0.46~pre1.orig/src/libnr/nr-maybe.h        2008-02-10 23:44:27.000000000 -0800
 
41
+++ inkscape-0.46~pre1/src/libnr/nr-maybe.h     2008-02-10 23:44:55.000000000 -0800
 
42
@@ -15,6 +15,7 @@
 
43
 
 
44
 #include <stdexcept>
 
45
 #include <string>
 
46
+#include <algorithm>
 
47
 
 
48
 namespace NR {
 
49
 
 
50
Index: inkscape-0.46~pre1/src/syseq.h
 
51
===================================================================
 
52
--- inkscape-0.46~pre1.orig/src/syseq.h 2008-02-10 23:44:28.000000000 -0800
 
53
+++ inkscape-0.46~pre1/src/syseq.h      2008-02-10 23:44:55.000000000 -0800
 
54
@@ -12,6 +12,7 @@
 
55
  * Released under GNU GPL, read the file 'COPYING' for more information
 
56
  */
 
57
 
 
58
+#include <algorithm>
 
59
 #include <iostream>
 
60
 #include <iomanip>
 
61
 #include <vector>
 
62
Index: inkscape-0.46~pre1/src/display/nr-filter-slot.cpp
 
63
===================================================================
 
64
--- inkscape-0.46~pre1.orig/src/display/nr-filter-slot.cpp      2008-02-10 23:44:27.000000000 -0800
 
65
+++ inkscape-0.46~pre1/src/display/nr-filter-slot.cpp   2008-02-10 23:44:55.000000000 -0800
 
66
@@ -14,6 +14,7 @@
 
67
  */
 
68
 
 
69
 #include <assert.h>
 
70
+#include <string.h>
 
71
 
 
72
 #include "display/nr-arena-item.h"
 
73
 #include "display/nr-filter-types.h"
 
74
Index: inkscape-0.46~pre1/src/live_effects/lpeobject-reference.cpp
 
75
===================================================================
 
76
--- inkscape-0.46~pre1.orig/src/live_effects/lpeobject-reference.cpp    2008-02-10 23:44:28.000000000 -0800
 
77
+++ inkscape-0.46~pre1/src/live_effects/lpeobject-reference.cpp 2008-02-10 23:44:55.000000000 -0800
 
78
@@ -6,6 +6,8 @@
 
79
  * Released under GNU GPL, read the file 'COPYING' for more information.
 
80
  */
 
81
 
 
82
+#include <string.h>
 
83
+
 
84
 #include "enums.h"
 
85
 #include "live_effects/lpeobject-reference.h"
 
86
 #include "live_effects/lpeobject.h"
 
87
Index: inkscape-0.46~pre1/src/ui/dialog/filter-effects-dialog.h
 
88
===================================================================
 
89
--- inkscape-0.46~pre1.orig/src/ui/dialog/filter-effects-dialog.h       2008-02-10 23:44:28.000000000 -0800
 
90
+++ inkscape-0.46~pre1/src/ui/dialog/filter-effects-dialog.h    2008-02-10 23:44:55.000000000 -0800
 
91
@@ -12,6 +12,8 @@
 
92
 #ifndef INKSCAPE_UI_DIALOG_FILTER_EFFECTS_H
 
93
 #define INKSCAPE_UI_DIALOG_FILTER_EFFECTS_H
 
94
 
 
95
+#include <memory>
 
96
+
 
97
 #include <gtkmm/adjustment.h>
 
98
 #include <gtkmm/alignment.h>
 
99
 #include <gtkmm/box.h>
 
100
Index: inkscape-0.46~pre1/src/widgets/ruler.h
 
101
===================================================================
 
102
--- inkscape-0.46~pre1.orig/src/widgets/ruler.h 2008-02-10 23:49:31.000000000 -0800
 
103
+++ inkscape-0.46~pre1/src/widgets/ruler.h      2008-02-10 23:49:45.000000000 -0800
 
104
@@ -15,7 +15,7 @@
 
105
 
 
106
 #include <gtk/gtkruler.h>
 
107
 #include "sp-metric.h"
 
108
-#include <iostream.h>
 
109
+#include <iostream>
 
110
 #include <glib.h>
 
111
 
 
112