~jderose/ubuntu/raring/qemu/vde-again

« back to all changes in this revision

Viewing changes to debian/patches/81_mips32r2_fpu.patch

  • Committer: Bazaar Package Importer
  • Author(s): Aurelien Jarno, Aurelien Jarno
  • Date: 2008-08-25 04:38:35 UTC
  • mfrom: (1.1.8 upstream)
  • Revision ID: james.westby@ubuntu.com-20080825043835-8e3tftavy8bujdch
Tags: 0.9.1-6
[ Aurelien Jarno ]
* debian/control: 
  - Update list of supported targets (Closes: bug#488339).
* debian/qemu-make-debian-root:
  - Use mktemp instead of $$ to create temporary directories (Closes: 
    bug#496394).
* debian/links:
  - Add missing links to manpages.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
commit e11972fd3238aa5b3847cdc530afe1c7319ffce2
 
2
Author: ths <ths>
 
3
Date:   Wed Jan 9 12:03:22 2008 +0000
 
4
 
 
5
    Fix typo which broke MIPS32R2 64-bit FPU support.
 
6
 
 
7
Index: qemu-0.9.1/target-mips/exec.h
 
8
===================================================================
 
9
--- qemu-0.9.1.orig/target-mips/exec.h  2008-01-06 20:38:45.000000000 +0100
 
10
+++ qemu-0.9.1/target-mips/exec.h       2008-04-14 11:26:14.000000000 +0200
 
11
@@ -258,7 +258,7 @@
 
12
     if (env->CP0_Status & (1 << CP0St_FR))
 
13
         env->hflags |= MIPS_HFLAG_F64;
 
14
     if (env->insn_flags & ISA_MIPS32R2) {
 
15
-        if (env->fpu->fcr0 & FCR0_F64)
 
16
+        if (env->fpu->fcr0 & (1 << FCR0_F64))
 
17
             env->hflags |= MIPS_HFLAG_COP1X;
 
18
     } else if (env->insn_flags & ISA_MIPS32) {
 
19
         if (env->hflags & MIPS_HFLAG_64)