~serge-hallyn/ubuntu/oneiric/libvirt/fix-shutdown

« back to all changes in this revision

Viewing changes to debian/patches/9002-better_default_uri_virsh.patch

  • Committer: Bazaar Package Importer
  • Author(s): Serge Hallyn
  • Date: 2010-11-02 16:26:51 UTC
  • mfrom: (1.2.7 upstream)
  • Revision ID: james.westby@ubuntu.com-20101102162651-aq8tnbz58mdf01bf
Tags: 0.8.5-0ubuntu1
* New upstream release.
* Removed a slew of patches which have been
  applied upstream since 0.8.3.
  - 9012-apparmor-extra-tests.patch
  - 9013-apparmor-chardev.patch
  - 9015-Add-ubd-to-the-list-of-disk-prefixes.patch
  - 9016-Close-fd-s-of-persistent-tap-devices.patch
  - 9017-Make-sure-all-command-line-arguments-get-passed-to-U.patch
  - 9018-Make-umlConnectTapDevice-ask-brAddTap-for-a-persiste.patch
  - 9019-uml-fix-logic-bug-in-checking-reply-length.patch
  - 9021-Allow-chardev-of-type-file-for-UML-domains.patch
  - 9022-Rename-qemudShrinkDisks-to-virDomainDiskRemove-and-m.patch
  - 9023-Support-virDomainAttachDevice-and-virDomainDetachDev.patch
  - 9024-Explicitly-pass-uml_dir-argument-to-user-mode-linux.patch
  - 9025-Add-nwfilter-support-to-UML-driver.patch
  - 9026-Rebuild-network-filter-for-UML-guests-on-updates.patch
  - 9027-Make-newfilter-xml-transformations-endian-safe.patch
  - 9028-lp628055.patch
* Updated 9002-better_default_uri_virsh.patch to use vshStrdup,
  as now required in that file.  (use of strdup now causes compilation
  to fail)
* Removed 9008-run-as-root-by-default.patch, which has not been
  applied for awhile now, with no ill effects.
* Simple refresh of:
  - 0001-remove-RHism.diff.patch
  - 0003-allow-libvirt-group-to-access-the-socket.patch
  - 0004-fix-Debian-specific-path-to-hvm-loader.patch
  - 0006-patch-qemuMonitorTextGetMigrationStatus-to-intercept.patch
  - 9000-delayed_iff_up_bridge.patch
  - 9001-dont_clobber_existing_bridges.patch
  - 9003-better-default-arch.patch
  - 9004-libvirtd-group-name.patch
  - 9005-increase-unix-socket-timeout.patch
  - 9006-default-config-test-case.patch
  - 9009-autodetect-nc-params.patch
  - 9010-dont-disable-ipv6.patch
  - 9011-move-ebtables-script.patch
  - 9014-skip-nodeinfotest.patch
  - 9020-lp545795.patch
* Create a patch to include stdint.h so lxc_container.h, which
  #includes linux/fs.h, doesn't trip up on undefined uint64_t.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: libvirt-0.8.3/tools/virsh.c
 
1
Index: libvirt-0.8.5/tools/virsh.c
2
2
===================================================================
3
 
--- libvirt-0.8.3.orig/tools/virsh.c    2010-08-04 06:35:58.000000000 -0500
4
 
+++ libvirt-0.8.3/tools/virsh.c 2010-08-11 17:02:04.000000000 -0500
 
3
--- libvirt-0.8.5.orig/tools/virsh.c    2010-11-02 16:26:33.704307000 -0500
 
4
+++ libvirt-0.8.5/tools/virsh.c 2010-11-02 16:29:22.793576001 -0500
5
5
@@ -63,6 +63,8 @@
6
6
 #define VSH_PROMPT_RW    "virsh # "
7
7
 #define VSH_PROMPT_RO    "virsh > "
11
11
 #define GETTIMEOFDAY(T) gettimeofday(T, NULL)
12
12
 #define DIFF_MSEC(T, U) \
13
13
         ((((int) ((T)->tv_sec - (U)->tv_sec)) * 1000000.0 + \
14
 
@@ -11121,6 +11123,10 @@
 
14
@@ -11596,6 +11598,10 @@
15
15
 
16
16
     if ((defaultConn = getenv("VIRSH_DEFAULT_CONNECT_URI"))) {
17
 
         ctl->name = strdup(defaultConn);
 
17
         ctl->name = vshStrdup(ctl, defaultConn);
18
18
+    } else if (!access(LIBVIRTD_PRIV_UNIX_SOCKET, W_OK)) {
19
 
+        ctl->name = strdup("qemu:///system");
 
19
+        ctl->name = vshStrdup(ctl, "qemu:///system");
20
20
+    } else {
21
 
+        ctl->name = strdup("qemu:///session");
 
21
+        ctl->name = vshStrdup(ctl, "qemu:///session");
22
22
     }
23
23
 
24
24
     if (!vshParseArgv(ctl, argc, argv)) {
25
 
Index: libvirt-0.8.3/tools/Makefile.am
 
25
Index: libvirt-0.8.5/tools/Makefile.am
26
26
===================================================================
27
 
--- libvirt-0.8.3.orig/tools/Makefile.am        2010-06-06 21:50:32.000000000 -0500
28
 
+++ libvirt-0.8.3/tools/Makefile.am     2010-08-11 17:02:04.000000000 -0500
29
 
@@ -45,9 +45,11 @@
 
27
--- libvirt-0.8.5.orig/tools/Makefile.am        2010-11-02 16:26:33.704307000 -0500
 
28
+++ libvirt-0.8.5/tools/Makefile.am     2010-11-02 16:29:22.793576001 -0500
 
29
@@ -51,9 +51,11 @@
30
30
                -I$(top_srcdir)/gnulib/lib -I../gnulib/lib      \
31
31
                -I../include -I$(top_srcdir)/include            \
32
32
                -I$(top_srcdir)/src                             \
38
38
                $(WARN_CFLAGS)                                  \
39
39
                $(COVERAGE_CFLAGS)                              \
40
40
                $(LIBXML_CFLAGS)                                \
41
 
Index: libvirt-0.8.3/tools/Makefile.in
 
41
Index: libvirt-0.8.5/tools/Makefile.in
42
42
===================================================================
43
 
--- libvirt-0.8.3.orig/tools/Makefile.in        2010-08-04 08:00:16.000000000 -0500
44
 
+++ libvirt-0.8.3/tools/Makefile.in     2010-08-11 17:02:04.000000000 -0500
45
 
@@ -1065,9 +1065,11 @@
 
43
--- libvirt-0.8.5.orig/tools/Makefile.in        2010-11-05 16:37:04.121871000 -0500
 
44
+++ libvirt-0.8.5/tools/Makefile.in     2010-11-05 16:38:28.991871001 -0500
 
45
@@ -1100,9 +1100,11 @@
46
46
                -I$(top_srcdir)/gnulib/lib -I../gnulib/lib      \
47
47
                -I../include -I$(top_srcdir)/include            \
48
48
                -I$(top_srcdir)/src                             \