~serge-hallyn/ubuntu/precise/rhythmbox/rhythmbox-sort

« back to all changes in this revision

Viewing changes to debian/patches/02_patch-134_ipod-crash.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastien Bacher
  • Date: 2005-12-02 19:23:18 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20051202192318-7ayjionj59dq1wk4
Tags: 0.9.2-0ubuntu3
* debian/control.in:
  - Build-Depends on libmusicbrainz4-dev so rhythmbox does the CD 
    query on internet (Ubuntu: #20363).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- orig/sources/rb-ipod-source.c
2
 
+++ mod/sources/rb-ipod-source.c
3
 
@@ -236,11 +236,11 @@
4
 
                /* Set disc number */
5
 
                if (song->cd_nr != 0) {
6
 
                        GValue value = {0, };
7
 
-                       g_value_init (&value, G_TYPE_ULONG);
8
 
-                       g_value_set_ulong (&value, song->cd_nr);
9
 
-                       rhythmdb_entry_set (RHYTHMDB (ctxt->db), entry, 
10
 
-                                           RHYTHMDB_PROP_DISC_NUMBER, 
11
 
-                                           &value);
12
 
+                       g_value_init (&value, G_TYPE_INT);
13
 
+                       g_value_set_int (&value, song->cd_nr);
14
 
+                       entry_set_locked (RHYTHMDB (ctxt->db), entry, 
15
 
+                                         RHYTHMDB_PROP_DISC_NUMBER, 
16
 
+                                         &value);
17
 
                        g_value_unset (&value);
18
 
                }
19
 
                
20
 
 
21
 
 
22