~ubuntu-branches/debian/sid/docky/sid

« back to all changes in this revision

Viewing changes to debian/patches/use-system-gio-sharp.patch

  • Committer: Package Import Robot
  • Author(s): Rico Tzschichholz
  • Date: 2012-01-19 19:03:38 UTC
  • mfrom: (1.1.14) (10.1.9 experimental)
  • Revision ID: package-import@ubuntu.com-20120119190338-n44q7tmqsrkudvk7
Tags: 2.1.3-2
* Upload to unstable
* debian/watch:
  + Look for xz tarballs from now on

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: docky/configure.ac
2
 
===================================================================
3
 
--- docky.orig/configure.ac
4
 
+++ docky/configure.ac
5
 
@@ -138,7 +138,18 @@
6
 
 DOCKY_WINDOWING_LIBS="-r:$(pwd)/build/Docky.Windowing.dll"
7
 
 AC_SUBST([DOCKY_WINDOWING_LIBS])
8
 
 
9
 
-GIO_SHARP_LIBS="-r:$(pwd)/build/gio-sharp.dll"
10
 
+dnl gio-sharp is an unstable api library
11
 
+GIO_SHARP_REQUIRED_VERSION=2.22.2
12
 
+PKG_CHECK_MODULES([GIO_SHARP], [gio-sharp-2.0 >= $GIO_SHARP_REQUIRED_VERSION])
13
 
+files="`$PKG_CONFIG --variable=Libraries gio-sharp-2.0`"
14
 
+for file in $files; do
15
 
+       [ mkdir -p $top_srcdir/build ] && [ cp -vu $file $top_srcdir/build/ ]
16
 
+       GIO_SHARP_ASSEMBLIES="$GIO_SHARP_ASSEMBLIES $top_srcdir/build/$(basename $file)"
17
 
+       GIO_SHARP_LIBS="$GIO_SHARP_LIBS -r:$top_srcdir/build/$(basename $file)"
18
 
+       [[ -r "$file.config" ]] && [ mkdir -p $top_srcdir/build ] && [ cp -vu $file.config $top_srcdir/build/ ]
19
 
+       [[ -r "$file.config" ]] && GIO_SHARP_ASSEMBLIES="$GIO_SHARP_ASSEMBLIES $top_srcdir/build/$(basename $file).config"
20
 
+done
21
 
+AC_SUBST([GIO_SHARP_ASSEMBLIES])
22
 
 AC_SUBST([GIO_SHARP_LIBS])
23
 
 
24
 
 PKG_CHECK_MODULES([NUNIT], [nunit], have_nunit=yes, have_nunit=no)
25
 
@@ -175,9 +186,6 @@
26
 
 
27
 
 AC_CONFIG_FILES([
28
 
 lib/Makefile
29
 
-lib/gio-sharp/Makefile
30
 
-lib/gio-sharp/generator/Makefile
31
 
-lib/gio-sharp/gio/Makefile
32
 
 scripts/Makefile
33
 
 scripts/docky/Makefile
34
 
 scripts/docky/docky.py
35
 
Index: docky/Makefile.am
36
 
===================================================================
37
 
--- docky.orig/Makefile.am
38
 
+++ docky/Makefile.am
39
 
@@ -5,11 +5,15 @@
40
 
 
41
 
 ACLOCAL_AMFLAGS = -I m4 -I m4/shamrock
42
 
 
43
 
+# Install copied assemblies to our libdir
44
 
+copiedlibsdir = $(pkglibdir)
45
 
+copiedlibs_DATA = \
46
 
+       $(GIO_SHARP_ASSEMBLIES)
47
 
+
48
 
 SUBDIRS = \
49
 
        . \
50
 
        data \
51
 
        scripts \
52
 
-       lib \
53
 
        po \
54
 
        Docky.CairoHelper \
55
 
        Docky.Services \