~ubuntu-branches/ubuntu/gutsy/tomboy/gutsy-updates

« back to all changes in this revision

Viewing changes to debian/patches/01-dbus0.9.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastian Dröge
  • Date: 2006-11-16 21:24:14 UTC
  • mfrom: (1.1.7 upstream) (2.1.1 etch)
  • Revision ID: james.westby@ubuntu.com-20061116212414-i9mqu3nnn90ulo7m
Tags: 0.5.0-0ubuntu1
* New upstream release
* debian/patches/52_applet-crash.patch:
  + Dropped, merged upstream
* debian/control,
  debian/patches/52_external-dbus-sharp.patch:
  + Build depend on libdbus-1-cil and build against it instead of the
    bundled version
* debian/rules:
  + Install DBus service file into the correct directory
* debian/patches/53_tomboy-tray-icon.patch:
  + Correctly set the icon for the trayicon

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- Tomboy/dbus-sharp/Connection.cs.old 2006-08-24 17:14:03.056705000 +0200
 
2
+++ Tomboy/dbus-sharp/Connection.cs     2006-08-24 17:14:15.061455250 +0200
 
3
@@ -89,7 +89,7 @@
 
4
     {
 
5
       if (disposing && RawConnection != IntPtr.Zero) 
 
6
        {
 
7
-         dbus_connection_disconnect(rawConnection);
 
8
+         dbus_connection_close(rawConnection);
 
9
 
 
10
          RawConnection = IntPtr.Zero; // free the native object
 
11
        }
 
12
@@ -314,7 +314,7 @@
 
13
                                                           int    slot);
 
14
     
 
15
     [DllImport ("dbus-1")]
 
16
-    private extern static void dbus_connection_disconnect (IntPtr ptr);
 
17
+    private extern static void dbus_connection_close (IntPtr ptr);
 
18
 
 
19
     [DllImport ("dbus-1")]
 
20
     private extern static IntPtr dbus_bus_get_unique_name (IntPtr ptr);