~ubuntu-branches/ubuntu/jaunty/ghostscript/jaunty-updates

« back to all changes in this revision

Viewing changes to debian/patches/02_gs_man_fix_debian.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Till Kamppeter
  • Date: 2009-01-20 16:40:45 UTC
  • mfrom: (1.1.10 upstream)
  • Revision ID: james.westby@ubuntu.com-20090120164045-lnfhi0n30o5lwhwa
Tags: 8.64.dfsg.1~svn9377-0ubuntu1
* New upstream release (SVN rev 9377)
   o Fixes many bugs concerning PDF rendering, to make the PDF printing
     workflow correctly working.
   o Fixes long-standing bugs in many drivers, like input paper tray and
     duplex options not working for the built-in PCL 4, 5, 5c, 5e, and
     6/XL drivers, PDF input not working for bjc600, bjc800, and cups
     output devices, several options not working and uninitialized
     memory with cups output device.
   o Merged nearly all patches of the Ubuntu and Debian packages upstream.
   o Fixes LP: #317810, LP: #314439, LP: #314018.
* debian/patches/03_libpaper_support.dpatch,
  debian/patches/11_gs-cjk_font_glyph_handling_fix.dpatch,
  debian/patches/12_gs-cjk_vertical_writing_metrics_fix.dpatch,
  debian/patches/13_gs-cjk_cjkps_examples.dpatch,
  debian/patches/20_bbox_segv_fix.dpatch,
  debian/patches/21_brother_7x0_gdi_fix.dpatch,
  debian/patches/22_epsn_margin_workaround.dpatch,
  debian/patches/24_gs_man_fix.dpatch,
  debian/patches/25_toolbin_insecure_tmp_usage_fix.dpatch,
  debian/patches/26_assorted_script_fixes.dpatch,
  debian/patches/29_gs_css_fix.dpatch,
  debian/patches/30_ps2pdf_man_improvement.dpatch,
  debian/patches/31_fix-gc-sigbus.dpatch,
  debian/patches/34_ftbfs-on-hurd-fix.dpatch,
  debian/patches/35_disable_libcairo.dpatch,
  debian/patches/38_pxl-duplex.dpatch,
  debian/patches/39_pxl-resolution.dpatch,
  debian/patches/42_gs-init-ps-delaybind-fix.dpatch,
  debian/patches/45_bjc600-bjc800-pdf-input.dpatch,
  debian/patches/48_cups-output-device-pdf-duplex-uninitialized-memory-fix.dpatch,
  debian/patches/50_lips4-floating-point-exception.dpatch,
  debian/patches/52_cups-device-logging.dpatch,
  debian/patches/55_pcl-input-slot-fix.dpatch,
  debian/patches/57_pxl-input-slot-fix.dpatch,
  debian/patches/60_pxl-cups-driver-pdf.dpatch,
  debian/patches/62_onebitcmyk-pdf.dpatch,
  debian/patches/65_too-big-temp-files-1.dpatch,
  debian/patches/67_too-big-temp-files-2.dpatch,
  debian/patches/70_take-into-account-data-in-stream-buffer-before-refill.dpatch:
  Removed, applied upstream.
* debian/patches/01_docdir_fix_for_debian.dpatch,
  debian/patches/02_gs_man_fix_debian.dpatch,
  debian/patches/01_docdir-fix-for-debian.dpatch,
  debian/patches/02_docdir-fix-for-debian.dpatch: Renamed patches to
  make merging with Debian easier.
* debian/patches/32_improve-handling-of-media-size-changes-from-gv.dpatch, 
  debian/patches/33_bad-params-to-xinitimage-on-large-bitmaps.dpatch:
  regenerated for new source directory structure.
* debian/rules: Corrected paths to remove cidfmap (it is in Resource/Init/
  in GS 8.64) and to install headers (source paths are psi/ and base/ now).
* debian/rules: Remove all fontmaps, as DeFoMa replaces them.
* debian/local/pdftoraster/pdftoraster.c,
  debian/local/pdftoraster/pdftoraster.convs, debian/rules: Removed
  added pdftoraster filter and use the one which comes with Ghostscript.
* debian/ghostscript.links: s/8.63/8.64/

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
## 02_gs_man_fix_debian.dpatch by Masayuki Hatta <mhatta@debian.org>
3
 
##
4
 
## All lines beginning with \`## DP:' are a description of the patch.
5
 
## DP: Fixes for gs.1 (Debian specific path adjustments)
6
 
 
7
 
if [ $# -ne 1 ]; then
8
 
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
9
 
    exit 1
10
 
fi
11
 
case "$1" in
12
 
        -patch) patch -f --no-backup-if-mismatch --dry-run -p1 < $0 && patch -f --no-backup-if-mismatch -p1 < $0
13
 
;;
14
 
        -unpatch) patch -f --no-backup-if-mismatch -R -p1 < $0;;
15
 
        *)
16
 
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
17
 
                exit 1;;
18
 
esac
19
 
 
20
 
exit 0
21
 
 
22
 
diff -urN gs-gpl-8.56.dfsg.1.orig/man/gs.1 gs-gpl-8.56.dfsg.1/man/gs.1
23
 
--- gs-gpl-8.56.dfsg.1.orig/man/gs.1    2007-05-05 01:09:16.000000000 +0900
24
 
+++ gs-gpl-8.56.dfsg.1/man/gs.1 2007-05-05 01:09:51.000000000 +0900
25
 
@@ -295,18 +295,18 @@
26
 
 are typically based in \fBC:\\GS\fR, but may be elsewhere, especially if
27
 
 you install Ghostscript with \fBGSview\fR.  Run "\fBgs -h\fR" to find the
28
 
 location of Ghostscript documentation on your system, from which you can
29
 
-get more details.
30
 
+get more details. On a Debian system they are in \fB/usr\fR.
31
 
 .TP
32
 
-.B /usr/local/share/ghostscript/#.##/*
33
 
+.B /usr/share/ghostscript/#.##/*/*
34
 
 Startup files, utilities, and basic font definitions
35
 
 .TP
36
 
-.B /usr/local/share/ghostscript/fonts/*
37
 
-More font definitions
38
 
+.B /usr/share/fonts/type1/gsfonts/*
39
 
+More font definitions from the gsfonts package
40
 
 .TP
41
 
-.B /usr/local/share/ghostscript/#.##/examples/*
42
 
+.B /usr/share/doc/ghostscript/examples/*
43
 
 Ghostscript demonstration files
44
 
 .TP
45
 
-.B /usr/local/share/ghostscript/#.##/doc/*
46
 
+.B /usr/share/doc/ghostscript/*
47
 
 Diverse document files
48
 
 .SH "INITIALIZATION FILES"
49
 
 When looking for the initialization files "gs_*.ps", the files related to
50
 
@@ -330,7 +330,8 @@
51
 
 Ghostscript makefile when the executable was built.  When \fBgs\fR is built
52
 
 on Unix, \fBGS_LIB_DEFAULT\fR is usually
53
 
 "/usr/local/share/ghostscript/#.##:/usr/local/share/ghostscript/fonts"
54
 
-where "#.##" represents the Ghostscript version number.
55
 
+where "#.##" represents the Ghostscript version number. They are
56
 
+"/usr/share/ghostscript/#.## on a Debian system".
57
 
 .PP
58
 
 Each of these (\fBGS_LIB_DEFAULT\fR, \fBGS_LIB\fR, and \fB\-I\fR parameter)
59
 
 may be either a single directory or a list of directories separated by