~ubuntu-branches/ubuntu/jaunty/ghostscript/jaunty-updates

« back to all changes in this revision

Viewing changes to debian/patches/03_libpaper_support.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Till Kamppeter
  • Date: 2009-01-20 16:40:45 UTC
  • mfrom: (1.1.10 upstream)
  • Revision ID: james.westby@ubuntu.com-20090120164045-lnfhi0n30o5lwhwa
Tags: 8.64.dfsg.1~svn9377-0ubuntu1
* New upstream release (SVN rev 9377)
   o Fixes many bugs concerning PDF rendering, to make the PDF printing
     workflow correctly working.
   o Fixes long-standing bugs in many drivers, like input paper tray and
     duplex options not working for the built-in PCL 4, 5, 5c, 5e, and
     6/XL drivers, PDF input not working for bjc600, bjc800, and cups
     output devices, several options not working and uninitialized
     memory with cups output device.
   o Merged nearly all patches of the Ubuntu and Debian packages upstream.
   o Fixes LP: #317810, LP: #314439, LP: #314018.
* debian/patches/03_libpaper_support.dpatch,
  debian/patches/11_gs-cjk_font_glyph_handling_fix.dpatch,
  debian/patches/12_gs-cjk_vertical_writing_metrics_fix.dpatch,
  debian/patches/13_gs-cjk_cjkps_examples.dpatch,
  debian/patches/20_bbox_segv_fix.dpatch,
  debian/patches/21_brother_7x0_gdi_fix.dpatch,
  debian/patches/22_epsn_margin_workaround.dpatch,
  debian/patches/24_gs_man_fix.dpatch,
  debian/patches/25_toolbin_insecure_tmp_usage_fix.dpatch,
  debian/patches/26_assorted_script_fixes.dpatch,
  debian/patches/29_gs_css_fix.dpatch,
  debian/patches/30_ps2pdf_man_improvement.dpatch,
  debian/patches/31_fix-gc-sigbus.dpatch,
  debian/patches/34_ftbfs-on-hurd-fix.dpatch,
  debian/patches/35_disable_libcairo.dpatch,
  debian/patches/38_pxl-duplex.dpatch,
  debian/patches/39_pxl-resolution.dpatch,
  debian/patches/42_gs-init-ps-delaybind-fix.dpatch,
  debian/patches/45_bjc600-bjc800-pdf-input.dpatch,
  debian/patches/48_cups-output-device-pdf-duplex-uninitialized-memory-fix.dpatch,
  debian/patches/50_lips4-floating-point-exception.dpatch,
  debian/patches/52_cups-device-logging.dpatch,
  debian/patches/55_pcl-input-slot-fix.dpatch,
  debian/patches/57_pxl-input-slot-fix.dpatch,
  debian/patches/60_pxl-cups-driver-pdf.dpatch,
  debian/patches/62_onebitcmyk-pdf.dpatch,
  debian/patches/65_too-big-temp-files-1.dpatch,
  debian/patches/67_too-big-temp-files-2.dpatch,
  debian/patches/70_take-into-account-data-in-stream-buffer-before-refill.dpatch:
  Removed, applied upstream.
* debian/patches/01_docdir_fix_for_debian.dpatch,
  debian/patches/02_gs_man_fix_debian.dpatch,
  debian/patches/01_docdir-fix-for-debian.dpatch,
  debian/patches/02_docdir-fix-for-debian.dpatch: Renamed patches to
  make merging with Debian easier.
* debian/patches/32_improve-handling-of-media-size-changes-from-gv.dpatch, 
  debian/patches/33_bad-params-to-xinitimage-on-large-bitmaps.dpatch:
  regenerated for new source directory structure.
* debian/rules: Corrected paths to remove cidfmap (it is in Resource/Init/
  in GS 8.64) and to install headers (source paths are psi/ and base/ now).
* debian/rules: Remove all fontmaps, as DeFoMa replaces them.
* debian/local/pdftoraster/pdftoraster.c,
  debian/local/pdftoraster/pdftoraster.convs, debian/rules: Removed
  added pdftoraster filter and use the one which comes with Ghostscript.
* debian/ghostscript.links: s/8.63/8.64/

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
## 03_libpaper_support.dpatch by Masayuki Hatta <mhatta@debian.org>
3
 
##
4
 
## All lines beginning with \`## DP:' are a description of the patch.
5
 
## DP: Adds libpaper support
6
 
 
7
 
if [ $# -ne 1 ]; then
8
 
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
9
 
    exit 1
10
 
fi
11
 
case "$1" in
12
 
        -patch) patch -f --no-backup-if-mismatch --dry-run -p1 < $0 && patch -f --no-backup-if-mismatch -p1 < $0
13
 
;;
14
 
        -unpatch) patch -f --no-backup-if-mismatch -R -p1 < $0;;
15
 
        *)
16
 
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
17
 
                exit 1;;
18
 
esac
19
 
 
20
 
exit 0
21
 
 
22
 
diff -ur gs/lib/gs_init.ps ghostscript-8.61.dfsg.1~svn8187/lib/gs_init.ps
23
 
--- gs/lib/gs_init.ps   2007-12-03 19:48:52.000000000 +0100
24
 
+++ ghostscript-8.61.dfsg.1~svn8187/lib/gs_init.ps      2007-12-03 19:43:05.000000000 +0100
25
 
@@ -76,6 +76,13 @@
26
 
 % devices that default to letter or A4 can be changed by setting
27
 
 % DEFAULTPAPERSIZE.
28
 
 % /DEFAULTPAPERSIZE (a4) def
29
 
+% Debian: Libpaper's default is in DEFPAPERSIZE; use that if the
30
 
+%         current device is not "cups".
31
 
+currentdict /DEFPAPERSIZE known
32
 
+currentdict /DEVICE known { DEVICE } { () } ifelse
33
 
+(cups) ne and
34
 
+  { DEFPAPERSIZE /PAPERSIZE where { pop pop } { /PAPERSIZE exch def } ifelse }
35
 
+if
36
 
 
37
 
 % Turn on array packing for the rest of initialization.
38
 
 true setpacking
39
 
diff -ur gs/src/imainarg.c ghostscript-8.61.dfsg.1~svn8187/src/imainarg.c
40
 
--- gs/src/imainarg.c   2007-12-03 19:48:32.000000000 +0100
41
 
+++ ghostscript-8.61.dfsg.1~svn8187/src/imainarg.c      2007-12-03 19:43:05.000000000 +0100
42
 
@@ -194,6 +194,31 @@
43
 
                return e_Fatal;
44
 
        }
45
 
     }
46
 
+
47
 
+    /* Change by Torsten Landschoff <torsten@debian.org>:
48
 
+     * If no papersize is given on the commandline we want gs to use the
49
 
+     * default papersize of the system. This change differs from the old
50
 
+     * Debian change in that it does not use arg_push_string and therefore
51
 
+     * is not using up the nesting depth.
52
 
+     *  -- Thu, 30 Mar 2000 21:28:25 +0200
53
 
+     *
54
 
+     * Applied to GPL/AFPL GhostScript by Masayuki Hatta
55
 
+     *  -- Wed Mar 24 15:00:00 JST 2004 */
56
 
+
57
 
+    {
58
 
+#      include <paper.h>
59
 
+      const char *paper = systempapername();
60
 
+      static char paperswitch[15+40+1] = "";
61
 
+      /* strlen("-sDEFPAPERSIZE") + 40 + space for '\0' */
62
 
+      
63
 
+      if (paper != NULL && *paperswitch == '\0') {
64
 
+       strncat(paperswitch, "-sDEFPAPERSIZE=", 15);
65
 
+       strncat(paperswitch, paper, 40);
66
 
+       swproc(minst, paperswitch, &args);
67
 
+       /* args is not modified since a "-s" argument does not need
68
 
+        * such special handling */
69
 
+      }
70
 
+    }
71
 
     while ((arg = arg_next(&args, &code)) != 0) {
72
 
        switch (*arg) {
73
 
            case '-':
74