~ubuntu-branches/ubuntu/jaunty/ghostscript/jaunty-updates

« back to all changes in this revision

Viewing changes to debian/patches/39_pxl-resolution.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Till Kamppeter
  • Date: 2009-01-20 16:40:45 UTC
  • mfrom: (1.1.10 upstream)
  • Revision ID: james.westby@ubuntu.com-20090120164045-lnfhi0n30o5lwhwa
Tags: 8.64.dfsg.1~svn9377-0ubuntu1
* New upstream release (SVN rev 9377)
   o Fixes many bugs concerning PDF rendering, to make the PDF printing
     workflow correctly working.
   o Fixes long-standing bugs in many drivers, like input paper tray and
     duplex options not working for the built-in PCL 4, 5, 5c, 5e, and
     6/XL drivers, PDF input not working for bjc600, bjc800, and cups
     output devices, several options not working and uninitialized
     memory with cups output device.
   o Merged nearly all patches of the Ubuntu and Debian packages upstream.
   o Fixes LP: #317810, LP: #314439, LP: #314018.
* debian/patches/03_libpaper_support.dpatch,
  debian/patches/11_gs-cjk_font_glyph_handling_fix.dpatch,
  debian/patches/12_gs-cjk_vertical_writing_metrics_fix.dpatch,
  debian/patches/13_gs-cjk_cjkps_examples.dpatch,
  debian/patches/20_bbox_segv_fix.dpatch,
  debian/patches/21_brother_7x0_gdi_fix.dpatch,
  debian/patches/22_epsn_margin_workaround.dpatch,
  debian/patches/24_gs_man_fix.dpatch,
  debian/patches/25_toolbin_insecure_tmp_usage_fix.dpatch,
  debian/patches/26_assorted_script_fixes.dpatch,
  debian/patches/29_gs_css_fix.dpatch,
  debian/patches/30_ps2pdf_man_improvement.dpatch,
  debian/patches/31_fix-gc-sigbus.dpatch,
  debian/patches/34_ftbfs-on-hurd-fix.dpatch,
  debian/patches/35_disable_libcairo.dpatch,
  debian/patches/38_pxl-duplex.dpatch,
  debian/patches/39_pxl-resolution.dpatch,
  debian/patches/42_gs-init-ps-delaybind-fix.dpatch,
  debian/patches/45_bjc600-bjc800-pdf-input.dpatch,
  debian/patches/48_cups-output-device-pdf-duplex-uninitialized-memory-fix.dpatch,
  debian/patches/50_lips4-floating-point-exception.dpatch,
  debian/patches/52_cups-device-logging.dpatch,
  debian/patches/55_pcl-input-slot-fix.dpatch,
  debian/patches/57_pxl-input-slot-fix.dpatch,
  debian/patches/60_pxl-cups-driver-pdf.dpatch,
  debian/patches/62_onebitcmyk-pdf.dpatch,
  debian/patches/65_too-big-temp-files-1.dpatch,
  debian/patches/67_too-big-temp-files-2.dpatch,
  debian/patches/70_take-into-account-data-in-stream-buffer-before-refill.dpatch:
  Removed, applied upstream.
* debian/patches/01_docdir_fix_for_debian.dpatch,
  debian/patches/02_gs_man_fix_debian.dpatch,
  debian/patches/01_docdir-fix-for-debian.dpatch,
  debian/patches/02_docdir-fix-for-debian.dpatch: Renamed patches to
  make merging with Debian easier.
* debian/patches/32_improve-handling-of-media-size-changes-from-gv.dpatch, 
  debian/patches/33_bad-params-to-xinitimage-on-large-bitmaps.dpatch:
  regenerated for new source directory structure.
* debian/rules: Corrected paths to remove cidfmap (it is in Resource/Init/
  in GS 8.64) and to install headers (source paths are psi/ and base/ now).
* debian/rules: Remove all fontmaps, as DeFoMa replaces them.
* debian/local/pdftoraster/pdftoraster.c,
  debian/local/pdftoraster/pdftoraster.convs, debian/rules: Removed
  added pdftoraster filter and use the one which comes with Ghostscript.
* debian/ghostscript.links: s/8.63/8.64/

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 39_pxl-resolution.dpatch by  <till.kamppeter@gmail.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad ghostscript-8.63.dfsg.1~/src/gdevpxut.c ghostscript-8.63.dfsg.1/src/gdevpxut.c
9
 
--- ghostscript-8.63.dfsg.1~/src/gdevpxut.c     2007-06-07 00:03:27.000000000 +0200
10
 
+++ ghostscript-8.63.dfsg.1/src/gdevpxut.c      2008-10-13 22:51:58.000000000 +0200
11
 
@@ -11,7 +11,7 @@
12
 
    San Rafael, CA  94903, U.S.A., +1(415)492-9861, for further information.
13
 
 */
14
 
 
15
 
-/* $Id: gdevpxut.c 8026 2007-06-06 22:03:27Z till $ */
16
 
+/* $Id: gdevpxut.c 9061 2008-09-02 18:37:07Z till $ */
17
 
 /* Utilities for PCL XL generation */
18
 
 #include "math_.h"
19
 
 #include "string_.h"
20
 
@@ -33,6 +33,13 @@
21
 
         "\033%-12345X@PJL SET RENDERMODE=";
22
 
     static const char *const rendermode_gray = "GRAYSCALE";
23
 
     static const char *const rendermode_color = "COLOR";
24
 
+    static const char *const pjl_resolution =
25
 
+        "\n@PJL SET RESOLUTION=";
26
 
+    static const char *const resolution_150 = "150";
27
 
+    static const char *const resolution_300 = "300";
28
 
+    static const char *const resolution_600 = "600";
29
 
+    static const char *const resolution_1200 = "1200";
30
 
+    static const char *const resolution_2400 = "2400";
31
 
     static const char *const file_header =
32
 
        "\n@PJL ENTER LANGUAGE = PCLXL\n\
33
 
 ) HP-PCL XL;1;1;Comment Copyright Artifex Sofware, Inc. 2005\000\n";
34
 
@@ -56,6 +63,44 @@
35
 
        px_put_bytes(s, (const byte *)rendermode_color,
36
 
                     strlen(rendermode_color));
37
 
 
38
 
+    px_put_bytes(s, (const byte *)pjl_resolution,
39
 
+                strlen(pjl_resolution));
40
 
+
41
 
+    if ((uint) (dev->HWResolution[0] + 0.5) == 150)
42
 
+       px_put_bytes(s, (const byte *)resolution_150,
43
 
+                    strlen(resolution_150));
44
 
+    else if ((uint) (dev->HWResolution[0] + 0.5) == 300)
45
 
+       px_put_bytes(s, (const byte *)resolution_300,
46
 
+                    strlen(resolution_300));
47
 
+    else if ((uint) (dev->HWResolution[0] + 0.5) == 1200)
48
 
+       px_put_bytes(s, (const byte *)resolution_1200,
49
 
+                    strlen(resolution_1200));
50
 
+    else if ((uint) (dev->HWResolution[0] + 0.5) == 2400)
51
 
+       px_put_bytes(s, (const byte *)resolution_2400,
52
 
+                    strlen(resolution_2400));
53
 
+    else 
54
 
+        px_put_bytes(s, (const byte *)resolution_600,
55
 
+                    strlen(resolution_600));
56
 
+    if ((uint) (dev->HWResolution[1] + 0.5) !=
57
 
+       (uint) (dev->HWResolution[0] + 0.5)) {
58
 
+        px_put_bytes(s, (const byte *)"x", strlen("x"));
59
 
+       if ((uint) (dev->HWResolution[1] + 0.5) == 150)
60
 
+           px_put_bytes(s, (const byte *)resolution_150,
61
 
+                        strlen(resolution_150));
62
 
+       else if ((uint) (dev->HWResolution[1] + 0.5) == 300)
63
 
+           px_put_bytes(s, (const byte *)resolution_300,
64
 
+                        strlen(resolution_300));
65
 
+       else if ((uint) (dev->HWResolution[1] + 0.5) == 1200)
66
 
+           px_put_bytes(s, (const byte *)resolution_1200,
67
 
+                        strlen(resolution_1200));
68
 
+       else if ((uint) (dev->HWResolution[1] + 0.5) == 2400)
69
 
+           px_put_bytes(s, (const byte *)resolution_2400,
70
 
+                        strlen(resolution_2400));
71
 
+       else 
72
 
+           px_put_bytes(s, (const byte *)resolution_600,
73
 
+                        strlen(resolution_600));
74
 
+    }
75
 
+
76
 
     /* We have to add 2 to the strlen because the next-to-last */
77
 
     /* character is a null. */
78
 
     px_put_bytes(s, (const byte *)file_header,