~ubuntu-branches/ubuntu/jaunty/ghostscript/jaunty-updates

« back to all changes in this revision

Viewing changes to debian/patches/55_pcl-input-slot-fix.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Till Kamppeter
  • Date: 2009-01-20 16:40:45 UTC
  • mfrom: (1.1.10 upstream)
  • Revision ID: james.westby@ubuntu.com-20090120164045-lnfhi0n30o5lwhwa
Tags: 8.64.dfsg.1~svn9377-0ubuntu1
* New upstream release (SVN rev 9377)
   o Fixes many bugs concerning PDF rendering, to make the PDF printing
     workflow correctly working.
   o Fixes long-standing bugs in many drivers, like input paper tray and
     duplex options not working for the built-in PCL 4, 5, 5c, 5e, and
     6/XL drivers, PDF input not working for bjc600, bjc800, and cups
     output devices, several options not working and uninitialized
     memory with cups output device.
   o Merged nearly all patches of the Ubuntu and Debian packages upstream.
   o Fixes LP: #317810, LP: #314439, LP: #314018.
* debian/patches/03_libpaper_support.dpatch,
  debian/patches/11_gs-cjk_font_glyph_handling_fix.dpatch,
  debian/patches/12_gs-cjk_vertical_writing_metrics_fix.dpatch,
  debian/patches/13_gs-cjk_cjkps_examples.dpatch,
  debian/patches/20_bbox_segv_fix.dpatch,
  debian/patches/21_brother_7x0_gdi_fix.dpatch,
  debian/patches/22_epsn_margin_workaround.dpatch,
  debian/patches/24_gs_man_fix.dpatch,
  debian/patches/25_toolbin_insecure_tmp_usage_fix.dpatch,
  debian/patches/26_assorted_script_fixes.dpatch,
  debian/patches/29_gs_css_fix.dpatch,
  debian/patches/30_ps2pdf_man_improvement.dpatch,
  debian/patches/31_fix-gc-sigbus.dpatch,
  debian/patches/34_ftbfs-on-hurd-fix.dpatch,
  debian/patches/35_disable_libcairo.dpatch,
  debian/patches/38_pxl-duplex.dpatch,
  debian/patches/39_pxl-resolution.dpatch,
  debian/patches/42_gs-init-ps-delaybind-fix.dpatch,
  debian/patches/45_bjc600-bjc800-pdf-input.dpatch,
  debian/patches/48_cups-output-device-pdf-duplex-uninitialized-memory-fix.dpatch,
  debian/patches/50_lips4-floating-point-exception.dpatch,
  debian/patches/52_cups-device-logging.dpatch,
  debian/patches/55_pcl-input-slot-fix.dpatch,
  debian/patches/57_pxl-input-slot-fix.dpatch,
  debian/patches/60_pxl-cups-driver-pdf.dpatch,
  debian/patches/62_onebitcmyk-pdf.dpatch,
  debian/patches/65_too-big-temp-files-1.dpatch,
  debian/patches/67_too-big-temp-files-2.dpatch,
  debian/patches/70_take-into-account-data-in-stream-buffer-before-refill.dpatch:
  Removed, applied upstream.
* debian/patches/01_docdir_fix_for_debian.dpatch,
  debian/patches/02_gs_man_fix_debian.dpatch,
  debian/patches/01_docdir-fix-for-debian.dpatch,
  debian/patches/02_docdir-fix-for-debian.dpatch: Renamed patches to
  make merging with Debian easier.
* debian/patches/32_improve-handling-of-media-size-changes-from-gv.dpatch, 
  debian/patches/33_bad-params-to-xinitimage-on-large-bitmaps.dpatch:
  regenerated for new source directory structure.
* debian/rules: Corrected paths to remove cidfmap (it is in Resource/Init/
  in GS 8.64) and to install headers (source paths are psi/ and base/ now).
* debian/rules: Remove all fontmaps, as DeFoMa replaces them.
* debian/local/pdftoraster/pdftoraster.c,
  debian/local/pdftoraster/pdftoraster.convs, debian/rules: Removed
  added pdftoraster filter and use the one which comes with Ghostscript.
* debian/ghostscript.links: s/8.63/8.64/

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 55_pcl-input-slot-fix.dpatch by  <till.kamppeter@gmail.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad ghostscript-8.63.dfsg.1~/src/gdevdjet.c ghostscript-8.63.dfsg.1/src/gdevdjet.c
9
 
--- ghostscript-8.63.dfsg.1~/src/gdevdjet.c     2008-05-02 03:42:14.000000000 +0200
10
 
+++ ghostscript-8.63.dfsg.1/src/gdevdjet.c      2008-11-26 11:12:03.000000000 +0100
11
 
@@ -316,12 +316,10 @@
12
 
 {
13
 
     gx_device_hpjet *dev = (gx_device_hpjet *)pdev;
14
 
     int paper_source = -1;
15
 
-    int paper_source_tab[] = { 5, 1 };
16
 
 
17
 
     if (dev->ManualFeed_set && dev->ManualFeed) paper_source = 2;
18
 
-    else if (dev->MediaPosition_set && dev->MediaPosition >= 0 &&
19
 
-            dev->MediaPosition < countof(paper_source_tab))
20
 
-       paper_source = paper_source_tab[dev->MediaPosition];
21
 
+    else if (dev->MediaPosition_set && dev->MediaPosition >= 0)
22
 
+       paper_source = dev->MediaPosition;
23
 
     if (paper_source >= 0)
24
 
        sprintf(buf, "%s\033&l%dH", str, paper_source);
25
 
     else
26
 
@@ -549,6 +547,10 @@
27
 
     {
28
 
        code = param_write_bool(plist, "ManualFeed", &dev->ManualFeed);
29
 
     }
30
 
+    if (code >= 0)
31
 
+    {
32
 
+       code = param_write_int(plist, "MediaPosition", &dev->MediaPosition);
33
 
+    }
34
 
     if (code >=0)
35
 
        code = param_write_bool(plist, "Tumble", &dev->Tumble);
36
 
     return code;
37
 
@@ -568,10 +570,10 @@
38
 
     code = param_read_bool(plist, "ManualFeed", &ManualFeed);
39
 
     if (code == 0) ManualFeed_set = true;
40
 
     if (code >= 0) {
41
 
-       code = param_read_int(plist, "%MediaSource", &MediaPosition);
42
 
+       code = param_read_int(plist, "MediaPosition", &MediaPosition);
43
 
        if (code == 0) MediaPosition_set = true;
44
 
        else if (code < 0) {
45
 
-           if (param_read_null(plist, "%MediaSource") == 0) {
46
 
+           if (param_read_null(plist, "MediaPosition") == 0) {
47
 
                code = 0;
48
 
            }
49
 
        }