~ubuntu-branches/ubuntu/jaunty/gnome-applets/jaunty

« back to all changes in this revision

Viewing changes to debian/patches/19_modem-applet_network-admin_gksu.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastien Bacher
  • Date: 2008-06-03 18:13:41 UTC
  • mfrom: (1.1.30 upstream)
  • Revision ID: james.westby@ubuntu.com-20080603181341-j2ldywy9g983scl2
Tags: 2.23.2-0ubuntu1
* New upstream version
* Sync on Debian
* debian/control.in:
  - build using liboobs and not type-handling and libcpufreq-dev
  - Pre-Depends: dpkg (>= 1.10.24)
  - updated maintainer information
* debian/patches/04_applets_categories.patch:
  - set applets categories
* debian/patches/13_battstat_measuring_more_appropriate.patch:
  - workaround acpi bug
* debian/patches/14_battstat_enable_pmi.patch:
  - use the pmi interface to know if suspend is available
* debian/patches/81_mixer_mute_callback.patch:
  - stop the mixer applet from randomly muting when the volume is adjusted.
* debian/patches/98_autoreconf.patch:
  - run autotools update
* debian/rules:
  - DEB_DH_BUILDDEB_ARGS := -- -Zbzip2

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Nur gnome-applets-2.16.1/modemlights/modem-applet.c gnome-applets-2.16.1.new/modemlights/modem-applet.c
2
 
--- gnome-applets-2.16.1/modemlights/modem-applet.c     2006-12-14 14:59:55.000000000 +0000
3
 
+++ gnome-applets-2.16.1.new/modemlights/modem-applet.c 2006-12-14 15:00:23.000000000 +0000
4
 
@@ -357,22 +357,29 @@
5
 
 static gboolean
6
 
 launch_config_tool (GdkScreen *screen, OobsIface *iface)
7
 
 {
8
 
-  gchar    *argv[4], *application;
9
 
+  gchar    *argv[6], *application, *gksu;
10
 
   gboolean  ret;
11
 
 
12
 
+  gksu = g_find_program_in_path ("gksu");
13
 
   application = g_find_program_in_path (NETWORK_TOOL);
14
 
 
15
 
-  if (!application)
16
 
+  if (!application || !gksu) {
17
 
+    g_free (application);
18
 
+    g_free (gksu);
19
 
     return FALSE;
20
 
+  }
21
 
 
22
 
-  argv[0] = application;
23
 
-  argv[1] = "--configure";
24
 
-  argv[2] = (gchar*) oobs_iface_get_device_name (iface);
25
 
-  argv[3] = NULL;
26
 
+  argv[0] = gksu;
27
 
+  argv[1] = "--";
28
 
+  argv[2] = application;
29
 
+  argv[3] = "--configure";
30
 
+  argv[4] = (gchar*) oobs_iface_get_device_name (iface);
31
 
+  argv[5] = NULL;
32
 
 
33
 
   ret = gdk_spawn_on_screen (screen, NULL, argv, NULL, 0,
34
 
                             NULL, NULL, NULL, NULL);
35
 
   g_free (application);
36
 
+  g_free (gksu);
37
 
   return ret;
38
 
 }
39