~ubuntu-branches/ubuntu/karmic/sysvinit/karmic-updates

« back to all changes in this revision

Viewing changes to debian/patches/13_doc_telinit.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Scott James Remnant
  • Date: 2009-09-07 19:56:53 UTC
  • mfrom: (1.1.4 upstream) (2.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20090907195653-2i6t0j91wfbf1f0d
Tags: 2.87dsf-4ubuntu1
* Merge from debian unstable, remaining changes:
  - Support Cell processor:
    + debian/initscripts/postinst: Create spu system group and /spu mount
      point if we are running on a Cell processor.
    + debian/initscripts/etc/init.d/mountkernfs.sh: Mount spufs if Cell
      processor is detected.
    + debian/initscripts/lib/init/mount-functions.sh: Modprobe spufs
      if not available.
    + debian/control: Add initscripts dependency 'passwd' for groupadd.
    (Forwarded to Debian #483399)
  - Use tmpfs mounts for /var/lock and /var/run:
    + debian/initscripts/share/default.rcS: Enable RAMRUN and RAMLOCK by
      default.
    + debian/initscripts.postinst: Enable RAMRUN and RAMLOCK in
      /etc/default/rcS on upgrades. This needs to be kept until the next
      LTS.
    + debian/initscripts/etc/init.d/mountkernfs.sh: Propagate files from the
      initramfs to our new /var/run, so that we can populate
      /var/run/sendsigs.omit from initramfs.
  - Boot ordering differences:
    + mountkernfs.sh: 02 -> 01
    + mountdevsubfs.sh: 04 -> 11
    + bootlogd: disabled by default
    + checkroot.sh: 10 -> 20
    + mtab.sh: 12 -> 22
  - debian/patches/91_sulogin_lockedpw.dpatch: Disable "root account is
    locked" warning, since this is the default in Ubuntu. Document this in
    sulogin.8.
  - debian/control: Drop Essential: yes from packages since we use Upstart.
  - debian/control: Conflict/Replace sysvconfig which has also previously
    provided service(8).
  - debian/control, debian/rules: Previous name for sysvinit-utils was
    'sysvutils' in Ubuntu, so Conflict/Replace/Provide it. Also create a
    dummy sysvutils package, since Hardy has reverse versioned dependencies
    to it. This needs to be kept until after the next LTS.
  - debian/control: Depend on lsb-base (>= 3.2-14) for status_of_proc()
    function.
  - debian/initscripts/etc/init.d/checkfs.sh: Don't depend on hwclockfirst
    which Ubuntu does not have.
  - debian/initscripts/etc/init.d/mountkernfs.sh: Always mount devpts, and
    do not touch /dev/ptmx (which is already managed by udev).
  - debian/initscripts/etc/init.d/mountkernfs.sh: mount fusectl if it is
    available
  - debian/initscripts/etc/init.d/mountkernfs.sh: mount securityfs if it is
    available. This allows for easier AppArmor confinement of applications
    early in the boot process. LP: #399954
  - debian/initscripts/etc/init.d/mountkernfs.sh: mount debugfs if it is
    available.
  - debian/initscripts/etc/init.d/ondemand: Sleep for 60 seconds, then
    set CPU Frequency Scaling governor to "ondemand".   LP: #341573.
  - debian/initscripts/etc/init.d/umountfs: Don't unmount filesystems
    that precede root or use force for some mountpoints.
  - debian/initscripts/etc/network/if-up.d/mountnfs: Rename ifstate
    file to /var/run/network/ifstate
  - ./debian/initscripts/lib/init/usplash-fsck-functions.sh: Use blkid,
    vol_id is gone.
  - debian/initscripts.{pre,postinst}: waitnfs.sh -> mountnfs.sh renaming
    transition. This needs to be kept until after the next LTS.

LP: #32455, #94120, #160197, #382097 (amongst others).

* debian/sysv-rc/sbin/update-rc.d: Dropped support for "multiuser"
  command-line option.
* debian/rules: Compat symlink from /usr/bin/service to /usr/sbin/service
* debian/initscripts.postinst: Transition from bootlogs.sh to bootlogs

* debian/sysv-rc.postinst: Don't try and use insserv by default, though
  everything's in place for you to try if you like.  It can be activated
  with:
      USEINSSERV=yes dpkg-reconfigure sysv-rc

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 13_doc_telinit.dpatch by Petter Reinholdtsen
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Document -e and -t option in telinit.  Fixes bug #272657.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad --exclude=CVS --exclude=.svn ./man/init.8 /tmp/dpep-work.onJlGf/trunk/man/init.8
9
 
--- ./man/init.8        2006-01-04 11:37:18.000000000 +0100
10
 
+++ /tmp/dpep-work.onJlGf/trunk/man/init.8      2006-01-04 11:37:34.000000000 +0100
11
 
@@ -12,12 +12,15 @@
12
 
 .RB [ " -a " ]
13
 
 .RB [ " -s " ]
14
 
 .RB [ " -b " ]
15
 
-.RB [ " -z xxx " ]
16
 
+[ \fB\-z\fP \fIxxx\fP ]
17
 
 .RB [ " 0123456Ss " ]
18
 
 .br
19
 
 .B /sbin/telinit
20
 
-.RB [ " \-t sec " ]
21
 
+[ \fB\-t\fP \fISECONDS\fP ]
22
 
 .RB [ " 0123456sSQqabcUu " ]
23
 
+.br
24
 
+.B /sbin/telinit
25
 
+[ \fB\-e\fP \fIVAR\fP[\fB=\fP\fIVAL\fP] ]
26
 
 .\"}}}
27
 
 .\"{{{  Description
28
 
 .SH DESCRIPTION
29
 
@@ -155,12 +158,21 @@
30
 
 tell \fBinit\fP to switch to single user mode.
31
 
 .IP "\fBU\fP or \fBu\fP"
32
 
 tell \fBinit\fP to re-execute itself (preserving the state). No re-examining of 
33
 
-\fB/etc/inittab\fP file happens. Run level should be one of \fBSs12345\fP,
34
 
+\fB/etc/inittab\fP file happens. Run level should be one of
35
 
+\fBSs12345\fP
36
 
 otherwise request would be silently ignored.
37
 
 .PP
38
 
-\fBtelinit\fP can also tell \fBinit\fP how long it should wait
39
 
+\fBtelinit\fP can tell \fBinit\fP how long it should wait
40
 
 between sending processes the SIGTERM and SIGKILL signals.  The default
41
 
-is 5 seconds, but this can be changed with the \fB-t sec\fP option.
42
 
+is 5 seconds, but this can be changed with the \fB-t\fP option.
43
 
+.PP
44
 
+\fBtelinit -e\fP tells \fBinit\fP to change the environment
45
 
+for processes it spawns.
46
 
+The argument of \fB-e\fP is either of the form \fIVAR\fP=\fIVAL\fP
47
 
+which sets variable \fIVAR\fP to value \fIVAL\fP,
48
 
+or of the form \fIVAR\fP
49
 
+(without an equality sign)
50
 
+which unsets variable \fIVAR\fP.
51
 
 .PP
52
 
 \fBtelinit\fP can be invoked only by users with appropriate
53
 
 privileges.
54
 
@@ -212,8 +224,8 @@
55
 
 command line manually.
56
 
 .PP
57
 
 .TP 0.5i
58
 
-.B -z xxx
59
 
-The argument to -z is ignored. You can use this to expand the command
60
 
+.BI "-z " xxx
61
 
+The argument to \fB-z\fP is ignored. You can use this to expand the command
62
 
 line a bit, so that it takes some more space on the stack. \fBInit\fP
63
 
 can then manipulate the command line so that \fBps\fP(1) shows
64
 
 the current runlevel.
65
 
diff -urNad --exclude=CVS --exclude=.svn ./src/init.c /tmp/dpep-work.onJlGf/trunk/src/init.c
66
 
--- ./src/init.c        2005-12-02 17:22:57.000000000 +0100
67
 
+++ /tmp/dpep-work.onJlGf/trunk/src/init.c      2006-01-04 11:37:19.000000000 +0100
68
 
@@ -2495,7 +2495,7 @@
69
 
  */
70
 
 void usage(char *s)
71
 
 {
72
 
-       fprintf(stderr, "Usage: %s 0123456SsQqAaBbCcUu\n", s);
73
 
+       fprintf(stderr, "Usage: %s {-e VAR[=VAL] | [-t SECONDS] {0|1|2|3|4|5|6|S|s|Q|q|A|a|B|b|C|c|U|u}}\n", s);
74
 
        exit(1);
75
 
 }
76