~ubuntu-branches/ubuntu/karmic/sysvinit/karmic-updates

« back to all changes in this revision

Viewing changes to debian/patches/fix-minor-warnings

  • Committer: Bazaar Package Importer
  • Author(s): Scott James Remnant
  • Date: 2009-09-07 19:56:53 UTC
  • mfrom: (1.1.4 upstream) (2.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20090907195653-2i6t0j91wfbf1f0d
Tags: 2.87dsf-4ubuntu1
* Merge from debian unstable, remaining changes:
  - Support Cell processor:
    + debian/initscripts/postinst: Create spu system group and /spu mount
      point if we are running on a Cell processor.
    + debian/initscripts/etc/init.d/mountkernfs.sh: Mount spufs if Cell
      processor is detected.
    + debian/initscripts/lib/init/mount-functions.sh: Modprobe spufs
      if not available.
    + debian/control: Add initscripts dependency 'passwd' for groupadd.
    (Forwarded to Debian #483399)
  - Use tmpfs mounts for /var/lock and /var/run:
    + debian/initscripts/share/default.rcS: Enable RAMRUN and RAMLOCK by
      default.
    + debian/initscripts.postinst: Enable RAMRUN and RAMLOCK in
      /etc/default/rcS on upgrades. This needs to be kept until the next
      LTS.
    + debian/initscripts/etc/init.d/mountkernfs.sh: Propagate files from the
      initramfs to our new /var/run, so that we can populate
      /var/run/sendsigs.omit from initramfs.
  - Boot ordering differences:
    + mountkernfs.sh: 02 -> 01
    + mountdevsubfs.sh: 04 -> 11
    + bootlogd: disabled by default
    + checkroot.sh: 10 -> 20
    + mtab.sh: 12 -> 22
  - debian/patches/91_sulogin_lockedpw.dpatch: Disable "root account is
    locked" warning, since this is the default in Ubuntu. Document this in
    sulogin.8.
  - debian/control: Drop Essential: yes from packages since we use Upstart.
  - debian/control: Conflict/Replace sysvconfig which has also previously
    provided service(8).
  - debian/control, debian/rules: Previous name for sysvinit-utils was
    'sysvutils' in Ubuntu, so Conflict/Replace/Provide it. Also create a
    dummy sysvutils package, since Hardy has reverse versioned dependencies
    to it. This needs to be kept until after the next LTS.
  - debian/control: Depend on lsb-base (>= 3.2-14) for status_of_proc()
    function.
  - debian/initscripts/etc/init.d/checkfs.sh: Don't depend on hwclockfirst
    which Ubuntu does not have.
  - debian/initscripts/etc/init.d/mountkernfs.sh: Always mount devpts, and
    do not touch /dev/ptmx (which is already managed by udev).
  - debian/initscripts/etc/init.d/mountkernfs.sh: mount fusectl if it is
    available
  - debian/initscripts/etc/init.d/mountkernfs.sh: mount securityfs if it is
    available. This allows for easier AppArmor confinement of applications
    early in the boot process. LP: #399954
  - debian/initscripts/etc/init.d/mountkernfs.sh: mount debugfs if it is
    available.
  - debian/initscripts/etc/init.d/ondemand: Sleep for 60 seconds, then
    set CPU Frequency Scaling governor to "ondemand".   LP: #341573.
  - debian/initscripts/etc/init.d/umountfs: Don't unmount filesystems
    that precede root or use force for some mountpoints.
  - debian/initscripts/etc/network/if-up.d/mountnfs: Rename ifstate
    file to /var/run/network/ifstate
  - ./debian/initscripts/lib/init/usplash-fsck-functions.sh: Use blkid,
    vol_id is gone.
  - debian/initscripts.{pre,postinst}: waitnfs.sh -> mountnfs.sh renaming
    transition. This needs to be kept until after the next LTS.

LP: #32455, #94120, #160197, #382097 (amongst others).

* debian/sysv-rc/sbin/update-rc.d: Dropped support for "multiuser"
  command-line option.
* debian/rules: Compat symlink from /usr/bin/service to /usr/sbin/service
* debian/initscripts.postinst: Transition from bootlogs.sh to bootlogs

* debian/sysv-rc.postinst: Don't try and use insserv by default, though
  everything's in place for you to try if you like.  It can be activated
  with:
      USEINSSERV=yes dpkg-reconfigure sysv-rc

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: src/last.c
2
 
===================================================================
3
 
--- src/last.c  (revision 290)
4
 
+++ src/last.c  (working copy)
5
 
@@ -320,7 +320,7 @@
6
 
         *
7
 
         *      Ugly.
8
 
         */
9
 
-       if (a[0] == 0 && a[1] == 0 && a[2] == htonl (0xffff))
10
 
+       if (a[0] == 0 && a[1] == 0 && a[2] == (int32_t)htonl (0xffff))
11
 
                mapped = 1;
12
 
        topnibble = ntohl((unsigned int)a[0]) >> 28;
13
 
        if (topnibble < 2 || topnibble > 3 || mapped ||
14
 
@@ -436,7 +436,7 @@
15
 
                r = dns_lookup(domain, sizeof(domain), useip, p->ut_addr_v6);
16
 
        if (r < 0) {
17
 
                len = UT_HOSTSIZE;
18
 
-               if (len >= sizeof(domain)) len = sizeof(domain) - 1;
19
 
+               if (len >= (int)sizeof(domain)) len = sizeof(domain) - 1;
20
 
                domain[0] = 0;
21
 
                strncat(domain, p->ut_host, len);
22
 
        }
23
 
Index: src/init.c
24
 
===================================================================
25
 
--- src/init.c  (revision 290)
26
 
+++ src/init.c  (working copy)
27
 
@@ -561,7 +561,8 @@
28
 
         *      Find out which process(es) this was (were)
29
 
         */
30
 
        while((pid = waitpid(-1, &st, WNOHANG)) != 0) {
31
 
-               if (errno == ECHILD) break;
32
 
+               if (errno == ECHILD)
33
 
+                       break;
34
 
                for( ch = family; ch; ch = ch->next )
35
 
                        if ( ch->pid == pid && (ch->flags & RUNNING) ) {
36
 
                                INITDBG(L_VB,
37
 
@@ -576,9 +577,10 @@
38
 
                                }
39
 
                                break;
40
 
                        }
41
 
-               if (ch == NULL)
42
 
+               if (ch == NULL) {
43
 
                        INITDBG(L_VB, "chld_handler: unknown child %d exited.",
44
 
                                pid);
45
 
+               }
46
 
        }
47
 
        errno = saved_errno;
48
 
 }
49
 
@@ -1237,7 +1239,7 @@
50
 
        strncpy(ch->id, id, sizeof(utproto.ut_id) + 1); /* Hack for different libs. */
51
 
        strncpy(ch->process, process, sizeof(ch->process) - 1);
52
 
        if (rlevel[0]) {
53
 
-               for(f = 0; f < sizeof(rlevel) - 1 && rlevel[f]; f++) {
54
 
+               for(f = 0; f < (int)sizeof(rlevel)-1 && rlevel[f]; f++) {
55
 
                        ch->rlevel[f] = rlevel[f];
56
 
                        if (ch->rlevel[f] == 's') ch->rlevel[f] = 'S';
57
 
                }
58
 
Index: src/bootlogd.c
59
 
===================================================================
60
 
--- src/bootlogd.c      (revision 290)
61
 
+++ src/bootlogd.c      (working copy)
62
 
@@ -123,7 +123,7 @@
63
 
                fprintf(stderr, "bootlogd: cannot find console device "
64
 
                        "%d:%d in /dev\n", major(dev), minor(dev));
65
 
                r = -1;
66
 
-       } else if (strlen(ent->d_name) + 5 >= rlen) {
67
 
+       } else if ((int)strlen(ent->d_name) + 5 >= rlen) {
68
 
                fprintf(stderr, "bootlogd: console device name too long\n");
69
 
                r = -1;
70
 
        } else
71
 
@@ -341,7 +341,7 @@
72
 
                                break;
73
 
                        case '\t':
74
 
                                line.pos += (line.pos / 8 + 1) * 8;
75
 
-                               if (line.pos >= sizeof(line.buf))
76
 
+                               if (line.pos >= (int)sizeof(line.buf))
77
 
                                        line.pos = sizeof(line.buf) - 1;
78
 
                                break;
79
 
                        case  32 ... 127:
80
 
@@ -357,7 +357,7 @@
81
 
                len--;
82
 
 
83
 
                tlen = strlen(tmp);
84
 
-               if (tlen && (line.pos + tlen < sizeof(line.buf))) {
85
 
+               if (tlen && (line.pos + tlen < (int)sizeof(line.buf))) {
86
 
                        memcpy(line.buf + line.pos, tmp, tlen);
87
 
                        line.pos += tlen;
88
 
                }
89
 
@@ -609,7 +609,7 @@
90
 
                else
91
 
                        todo = endptr - outptr;
92
 
                if (fp && todo)
93
 
-                       writelog(fp, outptr, todo);
94
 
+                       writelog(fp, (unsigned char *)outptr, todo);
95
 
        }
96
 
 
97
 
        if (fp) {
98
 
Index: src/shutdown.c
99
 
===================================================================
100
 
--- src/shutdown.c      (revision 290)
101
 
+++ src/shutdown.c      (working copy)
102
 
@@ -141,7 +141,7 @@
103
 
        nl = strlen(name);
104
 
        vl = value ? strlen(value) : 0;
105
 
 
106
 
-       if (nl + vl + 3 >= sizeof(request.i.data))
107
 
+       if (nl + vl + 3 >= (int)sizeof(request.i.data))
108
 
                return -1;
109
 
 
110
 
        memcpy(request.i.data, name, nl);
111
 
Index: src/sulogin.c
112
 
===================================================================
113
 
--- src/sulogin.c       (revision 290)
114
 
+++ src/sulogin.c       (working copy)
115
 
@@ -275,7 +275,7 @@
116
 
        if (read(0, pass, sizeof(pass) - 1) <= 0)
117
 
                ret = NULL;
118
 
        else {
119
 
-               for(i = 0; i < sizeof(pass) && pass[i]; i++)
120
 
+               for(i = 0; i < (int)sizeof(pass) && pass[i]; i++)
121
 
                        if (pass[i] == '\r' || pass[i] == '\n') {
122
 
                                pass[i] = 0;
123
 
                                break;