~ubuntu-branches/ubuntu/karmic/sysvinit/karmic-updates

« back to all changes in this revision

Viewing changes to debian/patches/71_wall_hostname.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Scott James Remnant
  • Date: 2009-09-07 19:56:53 UTC
  • mfrom: (1.1.4 upstream) (2.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20090907195653-2i6t0j91wfbf1f0d
Tags: 2.87dsf-4ubuntu1
* Merge from debian unstable, remaining changes:
  - Support Cell processor:
    + debian/initscripts/postinst: Create spu system group and /spu mount
      point if we are running on a Cell processor.
    + debian/initscripts/etc/init.d/mountkernfs.sh: Mount spufs if Cell
      processor is detected.
    + debian/initscripts/lib/init/mount-functions.sh: Modprobe spufs
      if not available.
    + debian/control: Add initscripts dependency 'passwd' for groupadd.
    (Forwarded to Debian #483399)
  - Use tmpfs mounts for /var/lock and /var/run:
    + debian/initscripts/share/default.rcS: Enable RAMRUN and RAMLOCK by
      default.
    + debian/initscripts.postinst: Enable RAMRUN and RAMLOCK in
      /etc/default/rcS on upgrades. This needs to be kept until the next
      LTS.
    + debian/initscripts/etc/init.d/mountkernfs.sh: Propagate files from the
      initramfs to our new /var/run, so that we can populate
      /var/run/sendsigs.omit from initramfs.
  - Boot ordering differences:
    + mountkernfs.sh: 02 -> 01
    + mountdevsubfs.sh: 04 -> 11
    + bootlogd: disabled by default
    + checkroot.sh: 10 -> 20
    + mtab.sh: 12 -> 22
  - debian/patches/91_sulogin_lockedpw.dpatch: Disable "root account is
    locked" warning, since this is the default in Ubuntu. Document this in
    sulogin.8.
  - debian/control: Drop Essential: yes from packages since we use Upstart.
  - debian/control: Conflict/Replace sysvconfig which has also previously
    provided service(8).
  - debian/control, debian/rules: Previous name for sysvinit-utils was
    'sysvutils' in Ubuntu, so Conflict/Replace/Provide it. Also create a
    dummy sysvutils package, since Hardy has reverse versioned dependencies
    to it. This needs to be kept until after the next LTS.
  - debian/control: Depend on lsb-base (>= 3.2-14) for status_of_proc()
    function.
  - debian/initscripts/etc/init.d/checkfs.sh: Don't depend on hwclockfirst
    which Ubuntu does not have.
  - debian/initscripts/etc/init.d/mountkernfs.sh: Always mount devpts, and
    do not touch /dev/ptmx (which is already managed by udev).
  - debian/initscripts/etc/init.d/mountkernfs.sh: mount fusectl if it is
    available
  - debian/initscripts/etc/init.d/mountkernfs.sh: mount securityfs if it is
    available. This allows for easier AppArmor confinement of applications
    early in the boot process. LP: #399954
  - debian/initscripts/etc/init.d/mountkernfs.sh: mount debugfs if it is
    available.
  - debian/initscripts/etc/init.d/ondemand: Sleep for 60 seconds, then
    set CPU Frequency Scaling governor to "ondemand".   LP: #341573.
  - debian/initscripts/etc/init.d/umountfs: Don't unmount filesystems
    that precede root or use force for some mountpoints.
  - debian/initscripts/etc/network/if-up.d/mountnfs: Rename ifstate
    file to /var/run/network/ifstate
  - ./debian/initscripts/lib/init/usplash-fsck-functions.sh: Use blkid,
    vol_id is gone.
  - debian/initscripts.{pre,postinst}: waitnfs.sh -> mountnfs.sh renaming
    transition. This needs to be kept until after the next LTS.

LP: #32455, #94120, #160197, #382097 (amongst others).

* debian/sysv-rc/sbin/update-rc.d: Dropped support for "multiuser"
  command-line option.
* debian/rules: Compat symlink from /usr/bin/service to /usr/sbin/service
* debian/initscripts.postinst: Transition from bootlogs.sh to bootlogs

* debian/sysv-rc.postinst: Don't try and use insserv by default, though
  everything's in place for you to try if you like.  It can be activated
  with:
      USEINSSERV=yes dpkg-reconfigure sysv-rc

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 71_wall_hostname.dpatch by Petter Reinholdtsen
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Include hostname in output from halt.  Closes debian bug
6
 
## DP: #325772.
7
 
 
8
 
@DPATCH@
9
 
Index: sysvinit/src/dowall.c
10
 
===================================================================
11
 
--- sysvinit/src/dowall.c       (revisjon 100)
12
 
+++ sysvinit/src/dowall.c       (arbeidskopi)
13
 
@@ -131,6 +131,7 @@
14
 
        time_t                  t;
15
 
        char                    term[UT_LINESIZE+6];
16
 
        char                    line[81];
17
 
+       char                    hostname[256]; /* HOST_NAME_MAX+1 */
18
 
        char                    *date, *p;
19
 
        char                    *user, *tty;
20
 
        int                     fd, flags;
21
 
@@ -144,6 +145,16 @@
22
 
 
23
 
        getuidtty(&user, &tty);
24
 
 
25
 
+       /* Get and report current hostname, to make it easier to find
26
 
+          out which machine is being shut down. */
27
 
+       if (0 != gethostname(hostname, sizeof(hostname))) {
28
 
+               strncpy(hostname, "[unknown]", sizeof(hostname)-1);
29
 
+       }
30
 
+       /* If hostname is truncated, it is unspecified if the string
31
 
+          is null terminated or not.  Make sure we know it is null
32
 
+          terminated. */
33
 
+       hostname[sizeof(hostname)-1] = 0;
34
 
+
35
 
        /* Get the time */
36
 
        time(&t);
37
 
        date = ctime(&t);
38
 
@@ -157,8 +168,8 @@
39
 
                        date);
40
 
        } else {
41
 
                snprintf(line, sizeof(line),
42
 
-                       "\007\r\nBroadcast message from %s %s(%s):\r\n\r\n",
43
 
-                       user, tty, date);
44
 
+                       "\007\r\nBroadcast message from %s@%s %s(%s):\r\n\r\n",
45
 
+                       user, hostname, tty, date);
46
 
        }
47
 
 
48
 
        /*