~ubuntu-branches/ubuntu/karmic/sysvinit/karmic-updates

« back to all changes in this revision

Viewing changes to debian/patches/30_strip.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Scott James Remnant
  • Date: 2009-09-07 19:56:53 UTC
  • mfrom: (1.1.4 upstream) (2.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20090907195653-2i6t0j91wfbf1f0d
Tags: 2.87dsf-4ubuntu1
* Merge from debian unstable, remaining changes:
  - Support Cell processor:
    + debian/initscripts/postinst: Create spu system group and /spu mount
      point if we are running on a Cell processor.
    + debian/initscripts/etc/init.d/mountkernfs.sh: Mount spufs if Cell
      processor is detected.
    + debian/initscripts/lib/init/mount-functions.sh: Modprobe spufs
      if not available.
    + debian/control: Add initscripts dependency 'passwd' for groupadd.
    (Forwarded to Debian #483399)
  - Use tmpfs mounts for /var/lock and /var/run:
    + debian/initscripts/share/default.rcS: Enable RAMRUN and RAMLOCK by
      default.
    + debian/initscripts.postinst: Enable RAMRUN and RAMLOCK in
      /etc/default/rcS on upgrades. This needs to be kept until the next
      LTS.
    + debian/initscripts/etc/init.d/mountkernfs.sh: Propagate files from the
      initramfs to our new /var/run, so that we can populate
      /var/run/sendsigs.omit from initramfs.
  - Boot ordering differences:
    + mountkernfs.sh: 02 -> 01
    + mountdevsubfs.sh: 04 -> 11
    + bootlogd: disabled by default
    + checkroot.sh: 10 -> 20
    + mtab.sh: 12 -> 22
  - debian/patches/91_sulogin_lockedpw.dpatch: Disable "root account is
    locked" warning, since this is the default in Ubuntu. Document this in
    sulogin.8.
  - debian/control: Drop Essential: yes from packages since we use Upstart.
  - debian/control: Conflict/Replace sysvconfig which has also previously
    provided service(8).
  - debian/control, debian/rules: Previous name for sysvinit-utils was
    'sysvutils' in Ubuntu, so Conflict/Replace/Provide it. Also create a
    dummy sysvutils package, since Hardy has reverse versioned dependencies
    to it. This needs to be kept until after the next LTS.
  - debian/control: Depend on lsb-base (>= 3.2-14) for status_of_proc()
    function.
  - debian/initscripts/etc/init.d/checkfs.sh: Don't depend on hwclockfirst
    which Ubuntu does not have.
  - debian/initscripts/etc/init.d/mountkernfs.sh: Always mount devpts, and
    do not touch /dev/ptmx (which is already managed by udev).
  - debian/initscripts/etc/init.d/mountkernfs.sh: mount fusectl if it is
    available
  - debian/initscripts/etc/init.d/mountkernfs.sh: mount securityfs if it is
    available. This allows for easier AppArmor confinement of applications
    early in the boot process. LP: #399954
  - debian/initscripts/etc/init.d/mountkernfs.sh: mount debugfs if it is
    available.
  - debian/initscripts/etc/init.d/ondemand: Sleep for 60 seconds, then
    set CPU Frequency Scaling governor to "ondemand".   LP: #341573.
  - debian/initscripts/etc/init.d/umountfs: Don't unmount filesystems
    that precede root or use force for some mountpoints.
  - debian/initscripts/etc/network/if-up.d/mountnfs: Rename ifstate
    file to /var/run/network/ifstate
  - ./debian/initscripts/lib/init/usplash-fsck-functions.sh: Use blkid,
    vol_id is gone.
  - debian/initscripts.{pre,postinst}: waitnfs.sh -> mountnfs.sh renaming
    transition. This needs to be kept until after the next LTS.

LP: #32455, #94120, #160197, #382097 (amongst others).

* debian/sysv-rc/sbin/update-rc.d: Dropped support for "multiuser"
  command-line option.
* debian/rules: Compat symlink from /usr/bin/service to /usr/sbin/service
* debian/initscripts.postinst: Transition from bootlogs.sh to bootlogs

* debian/sysv-rc.postinst: Don't try and use insserv by default, though
  everything's in place for you to try if you like.  It can be activated
  with:
      USEINSSERV=yes dpkg-reconfigure sysv-rc

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 30_strip.dpatch by Petter Reinholdtsten
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Make sure installed binaries are stripped.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad --exclude=CVS --exclude=.svn ./src/Makefile /tmp/dpep-work.wBpMdg/trunk/src/Makefile
9
 
--- ./src/Makefile      2005-12-19 22:45:14.000000000 +0100
10
 
+++ /tmp/dpep-work.wBpMdg/trunk/src/Makefile    2005-12-20 01:07:14.000000000 +0100
11
 
@@ -46,7 +46,9 @@
12
 
 BIN_OWNER      = root
13
 
 BIN_GROUP      = root
14
 
 BIN_COMBO      = $(BIN_OWNER):$(BIN_GROUP)
15
 
-INSTALL                = install -o $(BIN_OWNER) -g $(BIN_GROUP)
16
 
+STRIP          = strip -s -R .comment
17
 
+INSTALL_EXEC   = install -o $(BIN_OWNER) -g $(BIN_GROUP) -m 755
18
 
+INSTALL_DATA   = install -o $(BIN_OWNER) -g $(BIN_GROUP) -m 644
19
 
 MANDIR         = /usr/share/man
20
 
 
21
 
 # Additional libs for GNU libc.
22
 
@@ -111,15 +113,18 @@
23
 
 
24
 
 install:
25
 
                for i in $(BIN); do \
26
 
-                       $(INSTALL) -m 755 $$i $(ROOT)/bin/; \
27
 
+                       $(STRIP) $$i ; \
28
 
+                       $(INSTALL_EXEC) $$i $(ROOT)/bin/ ; \
29
 
                done
30
 
                for i in $(SBIN); do \
31
 
-                       $(INSTALL) -m 755 $$i $(ROOT)/sbin/; \
32
 
+                       $(STRIP) $$i ; \
33
 
+                       $(INSTALL_EXEC) $$i $(ROOT)/sbin/ ; \
34
 
                done
35
 
                for i in $(USRBIN); do \
36
 
-                       $(INSTALL) -m 755 $$i $(ROOT)/usr/bin/; \
37
 
+                       $(STRIP) $$i ; \
38
 
+                       $(INSTALL_EXEC) $$i $(ROOT)/usr/bin/ ; \
39
 
                done
40
 
-               # $(INSTALL) -m 755 etc/initscript.sample $(ROOT)/etc/
41
 
+               # $(INSTALL_EXEC) etc/initscript.sample $(ROOT)/etc/
42
 
                ln -sf halt $(ROOT)/sbin/reboot
43
 
                ln -sf halt $(ROOT)/sbin/poweroff
44
 
                ln -sf init $(ROOT)/sbin/telinit
45
 
@@ -127,15 +132,15 @@
46
 
                if [ ! -f $(ROOT)/usr/bin/lastb ]; then \
47
 
                        ln -sf last $(ROOT)/usr/bin/lastb; \
48
 
                fi
49
 
-               $(INSTALL) -m 644 initreq.h $(ROOT)/usr/include/
50
 
+               $(INSTALL_DATA) initreq.h $(ROOT)/usr/include/
51
 
                for i in $(MAN1); do \
52
 
-                       $(INSTALL) -m 644 ../man/$$i $(ROOT)$(MANDIR)/man1/; \
53
 
+                       $(INSTALL_DATA) ../man/$$i $(ROOT)$(MANDIR)/man1/; \
54
 
                done
55
 
                for i in $(MAN5); do \
56
 
-                       $(INSTALL) -m 644 ../man/$$i $(ROOT)$(MANDIR)/man5/; \
57
 
+                       $(INSTALL_DATA) ../man/$$i $(ROOT)$(MANDIR)/man5/; \
58
 
                done
59
 
                for i in $(MAN8); do \
60
 
-                       $(INSTALL) -m 644 ../man/$$i $(ROOT)$(MANDIR)/man8/; \
61
 
+                       $(INSTALL_DATA) ../man/$$i $(ROOT)$(MANDIR)/man8/; \
62
 
                done
63
 
 ifeq ($(ROOT),)
64
 
                #